update of Qt - Slackware

This is a discussion on update of Qt - Slackware ; I'm copilling QtiPlot, but that requires Qt>=4.2. I found a package for slack12.0 on linuxpackages.net but i'm wondering whether i should even upgrade dbus-qt. And any other probably depending on Qt. this question for advanced people i think. -- heavytull...

+ Reply to Thread
Results 1 to 11 of 11

Thread: update of Qt

  1. update of Qt

    I'm copilling QtiPlot, but that requires Qt>=4.2. I found a package for
    slack12.0 on linuxpackages.net but i'm wondering whether i should even upgrade
    dbus-qt. And any other probably depending on Qt.
    this question for advanced people i think.

    --
    heavytull

  2. Re: update of Qt

    On Sun, 23 Dec 2007 17:04:15 +0100, heavytull wrote:

    > I'm copilling QtiPlot, but that requires Qt>=4.2. I found a package for
    > slack12.0 on linuxpackages.net but i'm wondering whether i should even upgrade
    > dbus-qt.


    If you do you'll have a borked system. Probably unrecoverably borked.


    --
    "Ubuntu" -- an African word, meaning "Slackware is too hard for me".


  3. Re: update of Qt

    On Sun, 23 Dec 2007 17:04:15 +0100, heavytull wrote:

    > I'm copilling QtiPlot, but that requires Qt>=4.2. I found a package for
    > slack12.0 on linuxpackages.net but i'm wondering whether i should even
    > upgrade dbus-qt. And any other probably depending on Qt. this question
    > for advanced people i think.


    just install qt4, that is enough, I've done the same, and qtiplot 0.9.3-
    rc2 works here. By default qt4 goes into /usr/local/Trolltech/Qt-4.x.y/,
    so you'll have to call qmake with /usr/local/Trolltech/Qt-4.x.y/bin/qmake
    in order for qtiplot to use this version of qt. Also, I've put
    /usr/local/Trolltech/Qt-4.3.2/lib/
    as the last line in /etc/ld.so.conf, but I'm not sure if that was
    important for running qtiplot, or it was for some other qt4 program which
    was looking for the qt4 libs.
    BTW, you will also need to compile qwt and qwtplot3d with qt4 in you want
    to compile your version of qtiplot.

    --
    i.

  4. Re: update of Qt

    Ivan Rajkovic wrote:

    > On Sun, 23 Dec 2007 17:04:15 +0100, heavytull wrote:
    >
    >> I'm copilling QtiPlot, but that requires Qt>=4.2. I found a package for
    >> slack12.0 on linuxpackages.net but i'm wondering whether i should even
    >> upgrade dbus-qt. And any other probably depending on Qt. this question
    >> for advanced people i think.

    >
    > just install qt4, that is enough, I've done the same, and qtiplot 0.9.3-
    > rc2 works here. By default qt4 goes into /usr/local/Trolltech/Qt-4.x.y/,

    even the slackware package on linuxpackages.net?


    --
    heavytull

  5. Re: update of Qt

    On Sun, 23 Dec 2007 18:20:48 +0100, heavytull wrote:

    > Ivan Rajkovic wrote:
    >
    >> On Sun, 23 Dec 2007 17:04:15 +0100, heavytull wrote:
    >>
    >>> I'm copilling QtiPlot, but that requires Qt>=4.2. I found a package
    >>> for slack12.0 on linuxpackages.net but i'm wondering whether i should
    >>> even upgrade dbus-qt. And any other probably depending on Qt. this
    >>> question for advanced people i think.

    >>
    >> just install qt4, that is enough, I've done the same, and qtiplot
    >> 0.9.3- rc2 works here. By default qt4 goes into
    >> /usr/local/Trolltech/Qt-4.x.y/,

    > even the slackware package on linuxpackages.net?



    don't know, i compiled qt4 myself. the point is just to start qmake with
    the full path to the qt4 version, wherever it is.
    and, just to say, i didn't deinstall qt3, i'm not sure if you're planning
    on doing that, but i guess that would kill all other qt programs,
    including kde.


    --
    i.

  6. Re: update of Qt


    heavytull@hotmail.com wrote :

    > even the slackware package on linuxpackages.net?


    It looks like they are made to replace Qt-3 and this will ruin KDE-3.
    --
    Thomas O.

    This area is designed to become quite warm during normal operation.

  7. Re: update of Qt

    On Sun, 23 Dec 2007 20:05:22 +0100, Thomas Overgaard wrote:

    > heavytull@hotmail.com wrote :
    >
    >> even the slackware package on linuxpackages.net?

    >
    > It looks like they are made to replace Qt-3 and this will ruin KDE-3.


    Why not try slackbuilds.org? It co-exists with qt3 quite nicely:
    http://slackbuilds.org/repository/12.0/libraries/qt4/


    Paul

  8. Re: update of Qt

    Thomas Overgaard wrote:

    >
    > heavytull@hotmail.com wrote :
    >
    >> even the slackware package on linuxpackages.net?

    >
    > It looks like they are made to replace Qt-3 and this will ruin KDE-3.


    actually i configured Qt to build and install the binaries in a dir called
    build/ under the source dir.
    and it worked nicely.

    now i need to compile qwt and qwtplot3d and finally qtiplot against this version
    of Qt.

    I edited the qwt.pro and the Makefile, i'm trying to do that but i'm not sure
    how to do.


    --
    heavytull

  9. Re: update of Qt



    heavytull wrote:

    > Thomas Overgaard wrote:
    >
    >>
    >> heavytull@hotmail.com wrote :
    >>
    >>> even the slackware package on linuxpackages.net?

    >>
    >> It looks like they are made to replace Qt-3 and this will ruin KDE-3.

    >
    > actually i configured Qt to build and install the binaries in a dir called
    > build/ under the source dir.
    > and it worked nicely.
    >
    > now i need to compile qwt and qwtplot3d and finally qtiplot against this
    > version of Qt.
    >
    > I edited the qwt.pro and the Makefile, i'm trying to do that but i'm not sure
    > how to do.
    >
    >

    root@slack12:/usr/src/QtiPlot-qwt-qwtplot3d-gsl-muparser-liboriginiPlot/qwt-5.\
    0.2# ../qt-x11-opensource-src-4.3.3/bin/qmake
    QMAKESPEC has not been set, so configuration cannot be deduced.
    Error processing project
    file: /usr/src/QtiPlot-qwt-qwtplot3d-gsl-muparser-liboriginiPlot/qwt-5.0.2/qwt\
    ..pro

    --
    heavytull

  10. Re: update of Qt


    heavytull@hotmail.com wrote :

    > now i need to compile qwt and qwtplot3d and finally qtiplot against
    > this version of Qt.


    Don't know about qwt and qwtplot3d but KDE programs usually has a option
    in configure named --with-qt-dir=/foo/bar/qt. Run 'configure --help' to
    see if this is possible here.
    --
    Thomas O.

    This area is designed to become quite warm during normal operation.

  11. Re: update of Qt

    On Mon, 24 Dec 2007 08:28:52 +0000, Mr Paul wrote:

    >>> even the slackware package on linuxpackages.net?

    >> It looks like they are made to replace Qt-3 and this will ruin KDE-3.

    > Why not try slackbuilds.org? It co-exists with qt3 quite nicely:
    > http://slackbuilds.org/repository/12.0/libraries/qt4/


    so does slacky.eu version

+ Reply to Thread