hplip >=1.7.4a + cups bugs or miscompile? - Slackware

This is a discussion on hplip >=1.7.4a + cups bugs or miscompile? - Slackware ; Hello, I tried to compile the hplip-2.7.9 with Pat's SlackBuild. ../configure \ --prefix=/usr \ --sysconfdir=/etc \ --localstatedir=/var \ --enable-network-build=yes \ --enable-foomatic-ppd-install \ --disable-xml-install \ --build=$ARCH-slackware-linux \ --host=$ARCH-slackware-linux \ Restarted hplip and cups but I can't print hp-check (tool from hplip) ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: hplip >=1.7.4a + cups bugs or miscompile?

  1. hplip >=1.7.4a + cups bugs or miscompile?

    Hello,

    I tried to compile the hplip-2.7.9 with Pat's SlackBuild.
    ../configure \
    --prefix=/usr \
    --sysconfdir=/etc \
    --localstatedir=/var \
    --enable-network-build=yes \
    --enable-foomatic-ppd-install \ <--- added this
    --disable-xml-install \ <--- and this (hplip.sf.net)
    --build=$ARCH-slackware-linux \
    --host=$ARCH-slackware-linux \

    Restarted hplip and cups but I can't print

    hp-check (tool from hplip) is says everything is ok.
    hp-testpage not working although says "testpage sent"

    Printer is ok, since it works with ubuntu (hplip-1.7.3)
    and previous version of Slack.

    To my understanding the problem is with hpiod, since the script
    /etc/rc.d/rc.hplip start informs that hpssd is stardted but not hpiod

    AND
    /etc/rc.d/rc.hplip status says that NOTHING is started :?

    In tree source-hplip-2.7.9 | grep hpiod there is NO hpiod

    Any ideas?

    Should I fill a buf report to hplip, cups or... both?

    (scanner and card reader are working, the machine is PhotoSmart C3180)
    --
    Please excuse my english writing!
    Slackware 12
    Knowledge report: One and 1/2 year, still plenty to learn


  2. Re: hplip >=1.7.4a + cups bugs or miscompile?


    korgman wrote :

    > In tree source-hplip-2.7.9 | grep hpiod there is NO hpiod


    From:

    HPLIP 2.7.6 - This release has the following changes.

    2. Replaced hpiod with the new HP Multi-Point Transport Driver
    (hpmud). Hpmud is a shared library instead of a daemon.
    --
    Thomas O.

    This area is designed to become quite warm during normal operation.

  3. Re: hplip >=1.7.4a + cups bugs or miscompile?

    On 2007-10-06, Thomas Overgaard wrote:
    > From:
    >
    > HPLIP 2.7.6 - This release has the following changes.
    >
    > 2. Replaced hpiod with the new HP Multi-Point Transport Driver
    > (hpmud). Hpmud is a shared library instead of a daemon.


    Thank you, din't noticed, but still I don't undertand if I need
    to start some deamon or not.

    Also, I forgot to mention that I have problem also with
    the Slackware-12 hplip-1.7.4a for that reason I thought the
    upgrade.

    So, this is a bug? Or a mistake by me? Anyone managed to work
    with latest hplip and Photosmart C3180? (c 3100 series)

    I will try to downgrade with hplip from Slackware-11
    --
    Please excuse my english writing!
    Slackware 12
    Knowledge report: One and 1/2 year, still plenty to learn

  4. Re: hplip >=1.7.4a + cups bugs or miscompile?


    korgman wrote :

    > Thank you, din't noticed, but still I don't undertand if I need
    > to start some deamon or not.


    Did you configure your printer by running 'hp-setup' as root?:

    --
    Thomas O.

    This area is designed to become quite warm during normal operation.

  5. Re: hplip >=1.7.4a + cups bugs or miscompile?

    On 2007-10-06, korgman wrote:
    >
    > Should I fill a buf report to hplip, cups or... both?
    >
    > (scanner and card reader are working, the machine is PhotoSmart C3180)



    I think you'll find the information in here useful:
    http://rlworkman.net/pkgs/12.0/TESTING/

    RW

+ Reply to Thread