d-bus and bluetooth question - Slackware

This is a discussion on d-bus and bluetooth question - Slackware ; Hi all! I have a problem that I've been trying to solve for a while now. I use two bluetooth earphones to my computer (one at a time!) Normally I use btsco and it works as I want it to ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: d-bus and bluetooth question

  1. d-bus and bluetooth question

    Hi all!
    I have a problem that I've been trying to solve for a while now.
    I use two bluetooth earphones to my computer (one at a time!) Normally I use
    btsco and it works as I want it to sometimes, sometimes not. Same computer
    same configuration One day it works the other day it doesn't.

    snd-bt-sco loads as it should when starting.

    When it doesn't work I get this error:

    'Can't connect to RFCOMM channel: Operation now in progress'
    And btsco stop and nothing more happens.

    I use the same passkey for both so that shouldn't be a problem.? Or should
    it? Default is 0000 on all BT things I tried so far. And I have no reason
    to change it.


    My hcid.conf looks like this :

    options {
    autoinit yes;
    security auto;
    pairing multi;
    passkey "0000";
    }

    device {
    name "BlueZ (%d)";
    class 0xff0104
    lm master;
    # master since I use the computer as the master device.
    lp hold,park;
    }


    Ok this his how the rfcomm.conf looks like :

    rfcomm0 {
    bind yes;
    device 01:12:5B:32:16:54;
    channel 1;
    comment "StereoEarphone";
    }
    rfcomm1 {
    bind yes;
    device 00:14:21:00:58:F3;
    channel 2;
    comment "MonoEarphone";
    }


    Anyone got any idea of where I can find more info about this I would be
    grateful. I have searched all over for a solution and followed the few I
    found and made it work for a day,then it stops.

    Cheers!
    // Mussemouse

  2. Re: d-bus and bluetooth question

    Mussemouse wrote:

    > Hi all!
    > I have a problem that I've been trying to solve for a while now.
    > I use two bluetooth earphones to my computer (one at a time!) Normally I
    > use btsco and it works as I want it to sometimes, sometimes not. Same
    > computer same configuration One day it works the other day it doesn't.
    >
    > snd-bt-sco loads as it should when starting.
    >
    > When it doesn't work I get this error:
    >
    > 'Can't connect to RFCOMM channel: Operation now in progress'
    > And btsco stop and nothing more happens.
    >
    > I use the same passkey for both so that shouldn't be a problem.? Or should
    > it? Default is 0000 on all BT things I tried so far. And I have no reason
    > to change it.
    > snipp>
    >
    > Anyone got any idea of where I can find more info about this I would be
    > grateful. I have searched all over for a solution and followed the few I
    > found and made it work for a day,then it stops.


    Well. Got it working again. Then it stopped once again. It seems to have
    something to do with pairing.. Not sure though.
    I do like this :
    /usr/sbin/hciconfig hci0 auth
    /usr/bin/passkey-agent 0000 &
    /usr/local/bin btsco -v -f
    Gets the error msg
    Can't get on the bus.!!!

    I am confused,

    //Mussemouse


+ Reply to Thread