Slack 11 no sound from KDE - Slackware

This is a discussion on Slack 11 no sound from KDE - Slackware ; I installed Slackware 11 on my system. There are 2 soundcards: the onboard is disabled in the bios and the pci card works fine from non KDE applications (firefox, mplayer, xmms, etc.) I uninstalled arts and compiled the latest kernel ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Slack 11 no sound from KDE

  1. Slack 11 no sound from KDE

    I installed Slackware 11 on my system. There are 2 soundcards: the
    onboard is disabled in the bios and the pci card works fine from non
    KDE applications (firefox, mplayer, xmms, etc.) I uninstalled arts and
    compiled the latest kernel with Alsa support (and OSS emulation). I
    have an .asound.conf file in ~ so I can use dmix. No sound from KDE
    Apps or Notifications. There are no error messages or anything in the
    logs that refer to the problem. I tried the same things as root and
    still no sound from KDE, but there is sound from non KDE apps. I can
    play a sound from the command line using aplay but if I tell KDE to
    use aplay in the System Notifications I get nothing.

    Any help is appreciated.


  2. Re: Slack 11 no sound from KDE


    monkeyfunky@gmail.com wrote :

    > No sound from KDE Apps or Notifications.


    Thats because KDE depends on the aRts sound system and ALSA cannot
    replace aRts.
    --
    Thomas O.

    This area is designed to become quite warm during normal operation.

  3. Re: Slack 11 no sound from KDE

    On 2007-06-26, Thomas Overgaard wrote:
    >
    > monkeyfunky@gmail.com wrote :
    >
    >> No sound from KDE Apps or Notifications.

    >
    > Thats because KDE depends on the aRts sound system and ALSA cannot
    > replace aRts.


    Not only that, on a fresh install, make sure you login as root
    and type: alsamixer and unmute everything and turn up their
    volumes.

    Then hit Esc to exit and type: alsactl store and then alsactl restore


    -Matt

  4. Re: Slack 11 no sound from KDE

    On Jun 26, 12:31 pm, Thomas Overgaard wrote:
    > monkeyfu...@gmail.com wrote :
    >
    > > No sound from KDE Apps or Notifications.

    >
    > Thats because KDE depends on the aRts sound system and ALSA cannot
    > replace aRts.
    > --
    > Thomas O.
    >
    > This area is designed to become quite warm during normal operation.


    Ok... but in the KDE control centre you can turn aRts off and not use
    it. I did this with Slack 10 and I still had sound. Besides aRts is
    crap and I don't want to use it. I should be able to use ALSA like I
    did with 10.0.


  5. Re: Slack 11 no sound from KDE

    On Jun 26, 1:56 pm, Matt Hayes wrote:
    > On 2007-06-26, Thomas Overgaard wrote:
    >
    >
    >
    > > monkeyfu...@gmail.com wrote :

    >
    > >> No sound from KDE Apps or Notifications.

    >
    > > Thats because KDE depends on the aRts sound system and ALSA cannot
    > > replace aRts.

    >
    > Not only that, on a fresh install, make sure you login as root
    > and type: alsamixer and unmute everything and turn up their
    > volumes.
    >
    > Then hit Esc to exit and type: alsactl store and then alsactl restore
    >
    > -Matt


    Already did that... no help.


+ Reply to Thread