6.2 Indy, ec0 gone missing? - SGI

This is a discussion on 6.2 Indy, ec0 gone missing? - SGI ; Hi, I wonder if anyone can help me shed some light on this situation. I have a 6.2 Indy which functions as a print server, and I have some stuff on the disks that I occasionally need to glance at. ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: 6.2 Indy, ec0 gone missing?

  1. 6.2 Indy, ec0 gone missing?

    Hi,

    I wonder if anyone can help me shed some light on this situation.

    I have a 6.2 Indy which functions as a print server, and I have some
    stuff on the disks that I occasionally need to glance at. No monitor
    plugged into this machine.

    A few days ago it disappeared from the net. I plugged a screen in
    and looked at the SYSLOG, which contains the following messages:

    ec0: machine has bad ethernet address: 0c:00:6b:08:3c:20

    ....

    WARNING: Failed to configure ec0 as hobbes
    WARNING: Cannot access primary interface, ec0

    ....

    objectserver[914]: netif verif: error in create

    Further, ec0 doesn't show up in the hinv (it does in my 6.5 Indy),
    which seems odd.

    I thought the nvram had perhaps been zapped as it started playing
    it's annoying power-up tune, which I had configured as off, suddenly.
    Indeed the nvram netaddr was wrong, but fixing it had no effect.
    "hosts" is OK, in any case I haven't changed any config files in a
    long time. The nvram eaddr can't of course be changed anyway,
    being the serial number AFAIK.

    The first message is new. The second part comes from /etc/init.d/network,
    the objectserver stuff is probably incidental.

    Any ideas of things I might check? Does it sound like HW maybe?
    The machine is over 10 years old...

    My thanks in advance.

    -E

    --
    Emery Davis
    You can reply to emeryamazon@ebayadelka.com
    by removing the well known companies

  2. Re: 6.2 Indy, ec0 gone missing?

    In article <20050708125042.16ee43ff.notareal@address.com>,
    Emery Davis wrote:

    : Any ideas of things I might check? Does it sound like HW maybe?
    : The machine is over 10 years old...

    Sounds like you need a new Dallas chip. You'll want to replace it, such as
    described here , but rather than order
    the chip you might want to try asking for a free sample first. Never hurts to
    try.

    Cheers - Tony 'Nicoya' Mantler

    --
    Tony 'Nicoya' Mantler -- Master of Code-fu -- nicoya@ubb.ca
    -- http://nicoya.feline.pp.se/ -- http://www.ubb.ca/ --

  3. Re: 6.2 Indy, ec0 gone missing?

    On Fri, 08 Jul 2005 18:39:27 GMT, Tony 'Nicoya' Mantler said:

    ] In article <20050708125042.16ee43ff.notareal@address.com>,
    ] Emery Davis wrote:
    ]
    ] : Any ideas of things I might check? Does it sound like HW maybe?
    ] : The machine is over 10 years old...
    ]
    ] Sounds like you need a new Dallas chip. You'll want to replace it, such as
    ] described here , but rather than order
    ] the chip you might want to try asking for a free sample first. Never hurts to
    ] try.
    ]
    ]

    Thanks Tony. Culprit is found, and what's more thanks to that handy
    site, I even managed to boot it onto the net and print some invoices...
    Oh, frabjous day!

    Cost of Dallas chip = 5% cost of 400 MHz octane 2, even in europe. Hmm,
    makes me think...

    -E

    --
    Emery Davis
    You can reply to emeryamazon@ebayadelka.com
    by removing the well known companies

  4. Re: 6.2 Indy, ec0 gone missing?

    Le Fri, 08 Jul 2005 12:50:42 +0200, Emery Davis a écrit*:

    >
    > ec0: machine has bad ethernet address: 0c:00:6b:08:3c:20


    You may try the following incantation from the PROM monitor :

    fill -w -v 0x08 0xbfbe04e8
    fill -w -v 0x00 0xbfbe04ec
    fill -w -v 0xGG 0xbfbe04f0
    fill -w -v 0xHH 0xbfbe04f4
    fill -w -v 0xII 0xbfbe04f8
    fill -w -v 0xJJ 0xbfbe04fc

    replacing GGHHIIJJ with the correct values from the machine serial number.
    Turn off the machine, turn it on again. If this doesn't heal it, then the
    Dallas chip is probably fried. Oh, I forgot the black chicken, but you
    probably did know about the black chicken, didn't you?

    --
    Quidquid latine dictum sit, altum sonatur


  5. Re: 6.2 Indy, ec0 gone missing?

    On Fri, 08 Jul 2005 23:42:07 +0200, Emmanuel Florac said:

    ] Le Fri, 08 Jul 2005 12:50:42 +0200, Emery Davis a écrit*:
    ]
    ] >
    ] > ec0: machine has bad ethernet address: 0c:00:6b:08:3c:20
    ]
    ] You may try the following incantation from the PROM monitor :
    ]
    ] fill -w -v 0x08 0xbfbe04e8
    ] fill -w -v 0x00 0xbfbe04ec
    ] fill -w -v 0xGG 0xbfbe04f0
    ] fill -w -v 0xHH 0xbfbe04f4
    ] fill -w -v 0xII 0xbfbe04f8
    ] fill -w -v 0xJJ 0xbfbe04fc
    ]
    ] replacing GGHHIIJJ with the correct values from the machine serial number.
    ] Turn off the machine, turn it on again. If this doesn't heal it, then the
    ] Dallas chip is probably fried. Oh, I forgot the black chicken, but you
    ] probably did know about the black chicken, didn't you?
    ]

    Now in my dotage I no longer wave the chicken, I eat it for dinner
    prior to the manipulation. Baked in Hoisin sauce it was black though!

    Apparently there's a little juice left in the Dallas still, because it came
    up again today with the correct address.

    Thanks again.

    -E

    --
    Emery Davis
    You can reply to emeryamazon@ebayadelka.com
    by removing the well known companies

  6. Re: 6.2 Indy, ec0 gone missing?

    Le Sat, 09 Jul 2005 20:38:14 +0200, Emery Davis a écrit*:

    >
    > Now in my dotage I no longer wave the chicken, I eat it for dinner
    > prior to the manipulation. Baked in Hoisin sauce it was black though!
    >


    So it may have helped anyway

    > Apparently there's a little juice left in the Dallas still, because it came
    > up again today with the correct address.


    Coool!

    --
    L'esprit qu'on veut avoir gâte celui qu'on a.
    Jean-Baptiste Louis Grisset.


+ Reply to Thread