gcc and GNU binutils on IRIX 5? - SGI

This is a discussion on gcc and GNU binutils on IRIX 5? - SGI ; Has anybody succeeded in running GNU binutils (as, ld) on IRIX 5.X, and in particular to use them with gcc? If so, I would be interested to get to know which version. Thanks. -- Georg Schwarz http://home.pages.de/~schwarz/ geos@epost.de +49 177 ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: gcc and GNU binutils on IRIX 5?

  1. gcc and GNU binutils on IRIX 5?

    Has anybody succeeded in running GNU binutils (as, ld) on IRIX 5.X, and
    in particular to use them with gcc? If so, I would be interested to get
    to know which version. Thanks.

    --
    Georg Schwarz http://home.pages.de/~schwarz/
    geos@epost.de +49 177 8811442

  2. Re: gcc and GNU binutils on IRIX 5?

    In article <1g7u1re.60a6y01rdtlhxN@geos.net.eu.org>,
    Georg Schwarz wrote:
    >Has anybody succeeded in running GNU binutils (as, ld) on IRIX 5.X, and
    >in particular to use them with gcc? If so, I would be interested to get
    >to know which version. Thanks.


    You won't get GNU ld to do anything useful on IRIX. Use IRIX ld.

    We long ago make 5.3 IDO available (full C compiler, linker,
    tools) for free download (it is large enough that it's painful
    to download by a slow link) so you could use it or gcc (but I
    think you know that).
    http://www.sgi.com/developers/devtools/apis/irix.html

    If you find someone that has downloaded it already you
    can get a copy from that person. We specifically allow
    copying of the 5.3 IDO image and sharing it
    (*not* a general allowance of copying/sharing IRIX CDs!).
    This 5.3 IDO allowance was granted in April 2000.

    >Georg Schwarz http://home.pages.de/~schwarz/
    > geos@epost.de +49 177 8811442



    You will need to find a correspondingly old version of gcc if
    you want it to play well with that old IDO, I suspect.

    Happy Historical Computing...
    David B. Anderson davea at sgi dot com http://reality.sgiweb.org/davea

  3. Re: gcc and GNU binutils on IRIX 5?

    davea@quasar.engr.sgi.com (David Anderson) writes:

    > In article <1g7u1re.60a6y01rdtlhxN@geos.net.eu.org>,
    > Georg Schwarz wrote:
    > >Has anybody succeeded in running GNU binutils (as, ld) on IRIX 5.X, and
    > >in particular to use them with gcc? If so, I would be interested to get
    > >to know which version. Thanks.

    >
    > You won't get GNU ld to do anything useful on IRIX. Use IRIX ld.


    My experience is different: while I recently succeeded in re-enabling the
    IRIX 5 port of GCC CVS mainline (now the 3.4 release branch) with native as
    and ld, you loose debugging support: GCC doesn't currently support mdebug
    in ELF with native tools, but you can use DWARF-2 with GNU as/ld. You need
    to use GNU ld in this case, because the IRIX 5 ld cannot deal with the
    additional sections created for DWARF-2 support.

    I've recently set up an IRIX 5.3 test system here and am working to bring
    this support up to date for the upcoming GCC 3.4 release.

    Rainer

    --
    -----------------------------------------------------------------------------
    Rainer Orth, Faculty of Technology, Bielefeld University

  4. Re: gcc and GNU binutils on IRIX 5?

    Rainer Orth wrote:

    >davea@quasar.engr.sgi.com (David Anderson) writes:
    >
    >> In article <1g7u1re.60a6y01rdtlhxN@geos.net.eu.org>,
    >> Georg Schwarz wrote:
    >> >Has anybody succeeded in running GNU binutils (as, ld) on IRIX 5.X, and
    >> >in particular to use them with gcc? If so, I would be interested to get
    >> >to know which version. Thanks.

    >>
    >> You won't get GNU ld to do anything useful on IRIX. Use IRIX ld.

    >
    >My experience is different: while I recently succeeded in re-enabling the
    >IRIX 5 port of GCC CVS mainline (now the 3.4 release branch) with native as
    >and ld, you loose debugging support: GCC doesn't currently support mdebug
    >in ELF with native tools, but you can use DWARF-2 with GNU as/ld. You need
    >to use GNU ld in this case, because the IRIX 5 ld cannot deal with the
    >additional sections created for DWARF-2 support.
    >
    >I've recently set up an IRIX 5.3 test system here and am working to bring
    >this support up to date for the upcoming GCC 3.4 release.
    >

    I think it's cool that people makes an effort to support these
    older systems. I would myself if I had the knowledge.

    /Bjorn


+ Reply to Thread