On Wed, 21 Jul 2004, Adrian Bridgett wrote:

a| Date: 21 Jul 2004 15:34:14 -0700
a| From: Adrian Bridgett
a| Newsgroups: comp.unix.aix
a| Subject: Re: AIX 5.2 connected to a TP9500
a|
a| "Michael E. Thomadakis" wrote in message news:...
a| > Hello all,
a| >
a| > we have a p690 IBM system running AIX 5.2 and we would like to attach it to a
a| > storage partition of an SGI TP9500 via 2 2Gigabit FC connections (2 PCI-X FC
a| > 6239, type 5705 IBM adapters). The TP9500 is similar to a FASt 900.
a| >
a| > Does anyone know of the necessary steps to accomplish this task? I've noticed
a| > that the TP9500 requires the host port numbers (WWN) to be specified for the
a| > partition that will be accessible by the IBM host. Does anyone know how to
a| > obtain this information from the AIX side? How are failover paths for
a| > FC storage specified in AIX 5.2?
a|
a| lsdev -Cc adapter (will show you your adapters)
a|
a| lscfg -vpl fcsX (replace X with the various adapters)
a|
a| the fastts normallly display a list of suitable WWNs. There are
a| various redbooks etc on the ibm site that will help you with this.
a| the main other component is the RDAC driver (bos.drivers.fcp.array.* I
a| think)
a|
a| fget_config -A -v (I think that's right) should show you the
a| controllers and fastt it can see)
a|
a| Two things to be aware of:
a| a) ibm only supports certain AIX setups with fastt
a| b) certainly when ordering a fastt there is an "AIX attachement"
a| option - I imagine that this provides a license key to allow "AIX" to
a| appear in the host-type panel.
a|

Adrian,

we have connected the p690 to a partition of the TP9500 which was identified
by the WWPN of the two host adapters. We defined 2 LUNs and assigned then
under the p690 host.

On the AIX side, I have enabled/condigured the FC adapters and the FC SCSI
protocol drivers:

~% lscfg | egrep -i 'fc|fcp'
+ fcs1 U1.9-P2-I7/Q1 FC Adapter
* fscsi1 U1.9-P2-I7/Q1 FC SCSI I/O Controller Protocol Device
* fcnet1 U1.9-P2-I7/Q1 Fibre Channel Network Protocol Device
+ fcs0 U1.9-P1-I7/Q1 FC Adapter
* fscsi0 U1.9-P1-I7/Q1 FC SCSI I/O Controller Protocol Device
* fcnet0 U1.9-P1-I7/Q1 Fibre Channel Network Protocol Device

~% lsdev | egrep -i 'fc|fcp'
fc0 Defined 2v-08-02 Fibre Channel Network Interface
fc1 Defined 3e-08-02 Fibre Channel Network Interface
fcnet0 Available 2v-08-02 Fibre Channel Network Protocol Device
fcnet1 Available 3e-08-02 Fibre Channel Network Protocol Device
fcs0 Available 2v-08 FC Adapter
fcs1 Available 3e-08 FC Adapter
fscsi0 Available 2v-08-01 FC SCSI I/O Controller Protocol Device
fscsi1 Available 3e-08-01 FC SCSI I/O Controller Protocol Device


I asked AIX to rediscover the h/w and load device drivers. I did this manually
(cfgmgr -v) and through SMIT.

cfmgr -v reports:

Method error (/usr/lib/methods/cfgefscsi -l fscsi1 ):
0514-061 Cannot find a child device.
Method error (/usr/lib/methods/cfgefscsi -l fscsi0 ):
0514-061 Cannot find a child device.


The problem is that the LUNs do not appear as new hdisks after the cfgmgr
command. There are no [r]dac devices showing up.

Also:

~% lsattr -D -l fscsi0
attach none How this adapter is CONNECTED False
dyntrk no Dynamic Tracking of FC Devices True
fc_err_recov delayed_fail FC Fabric Event Error RECOVERY Policy True
scsi_id Adapter SCSI ID False
sw_fc_class 3 FC Class for Fabric True

~% lsattr -D -l fscsi1
attach none How this adapter is CONNECTED False
dyntrk no Dynamic Tracking of FC Devices True
fc_err_recov delayed_fail FC Fabric Event Error RECOVERY Policy True
scsi_id Adapter SCSI ID False
sw_fc_class 3 FC Class for Fabric True

Any idea of what may be going wrong? Any hint on connecting AIX/p690 and
TP9500 is going to be appreciated.

Michael