Propack 3 and xvm not installed - SGI

This is a discussion on Propack 3 and xvm not installed - SGI ; I have gone through the Advanced Linux3 install and the ProPack3 install selecting installation of all. I now have, amongst other modules, sysadm_xvm-client-2.1-sgi300r1 xvm-standalone-module-3.0-sgi300r3 sysadm_xvm-server-2.1-sgi300r1 xvm-cmds-3.0-sgi300r3 sysadm_xvm-web-2.1-sgi300r1 But starting "xvm" gives the error XVM get api version failed: XVM not ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Propack 3 and xvm not installed

  1. Propack 3 and xvm not installed

    I have gone through the Advanced Linux3 install and
    the ProPack3 install selecting installation of all.
    I now have, amongst other modules,

    sysadm_xvm-client-2.1-sgi300r1
    xvm-standalone-module-3.0-sgi300r3
    sysadm_xvm-server-2.1-sgi300r1
    xvm-cmds-3.0-sgi300r3
    sysadm_xvm-web-2.1-sgi300r1

    But starting "xvm" gives the error

    XVM get api version failed: XVM not installed on this system.

    The flexlm license manager also doesn't seem to be installed.
    Creating /var/flexlm/license.dat didn't seem to help either.

    --
    Daniel Packman
    NCAR/ACD
    pack@ucar.edu

  2. Re: Propack 3 and xvm not installed

    Daniel Packman wrote:

    > I have gone through the Advanced Linux3 install and
    > the ProPack3 install selecting installation of all.
    > I now have, amongst other modules,
    >
    > sysadm_xvm-client-2.1-sgi300r1
    > xvm-standalone-module-3.0-sgi300r3
    > sysadm_xvm-server-2.1-sgi300r1
    > xvm-cmds-3.0-sgi300r3
    > sysadm_xvm-web-2.1-sgi300r1
    >
    > But starting "xvm" gives the error
    >
    > XVM get api version failed: XVM not installed on this system.


    The modules.conf needs an alias of xvm to tell it you mean xvm-standalone.
    I'm pretty sure that's documented in the relnotes/README, BTW.

    The cause of this, of course, is that if you join a CXFS cluster, "xvm"
    means an entirely different kernel module...

    --
    Alexis Cousein Senior Systems Engineer
    alexis@sgi.com SGI/Silicon Graphics Brussels

    If I have seen further, it is by standing on reference manuals.


  3. Re: Propack 3 and xvm not installed

    In article ,
    Alexis Cousein wrote:
    >Daniel Packman wrote:


    >> I have gone through the Advanced Linux3 install ....


    >> But starting "xvm" gives the error
    >>
    >> XVM get api version failed: XVM not installed on this system.


    >The modules.conf needs an alias of xvm to tell it you mean xvm-standalone.
    >I'm pretty sure that's documented in the relnotes/README, BTW.


    I didn't see this in /usr/share/doc/sgi-propack-3/README.txt
    but it turned out that the line

    alias xvm sgi-xvm-standalone

    was already present in /etc/modules.conf and all I needed to do was reboot.

    --
    Daniel Packman
    NCAR/ACD
    pack@ucar.edu

+ Reply to Thread