I have followed the instructions on upgrading an Altix
system, particularly the "start here: Installing the SGI
Advanced Linux Environment 2.1.1. Base OS". I am copied
the update to cds in iso format. The system can mount them
when in multi-user mode. I go through the boot process and
get to a Shell> prompt. The instructions suggest that the
cdrom should show up as an obvious entry in the Device
mapping table. This is the table I see. I see no cd device
and examining each in turn does not show the cd.


Device mapping table
fs0 : Pci(1|1)/Scsi(Pun0,Lun1)/HD(Part1,Sigg1)
blk0 : Pci(1|1)/Scsi(Pun0,Lun1)
blk1 : Pci(1|1)/Scsi(Pun0,Lun1)/HD(Part1,Sigg1) /boot/efi
blk2 : Pci(1|1)/Scsi(Pun0,Lun1)/HD(Part2,Sigg2)
blk3 : Pci(1|1)/Scsi(Pun0,Lun1)/HD(Part3,Sigg3) /
blk4 : Pci(1|1)/Scsi(Pun0,Lun3) /halt
blk5 : Pci(2|1)/Ata(Primary,Master)

Shell> fs0:


pci

Bus Dev Func
--- --- ----
00 01 00 ==> Processors -
Vendor 0x10A9 Device 0x100A Prog Interface 0
00 03 00 ==> Mass Storage Controller - SCSI Bus
Vendor 0x1077 Device 0x1216 Prog Interface 0
00 04 00 ==> Network Controller - Ethernet
Vendor 0x14E4 Device 0x1645 Prog Interface 0

-----------
An hinv -v on the installed system shows (amongst other things):

Broadcom Corporation NetXtreme BCM5701 Gigabit Ethernet (rev 21). on pci01.04.0
Silicon Graphics, Inc. SGI IO9 Gigabit Ethernet (Copper)
Integral SCSI controller pci01.03.0: QLogic 12160 Dual Channel Ultra3 SCSI (Rev
6) pci01.03.0
Disk Drive: unit 1 lun 0 SGI ST336753LC 36 GB
Disk Drive: unit 3 lun 0 SEAGATE ST336753LC 36 GB
Co-processor: Silicon Graphics, Inc. IOC4 I/O controller (rev 79). on pci01.01.0
CD-ROM MAT****ADVD-ROM SR-8588 7Z20 0.6G Formatted on pci01.01.0 target0/lu
n0


--
Daniel Packman
NCAR/ACD
pack@ucar.edu