irix won't install on irix /usr/lib32/libc.so.1 - SGI

This is a discussion on irix won't install on irix /usr/lib32/libc.so.1 - SGI ; Hi, I'm getting an error when installing irix 6.5 on my Octane. It cant find /usr/lib32/libc.so.1 . Inst bombs out. I've tried installing irix now 7 times and have given up and just unplugged the dam thing. Any idea hot ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: irix won't install on irix /usr/lib32/libc.so.1

  1. irix won't install on irix /usr/lib32/libc.so.1

    Hi,
    I'm getting an error when installing irix 6.5 on my
    Octane. It cant find /usr/lib32/libc.so.1 . Inst bombs out. I've tried
    installing irix now 7 times and have given up and just unplugged the dam
    thing.

    Any idea hot to fix this bloody thing? I've seen it a few times before.
    I'm just using install default, then conflicts and go after opening all
    the 6.5 cd's.

    Can't see what the hells wrong with it. I installed solaris 8 on a sun
    today. I'm so tempted to invest in one :-)

    But must fix this first. Any ideas?

    *********************
    Khalid Schofield
    System Administrator / EM Technician
    Dept. Of Materials
    University Of Oxford
    Parks Road
    Oxford
    OX1 3PH

    Email: khalid.schofield@materials.ox.ac.uk
    Tel: 01865 273785
    Fax: 01865 283333
    Web: http://www-em.materials.ox.ac.uk/peo...eld/index.html


  2. Re: irix won't install on irix /usr/lib32/libc.so.1

    In article ,
    Khalid Schofield wrote:
    >Hi,
    >I'm getting an error when installing irix 6.5 on my
    >Octane. It cant find /usr/lib32/libc.so.1 . Inst bombs out. I've tried
    >installing irix now 7 times and have given up and just unplugged the dam
    >thing.


    What is the 'it' that cannot find /usr/lib32/libc.so.1
    It is true that the machine won't work (in any useful way)
    without that file.

    I assume you are booting from the CD here.

    try
    set neweroverride on
    i same
    to get things reinstalled, which should get you a fresh
    /usr/lib32/libc.so.1


    Hope this helps [not an inst expert].
    David B. Anderson davea at sgi dot com http://reality.sgiweb.org/davea
    [ Suddenly to me that no verb in this sentence. -- Michael Toy ]

  3. Re: irix won't install on irix /usr/lib32/libc.so.1

    It's when installing irix. It complained about a dynamic link error and
    then pointed to /usr/lib32/libc.so.1 as the error.

    I even wiped the disk with mkfs before the install so it should be a new
    ver of it being installed. Short of dd'ing the disk off with /dev/zero I
    can't think of what to do to make absolutly it's re-installing this file.
    It seems really weird. But it's a 32 bit lib and Octanes are 64 bit.
    Perhaps thats a problem? It doesn't install the kernel and so won't boot
    :-(

    Any more ideas?

    thanks this is useful info you gave. I'm going to go try again in a
    minute.

    *********************
    Khalid Schofield
    System Administrator / EM Technician
    Dept. Of Materials
    University Of Oxford
    Parks Road
    Oxford
    OX1 3PH

    Email: khalid.schofield@materials.ox.ac.uk
    Tel: 01865 273785
    Fax: 01865 283333
    Web: http://www-em.materials.ox.ac.uk/peo...eld/index.html


    On Mon, 1 Mar 2004, David Anderson wrote:

    > In article ,
    > Khalid Schofield wrote:
    > >Hi,
    > >I'm getting an error when installing irix 6.5 on my
    > >Octane. It cant find /usr/lib32/libc.so.1 . Inst bombs out. I've tried
    > >installing irix now 7 times and have given up and just unplugged the dam
    > >thing.

    >
    > What is the 'it' that cannot find /usr/lib32/libc.so.1
    > It is true that the machine won't work (in any useful way)
    > without that file.
    >
    > I assume you are booting from the CD here.
    >
    > try
    > set neweroverride on
    > i same
    > to get things reinstalled, which should get you a fresh
    > /usr/lib32/libc.so.1
    >
    >
    > Hope this helps [not an inst expert].
    > David B. Anderson davea at sgi dot com http://reality.sgiweb.org/davea
    > [ Suddenly to me that no verb in this sentence. -- Michael Toy ]
    >


  4. Re: irix won't install on irix /usr/lib32/libc.so.1

    In article ,
    Khalid Schofield wrote:
    >It's when installing irix. It complained about a dynamic link error and
    >then pointed to /usr/lib32/libc.so.1 as the error.


    i required

    might be a good thing to do in inst (but should not be necessary).

    Strange. an rld complaint in running... what? swmgr itself or???
    In the context of a CD
    install it's probably impossible to copy/paste the message anywhere.
    Sigh. But you could try writing it down in full and retyping
    for this newsgroup.

    Because the message is emitted to /dev/tty from rld
    it won't appear in /var/inst/INSTLOG (sigh).
    Which you likely cannot see anyway because the machine is not getting
    set up right.

    Did you try simply installing the base IRIX cds (ignore the
    more recent 6.5.x CDs) to try to get a 'base machine' running?

    >I even wiped the disk with mkfs before the install so it should be a new
    >ver of it being installed. Short of dd'ing the disk off with /dev/zero I
    >can't think of what to do to make absolutly it's re-installing this file.
    >It seems really weird. But it's a 32 bit lib and Octanes are 64 bit.


    Yes, but it's normal and required on Octane to have
    /usr/lib/libc.so.1
    /usr/lib32/libc.so.1
    /usr/lib64/libc.so.1
    and you want and need all 3.
    So that executables in any and all of the 3 ABIs can run.
    (well a few executables don't use dynamic shared objects (DSOs, shared
    libraries) such as libc.so.1: sh/csh/cp/mv/rm and a few others.)

    >Perhaps thats a problem? It doesn't install the kernel and so won't boot
    >:-(


    Strange. The kernel does not use any of those 3, but the tools
    to build the kernel may use them.

    With a 'clean install' such as you did,
    set neweroverride on
    won't do anything useful, nor will
    i same
    as those help in 'installing on top' where something that
    inst thinks is already present is missing.

    I'm assuming you ran some disk tests (hardware tests)
    on the machine...

    Regards,
    David B. Anderson davea at sgi dot com http://reality.sgiweb.org/davea
    [Craftsman or hacker
    Code poet or code monkey
    Who am I today -- Sameer Ajmani]

  5. Re: irix won't install on irix /usr/lib32/libc.so.1

    I'll take a pic of the message and write it down. The messages scrole off
    the screen in half a seccond as theres so many printed. But the libc.so.1
    is the main one. The rest are other complaints about this file.

    *********************
    Khalid Schofield
    System Administrator / EM Technician
    Dept. Of Materials
    University Of Oxford
    Parks Road
    Oxford
    OX1 3PH

    Email: khalid.schofield@materials.ox.ac.uk
    Tel: 01865 273785
    Fax: 01865 283333
    Web: http://www-em.materials.ox.ac.uk/peo...eld/index.html


    On Mon, 1 Mar 2004, David Anderson wrote:

    > In article ,
    > Khalid Schofield wrote:
    > >It's when installing irix. It complained about a dynamic link error and
    > >then pointed to /usr/lib32/libc.so.1 as the error.

    >
    > i required
    >
    > might be a good thing to do in inst (but should not be necessary).
    >
    > Strange. an rld complaint in running... what? swmgr itself or???
    > In the context of a CD
    > install it's probably impossible to copy/paste the message anywhere.
    > Sigh. But you could try writing it down in full and retyping
    > for this newsgroup.
    >
    > Because the message is emitted to /dev/tty from rld
    > it won't appear in /var/inst/INSTLOG (sigh).
    > Which you likely cannot see anyway because the machine is not getting
    > set up right.
    >
    > Did you try simply installing the base IRIX cds (ignore the
    > more recent 6.5.x CDs) to try to get a 'base machine' running?
    >
    > >I even wiped the disk with mkfs before the install so it should be a new
    > >ver of it being installed. Short of dd'ing the disk off with /dev/zero I
    > >can't think of what to do to make absolutly it's re-installing this file.
    > >It seems really weird. But it's a 32 bit lib and Octanes are 64 bit.

    >
    > Yes, but it's normal and required on Octane to have
    > /usr/lib/libc.so.1
    > /usr/lib32/libc.so.1
    > /usr/lib64/libc.so.1
    > and you want and need all 3.
    > So that executables in any and all of the 3 ABIs can run.
    > (well a few executables don't use dynamic shared objects (DSOs, shared
    > libraries) such as libc.so.1: sh/csh/cp/mv/rm and a few others.)
    >
    > >Perhaps thats a problem? It doesn't install the kernel and so won't boot
    > >:-(

    >
    > Strange. The kernel does not use any of those 3, but the tools
    > to build the kernel may use them.
    >
    > With a 'clean install' such as you did,
    > set neweroverride on
    > won't do anything useful, nor will
    > i same
    > as those help in 'installing on top' where something that
    > inst thinks is already present is missing.
    >
    > I'm assuming you ran some disk tests (hardware tests)
    > on the machine...
    >
    > Regards,
    > David B. Anderson davea at sgi dot com http://reality.sgiweb.org/davea
    > [Craftsman or hacker
    > Code poet or code monkey
    > Who am I today -- Sameer Ajmani]
    >


+ Reply to Thread