mplayer gl2 - SGI

This is a discussion on mplayer gl2 - SGI ; Hi, ok I've asked this before but I need to use the mplayer -vo gl2 option. It seems that gl2 isn't working. mplayer -vo gl works fine. Is there something that I need to compile and install or a component ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: mplayer gl2

  1. mplayer gl2

    Hi,
    ok I've asked this before but I need to use the mplayer -vo gl2 option. It
    seems that gl2 isn't working. mplayer -vo gl works fine. Is there
    something that I need to compile and install or a component of irix that I
    havn't installed that I require?


    *********************
    Khalid Schofield
    System Administrator / EM Technician
    Dept. Of Materials
    University Of Oxford
    Parks Road
    Oxford
    OX1 3PH

    Email: khalid.schofield@materials.ox.ac.uk
    Tel: 01865 273785
    Fax: 01865 283333
    Web: http://www-em.materials.ox.ac.uk/peo...eld/index.html


  2. Re: mplayer gl2

    In article ,
    Khalid Schofield writes:

    > ok I've asked this before but I need to use the mplayer -vo gl2 option. It
    > seems that gl2 isn't working. mplayer -vo gl works fine.


    I did a MipsPro build of the latest MPlayer 1.0pre3, see:

    http://forums.nekochan.net/viewtopic.php?t=1374

    The gl2 output was successfully tested on several mgras based machines (EMXI,
    SI+T, ESI+T) without problems. Just make sure to force the output colorspace
    with -vf format=RGB24 (otherwise it just bombs out with bogus "unsupported
    texture size" messages on mgras). Also make sure it can get a double buffered
    high color visual. On your ESI that means using one of the _32db display modes.
    See the included default /usr/local/etc/mplayer/mplayer.conf for more detail,
    i've included some IRIX specific comments in there..

    so long,
    Timo

    --
    Timo Kanera . GPG Key-ID: 1024D/30CDB412



  3. Re: mplayer gl2

    yay all is working :-)

    Thanks for info. It does complain though of me using GL < 1.2 and some
    kinda corruption warnings are printed to the terminal but it seems to play
    ok.

    *********************
    Khalid Schofield
    System Administrator / EM Technician
    Dept. Of Materials
    University Of Oxford
    Parks Road
    Oxford
    OX1 3PH

    Email: khalid.schofield@materials.ox.ac.uk
    Tel: 01865 273785
    Fax: 01865 283333
    Web: http://www-em.materials.ox.ac.uk/peo...eld/index.html


    On Wed, 14 Jan 2004, Timo Kanera wrote:

    > In article ,
    > Khalid Schofield writes:
    >
    > > ok I've asked this before but I need to use the mplayer -vo gl2 option. It
    > > seems that gl2 isn't working. mplayer -vo gl works fine.

    >
    > I did a MipsPro build of the latest MPlayer 1.0pre3, see:
    >
    > http://forums.nekochan.net/viewtopic.php?t=1374
    >
    > The gl2 output was successfully tested on several mgras based machines (EMXI,
    > SI+T, ESI+T) without problems. Just make sure to force the output colorspace
    > with -vf format=RGB24 (otherwise it just bombs out with bogus "unsupported
    > texture size" messages on mgras). Also make sure it can get a double buffered
    > high color visual. On your ESI that means using one of the _32db display modes.
    > See the included default /usr/local/etc/mplayer/mplayer.conf for more detail,
    > i've included some IRIX specific comments in there..
    >
    > so long,
    > Timo
    >
    > --
    > Timo Kanera . GPG Key-ID: 1024D/30CDB412
    >
    >
    >


+ Reply to Thread