Inst: IRIX Upgrade fails - SGI

This is a discussion on Inst: IRIX Upgrade fails - SGI ; Hi, I'm trying to do an Irix upgrade from 6.5.19f to 6.5.22f on an O2, but it fails. First I tried with the software manager and I got 40 conflicts related to eoe.sw.base and dmedia: dmedia_dev.sw.base is installed but is ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Inst: IRIX Upgrade fails

  1. Inst: IRIX Upgrade fails

    Hi,

    I'm trying to do an Irix upgrade from 6.5.19f to
    6.5.22f on an O2, but it fails. First I tried
    with the software manager and I got 40 conflicts
    related to eoe.sw.base and dmedia:

    dmedia_dev.sw.base is installed but is missing prerequisites
    7a. Remove dmedia_dev.sw.base (1278786820)
    7b. Do not remove eoe.sw.base (1288786920).
    7c. Also install eoe.sw.base (1278786820 - 1278786899) from an additional
    distribution -- insert another CD or specify another software
    distribution.

    and some incompatibilities like:

    eoe.sw.base (1289434520) is incompatible with dev.sw.make (1288786920)
    15a. Do not install eoe.sw.base (1289434520)
    15b. Remove dev.sw.make (1288786920)
    15c. Open new distribution to resolve conflict

    So, I loaded the base 6.5 CD: Foundation 1 and 2, applications,
    development foundation and libraries.

    But they were still there. In the past I had the same problem
    and found a message in the newsgroup that said that probably the
    media could be corrupted, so I solved it by downloading the dist
    directly from SGI (usually I make updates by mounting a filesystem
    that our informatics department has). Unfortunately, this time,
    even with the packages from sgi.com it fails.

    When doing it with inst, additionally to those conflicts, I get
    10 warning like:

    WARNING: Invalid filetype "X" at line 317 of dmedia_dev_6522m.idb

    at the end:

    ERROR: No product corresponding to "" at line 299 of dmedia_dev_6522m.idb

    I only found two messages that mentioned these warnings and error messages,
    just one of them has an answer from Alexis Cousein:

    >Bad media, or bad drive (maybe "bad" in the sense that the firmware and
    >IRIX don't play together well, if not an SGI CD-ROM) (and bad media can
    >make pretty much anything happen).

    I think that it should be something else because I tested it
    with two different dists and got the same results.

    >The "Invalid file types" may occur unless you boot miniroot from the
    >6.5.X overlay CD (NOT the base 6.5 CD).

    Is this boot neccesary? In the past I have done it without booting from
    a CD and it has worked.

    has anybody else experienced this problem? Is there any solution rather
    than booting from a CD? Unfortunately, I only have the tardist files
    on a HD.

    Thanks in advanced,
    Josef

  2. Re: Inst: IRIX Upgrade fails

    In article <7d06f0b7.0311110640.456e1dfc@posting.google.com>,
    jmeile@hotmail.com (Josef Meile) writes:

    > When doing it with inst, additionally to those conflicts, I get
    > 10 warning like:
    >
    > WARNING: Invalid filetype "X" at line 317 of dmedia_dev_6522m.idb
    >
    > at the end:
    >
    > ERROR: No product corresponding to "" at line 299 of dmedia_dev_6522m.idb
    >


    this looks like you didn't install Patch 5086 before you attempted to upgrade.
    This one is needed when upgrading from 6.5.19 or earlier, see the 6.5.22 release
    notes..

    so long,
    Timo

    --
    Timo Kanera . GPG Key-ID: 1024D/30CDB412



  3. Re: Inst: IRIX Upgrade fails

    > this looks like you didn't install Patch 5086 before you attempted to
    upgrade.
    > This one is needed when upgrading from 6.5.19 or earlier, see the 6.5.22

    release
    > notes..

    Yes, that was the problem.
    Thanks.



+ Reply to Thread