Printing problem with cups. - Setup

This is a discussion on Printing problem with cups. - Setup ; Hi folks I have a new problem. I used cups for some time. Recently I reinstalled crux linux after a partition blew it's gasket. I have a hp officejet j5780. I installed hplip and cups. hplip 2.7.6-1 foomatic-filters 3.0.2-1 ghostscript ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Printing problem with cups.

  1. Printing problem with cups.

    Hi folks

    I have a new problem. I used cups for some time. Recently I reinstalled
    crux linux after a partition blew it's gasket.

    I have a hp officejet j5780. I installed hplip and cups.
    hplip 2.7.6-1
    foomatic-filters 3.0.2-1
    ghostscript 8.63-1
    cups 1.3.8-1
    gutenprint 5.02

    If I print an image it prints perfectly. If I print the test prints from
    either cups or from hp-toolbox they print fine. However if I try to
    print from the likes of openoffice or a textfile they do print but with
    complete disregard for spacing and formatting. No matter how I screen
    format the document, when I print it it comes out with no space
    whatsoever between successive lines. And I meant no space, the bottom of
    topline and top of bottom line are almost joined.

    I tried various other PPD files including the one from linuxprinting.org
    and from hpijs and gutenprint etc. No joy.

    Evenmore annoying is that I have a PCLinux installed in another
    partition with same ppd file as the driver and with similar setup. I
    even compared the files in /etc/cups/* between two installations without
    much use. Only real difference is the one under PCLinux is an older
    version of cups/gutenprint etc.


    Any help will be greatly appreciated.


    Some of my set up below.



    # lpoptions
    Default hp Collate=true Quality=300ColorCMYK fitplot=true prettyprint=true



    # cupsd.conf
    LogLevel info
    SystemGroup sys root
    Listen localhost:631
    Listen /var/run/cups/cups.sock
    Browsing On
    BrowseOrder allow,deny
    BrowseAllow all
    DefaultAuthType Basic


    Order allow,deny



    Encryption Required
    Order allow,deny



    AuthType Default
    Require user @SYSTEM
    Order allow,deny



    Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription
    Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job
    Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    O
    CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow


    Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs
    Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer
    Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs
    CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow



    Require user @OWNER @SYSTEM
    Order deny,allow



    Order deny,allow


    Order deny,allow





    #printers.conf

    # Printer configuration file for CUPS v1.3.8
    # Written by cupsd on 2008-10-18 13:16

    Info fax
    DeviceURI hpfax:/usb/Officejet_J5700_series?serial=CN7B1CF2K104TB
    State Idle
    StateTime 1224347056
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer


    Info HP Officejet J5700 series
    Location Local Printer
    DeviceURI hp:/usb/Officejet_J5700_series?serial=CN7B1CF2K104TB
    State Idle
    StateTime 1224350191
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer


  2. Re: Printing problem with cups.

    Any takers guys!

    none wrote:
    > Hi folks
    >
    > I have a new problem. I used cups for some time. Recently I reinstalled
    > crux linux after a partition blew it's gasket.
    >
    > I have a hp officejet j5780. I installed hplip and cups.
    > hplip 2.7.6-1
    > foomatic-filters 3.0.2-1
    > ghostscript 8.63-1
    > cups 1.3.8-1
    > gutenprint 5.02
    >
    > If I print an image it prints perfectly. If I print the test prints from
    > either cups or from hp-toolbox they print fine. However if I try to
    > print from the likes of openoffice or a textfile they do print but with
    > complete disregard for spacing and formatting. No matter how I screen
    > format the document, when I print it it comes out with no space
    > whatsoever between successive lines. And I meant no space, the bottom of
    > topline and top of bottom line are almost joined.
    >
    > I tried various other PPD files including the one from linuxprinting.org
    > and from hpijs and gutenprint etc. No joy.
    >
    > Evenmore annoying is that I have a PCLinux installed in another
    > partition with same ppd file as the driver and with similar setup. I
    > even compared the files in /etc/cups/* between two installations without
    > much use. Only real difference is the one under PCLinux is an older
    > version of cups/gutenprint etc.
    >
    >
    > Any help will be greatly appreciated.
    >
    >
    > Some of my set up below.
    >
    >
    >
    > # lpoptions
    > Default hp Collate=true Quality=300ColorCMYK fitplot=true prettyprint=true
    >
    >
    >
    > # cupsd.conf
    > LogLevel info
    > SystemGroup sys root
    > Listen localhost:631
    > Listen /var/run/cups/cups.sock
    > Browsing On
    > BrowseOrder allow,deny
    > BrowseAllow all
    > DefaultAuthType Basic
    >
    >
    > Order allow,deny
    >

    >
    >
    > Encryption Required
    > Order allow,deny
    >

    >
    >
    > AuthType Default
    > Require user @SYSTEM
    > Order allow,deny
    >

    >
    >
    > > Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription
    > Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job
    > Suspend-Current-Job Resume-Job CUPS-Move-Job>
    > Require user @OWNER @SYSTEM
    > O
    > > CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    > AuthType Default
    > Require user @SYSTEM
    > Order deny,allow
    >

    >
    > > Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs
    > Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer
    > Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs
    > CUPS-Reject-Jobs>
    > AuthType Default
    > Require user @SYSTEM
    > Order deny,allow
    >

    >
    >
    > Require user @OWNER @SYSTEM
    > Order deny,allow
    >

    >
    >
    > Order deny,allow
    >

    >

    > Order deny,allow
    >
    >
    >
    >
    >
    > #printers.conf
    >
    > # Printer configuration file for CUPS v1.3.8
    > # Written by cupsd on 2008-10-18 13:16
    >
    > Info fax
    > DeviceURI hpfax:/usb/Officejet_J5700_series?serial=CN7B1CF2K104TB
    > State Idle
    > StateTime 1224347056
    > Accepting Yes
    > Shared Yes
    > JobSheets none none
    > QuotaPeriod 0
    > PageLimit 0
    > KLimit 0
    > OpPolicy default
    > ErrorPolicy stop-printer
    >

    >
    > Info HP Officejet J5700 series
    > Location Local Printer
    > DeviceURI hp:/usb/Officejet_J5700_series?serial=CN7B1CF2K104TB
    > State Idle
    > StateTime 1224350191
    > Accepting Yes
    > Shared Yes
    > JobSheets none none
    > QuotaPeriod 0
    > PageLimit 0
    > KLimit 0
    > OpPolicy default
    > ErrorPolicy stop-printer
    >


  3. Re: Printing problem with cups.

    On Sun, 19 Oct 2008 12:39:39 -0400, none "> <"<"<""skodela""@"> (none)> wrote:

    >> I have a hp officejet j5780. I installed hplip and cups.
    >> hplip 2.7.6-1


    I'd try a newer version of hplip. Current version is 2.8.9.
    http://hplipopensource.com/hplip-web/index.html

    Regards, Dave Hodgins

    --
    Change nomail.afraid.org to ody.ca to reply by email.
    (nomail.afraid.org has been set up specifically for
    use in usenet. Feel free to use it yourself.)

  4. Re: Printing problem with cups.

    none <""skodela\"@(none)"> writes:

    >Any takers guys!


    >none wrote:
    >> Hi folks
    >>
    >> I have a new problem. I used cups for some time. Recently I reinstalled
    >> crux linux after a partition blew it's gasket.
    >>
    >> I have a hp officejet j5780. I installed hplip and cups.
    >> hplip 2.7.6-1
    >> foomatic-filters 3.0.2-1
    >> ghostscript 8.63-1
    >> cups 1.3.8-1
    >> gutenprint 5.02
    >>
    >> If I print an image it prints perfectly. If I print the test prints from
    >> either cups or from hp-toolbox they print fine. However if I try to
    >> print from the likes of openoffice or a textfile they do print but with
    >> complete disregard for spacing and formatting. No matter how I screen
    >> format the document, when I print it it comes out with no space
    >> whatsoever between successive lines. And I meant no space, the bottom of
    >> topline and top of bottom line are almost joined.
    >>
    >> I tried various other PPD files including the one from linuxprinting.org
    >> and from hpijs and gutenprint etc. No joy.
    >>
    >> Evenmore annoying is that I have a PCLinux installed in another
    >> partition with same ppd file as the driver and with similar setup. I
    >> even compared the files in /etc/cups/* between two installations without
    >> much use. Only real difference is the one under PCLinux is an older
    >> version of cups/gutenprint etc.


    mv /etc/cups /etc/cups.old
    rsync -av /pclinux/etc/cups /etc/

    service cupsd restart

    and try that. If it works it shows that there was a problem with the setup.

    If not, the problem lies elsewhere.


    >>
    >>
    >> Any help will be greatly appreciated.
    >>
    >>
    >> Some of my set up below.
    >>
    >>
    >>
    >> # lpoptions
    >> Default hp Collate=true Quality=300ColorCMYK fitplot=true prettyprint=true
    >>
    >>
    >>
    >> # cupsd.conf
    >> LogLevel info
    >> SystemGroup sys root
    >> Listen localhost:631
    >> Listen /var/run/cups/cups.sock
    >> Browsing On
    >> BrowseOrder allow,deny
    >> BrowseAllow all
    >> DefaultAuthType Basic
    >>
    >>
    >> Order allow,deny
    >>

    >>
    >>
    >> Encryption Required
    >> Order allow,deny
    >>

    >>
    >>
    >> AuthType Default
    >> Require user @SYSTEM
    >> Order allow,deny
    >>

    >>
    >>
    >> >> Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription
    >> Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job
    >> Suspend-Current-Job Resume-Job CUPS-Move-Job>
    >> Require user @OWNER @SYSTEM
    >> O
    >> >> CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    >> AuthType Default
    >> Require user @SYSTEM
    >> Order deny,allow
    >>

    >>
    >> >> Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs
    >> Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer
    >> Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs
    >> CUPS-Reject-Jobs>
    >> AuthType Default
    >> Require user @SYSTEM
    >> Order deny,allow
    >>

    >>
    >>
    >> Require user @OWNER @SYSTEM
    >> Order deny,allow
    >>

    >>
    >>
    >> Order deny,allow
    >>

    >>

    >> Order deny,allow
    >>
    >>
    >>
    >>
    >>
    >> #printers.conf
    >>
    >> # Printer configuration file for CUPS v1.3.8
    >> # Written by cupsd on 2008-10-18 13:16
    >>
    >> Info fax
    >> DeviceURI hpfax:/usb/Officejet_J5700_series?serial=CN7B1CF2K104TB
    >> State Idle
    >> StateTime 1224347056
    >> Accepting Yes
    >> Shared Yes
    >> JobSheets none none
    >> QuotaPeriod 0
    >> PageLimit 0
    >> KLimit 0
    >> OpPolicy default
    >> ErrorPolicy stop-printer
    >>

    >>
    >> Info HP Officejet J5700 series
    >> Location Local Printer
    >> DeviceURI hp:/usb/Officejet_J5700_series?serial=CN7B1CF2K104TB
    >> State Idle
    >> StateTime 1224350191
    >> Accepting Yes
    >> Shared Yes
    >> JobSheets none none
    >> QuotaPeriod 0
    >> PageLimit 0
    >> KLimit 0
    >> OpPolicy default
    >> ErrorPolicy stop-printer
    >>


  5. Re: Printing problem with cups.

    Hi guys

    I just installed a newer version of hplip and that sorted the problem
    out. However it bugs me that the problem couldn't be sorted using
    theexisting version.I suppose it might be because the pstops and
    foomatic filters are much newer than the hplip. Still :-(

    Atleast I can print properly now.

    Thanks
    sreekant

+ Reply to Thread