yum update problem - avahi-0.6.17-1.fc7 - Setup

This is a discussion on yum update problem - avahi-0.6.17-1.fc7 - Setup ; In trying to do a yum update, I got all the updates except for the following 3 which give me a transaction error below: NetworkManager.i386 1:0.7.0-0.11.svn4022.f updates-newkey NetworkManager-glib.i386 1:0.7.0-0.11.svn4022.f updates-newkey NetworkManager-gnome.i386 1:0.7.0-0.11.svn4022.f updates-newkey Transaction Check Error: file /etc/avahi/avahi-autoipd.action from install ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: yum update problem - avahi-0.6.17-1.fc7

  1. yum update problem - avahi-0.6.17-1.fc7

    In trying to do a yum update, I got all the updates except for the
    following
    3 which give me a transaction error below:


    NetworkManager.i386 1:0.7.0-0.11.svn4022.f
    updates-newkey
    NetworkManager-glib.i386 1:0.7.0-0.11.svn4022.f
    updates-newkey
    NetworkManager-gnome.i386 1:0.7.0-0.11.svn4022.f
    updates-newkey

    Transaction Check Error:

    file /etc/avahi/avahi-autoipd.action from install of avahi-
    autoipd-0.6.21-8.fc8.i386 conflicts with file from package
    avahi-0.6.17-1.fc7.i386
    file /usr/sbin/avahi-autoipd from install of avahi-
    autoipd-0.6.21-8.fc8.i386 conflicts with file from package
    avahi-0.6.17-1.fc7.i386

    Im not sure why they are fc7 when I have fc8 on my machine.
    I also noticed:

    rpm -qa | grep avahi
    avahi-compat-libdns_sd-0.6.21-8.fc8
    avahi-0.6.17-1.fc7
    avahi-devel-0.6.21-8.fc8
    avahi-qt3-0.6.21-8.fc8
    kdnssd-avahi-devel-0.1.3-0.2.20060713svn.fc8
    kdnssd-avahi-0.1.3-0.2.20060713svn.fc8
    avahi-0.6.21-8.fc8
    avahi-compat-howl-0.6.21-8.fc8
    avahi-glib-0.6.21-8.fc8

    How do I fix this? I tried removing the fc7 pkg, but I got:

    rpm -e avahi-0.6.17-1.fc7
    error: %postun(avahi-0.6.17-1.fc7.i386) scriptlet failed, exit status
    1

    Thanks for any help on this

  2. Re: yum update problem - avahi-0.6.17-1.fc7

    Jeff wrote:
    > In trying to do a yum update, I got all the updates except for the
    > following
    > 3 which give me a transaction error below:
    >
    >
    > NetworkManager.i386 1:0.7.0-0.11.svn4022.f
    > updates-newkey
    > NetworkManager-glib.i386 1:0.7.0-0.11.svn4022.f
    > updates-newkey
    > NetworkManager-gnome.i386 1:0.7.0-0.11.svn4022.f
    > updates-newkey
    >
    > Transaction Check Error:
    >
    > file /etc/avahi/avahi-autoipd.action from install of avahi-
    > autoipd-0.6.21-8.fc8.i386 conflicts with file from package
    > avahi-0.6.17-1.fc7.i386
    > file /usr/sbin/avahi-autoipd from install of avahi-
    > autoipd-0.6.21-8.fc8.i386 conflicts with file from package
    > avahi-0.6.17-1.fc7.i386
    >
    > Im not sure why they are fc7 when I have fc8 on my machine.
    > I also noticed:
    >
    > rpm -qa | grep avahi
    > avahi-compat-libdns_sd-0.6.21-8.fc8
    > avahi-0.6.17-1.fc7
    > avahi-devel-0.6.21-8.fc8
    > avahi-qt3-0.6.21-8.fc8
    > kdnssd-avahi-devel-0.1.3-0.2.20060713svn.fc8
    > kdnssd-avahi-0.1.3-0.2.20060713svn.fc8
    > avahi-0.6.21-8.fc8
    > avahi-compat-howl-0.6.21-8.fc8
    > avahi-glib-0.6.21-8.fc8
    >
    > How do I fix this? I tried removing the fc7 pkg, but I got:
    >
    > rpm -e avahi-0.6.17-1.fc7
    > error: %postun(avahi-0.6.17-1.fc7.i386) scriptlet failed, exit status
    > 1
    >
    > Thanks for any help on this


    Well, find out what the script is, and use -vvv to make it more verbose. And
    what does 'yum list extras' say about files you may have obtained and
    installed manually, from non-Fedora repositories, that can cause this kind of
    fun and games? And did you perhaps install this machine by doing a update from
    Fedora 7, and wound up with a few old files from the old installation?

    But you have to avahi packages there. Grab the avahi-0.6.21-8.fc8.rpm package,
    and try to do a 'rpm -U --replacepkgs avahi-0.6.21-8.fc8.rpm', and that still
    complains remove the old one with 'rpm -e --noscripts avahi-0.6.17-1.fc7',
    then do that rpm -U --replacepkgs command again to clean up the mess.

  3. Re: yum update problem - avahi-0.6.17-1.fc7


    > Well, find out what the script is, and use -vvv to make it more verbose. And
    > what does 'yum list extras' say about files you may have obtained and
    > installed manually, from non-Fedora repositories, that can cause this kind of
    > fun and games? And did you perhaps install this machine by doing a update from
    > Fedora 7, and wound up with a few old files from the old installation?
    >
    > But you have to avahi packages there. Grab the avahi-0.6.21-8.fc8.rpm package,
    > and try to do a 'rpm -U --replacepkgs avahi-0.6.21-8.fc8.rpm', and that still
    > complains remove the old one with 'rpm -e --noscripts avahi-0.6.17-1.fc7',
    > then do that rpm -U --replacepkgs command again to clean up the mess.


    Great, that worked, thank you so much.

  4. Re: yum update problem - avahi-0.6.17-1.fc7

    Works for me too. Highly recommended if you're having a similar
    problem, my avahi-autoipd-0.6.22-10.fc9.i386 was conflicting with
    avahi-0.6.16-4.fc6.i386

    I performed the following steps (as root)
    rpm -U --replacepkgs avahi-autoipd-0.6.22-10.fc9.i386
    This complained about the old fc6 package, so I did
    rpm -e --noscripts avahi-0.6.16-4.fc6.i386
    Then did the first command again:
    rpm -U --replacepkgs avahi-autoipd-0.6.22-10.fc9.i386
    which worked without error.
    I then did:
    yum update
    worked fine, with no complaints.




    On Sep 30, 9:02*pm, Nico Kadel-Garcia wrote:
    > Jeff wrote:
    > > In trying to do a yum update, I got all the updates except for the
    > > following
    > > 3 which give me a transaction error below:

    >
    > > NetworkManager.i386 * * * * * * * * * * *1:0.7.0-0.11.svn4022.f
    > > updates-newkey
    > > NetworkManager-glib.i386 * * * * * * * * 1:0.7.0-0.11.svn4022.f
    > > updates-newkey
    > > NetworkManager-gnome.i386 * * * * * * * *1:0.7.0-0.11.svn4022.f
    > > updates-newkey

    >
    > > Transaction Check Error:

    >
    > > * file /etc/avahi/avahi-autoipd.action from install ofavahi-
    > > autoipd-0.6.21-8.fc8.i386conflictswith file from package
    > >avahi-0.6.17-1.fc7.i386
    > > * file /usr/sbin/avahi-autoipd from install ofavahi-
    > > autoipd-0.6.21-8.fc8.i386conflictswith file from package
    > >avahi-0.6.17-1.fc7.i386

    >
    > > Im not sure why they are fc7 when I have fc8 on my machine.
    > > I also noticed:

    >
    > > *rpm -qa | grepavahi
    > >avahi-compat-libdns_sd-0.6.21-8.fc8
    > >avahi-0.6.17-1.fc7
    > >avahi-devel-0.6.21-8.fc8
    > >avahi-qt3-0.6.21-8.fc8
    > > kdnssd-avahi-devel-0.1.3-0.2.20060713svn.fc8
    > > kdnssd-avahi-0.1.3-0.2.20060713svn.fc8
    > >avahi-0.6.21-8.fc8
    > >avahi-compat-howl-0.6.21-8.fc8
    > >avahi-glib-0.6.21-8.fc8

    >
    > > How do I fix this? *I tried removing the fc7 pkg, but I got:

    >
    > > rpm -eavahi-0.6.17-1.fc7
    > > error: %postun(avahi-0.6.17-1.fc7.i386) scriptlet failed, exit status
    > > 1

    >
    > > Thanks for any help on this

    >
    > Well, find out what the script is, and use -vvv to make it more verbose. And
    > what does 'yum list extras' say about files you may have obtained and
    > installed manually, from non-Fedora repositories, that can cause this kind of
    > fun and games? And did you perhaps install this machine by doing a updatefrom
    > Fedora 7, and wound up with a few old files from the old installation?
    >
    > But you have toavahipackages there. Grab theavahi-0.6.21-8.fc8.rpm package,
    > and try to do a 'rpm -U --replacepkgsavahi-0.6.21-8.fc8.rpm', and that still
    > complains remove the old one with 'rpm -e --noscriptsavahi-0.6.17-1.fc7',
    > then do that rpm -U --replacepkgs command again to clean up the mess.



+ Reply to Thread