Sound on IBM ThinkPad 600E with Fedora 7 - Setup

This is a discussion on Sound on IBM ThinkPad 600E with Fedora 7 - Setup ; Has anybody got sound working on a 600E with Fedora 7 (or FC6)? The problem with 600E is that its sound card is mis-detected as snd-cs46xx which it is not - see the links below for explanation. I have tried ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Sound on IBM ThinkPad 600E with Fedora 7

  1. Sound on IBM ThinkPad 600E with Fedora 7

    Has anybody got sound working on a 600E with Fedora 7 (or FC6)? The
    problem with 600E is that its sound card is mis-detected as snd-cs46xx
    which it is not - see the links below for explanation.

    I have tried for a long time to get sound working on 600E with Fedora
    7. I have followed instructions from the following links, although
    they are for SUSE and Ubuntu:

    http://www.linuxquestions.org/questi...d.php?t=429437
    http://www.litljay.com/howtos/600e/
    http://ubuntuforums.org/archive/index.php/t-31226.html

    My modprobe.conf is as follows:

    alias char-major-116 snd
    alias snd-card-0 snd-cs4236
    options snd-cs4236 id=first port=0x530 cport=0x538 isapnp=0
    mpu_port=-1 fm_port=0x388 irq=5 dma1=1 dma2=0

    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0

    alias sound-service-0-0 snd-mixer oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss

    And in /etc/modprobe.d/blacklist there is a line:

    blacklist snd_cs46xx

    Now when I issue command "modprobe snd-cs4236" the console floods with
    messages:

    CS4236+ soundcard not found or device busy

    lspci -v shows:

    ....
    00:06.0 Multimedia audio controller: Cirrus Logic CS 4610/11
    [CrystalClear SoundFusion Audio Accelerator] (rev 01)
    Subsystem: IBM CS4610 SoundFusion Audio Accelerator
    Flags: bus master, medium devsel, latency 32, IRQ 9
    Memory at 50100000 (32-bit, non-prefetchable) [size=4K]
    Memory at 50000000 (32-bit, non-prefetchable) [size=1M]
    ....

    Here IRQ is 9 but everybody else suggests that I should use irq=5 in
    modprobe.conf. Is this a problem?


  2. Re: Sound on IBM ThinkPad 600E with Fedora 7

    Contrary to what was suggested in http://www.litljay.com/howtos/600e/
    I initialized the BIOS, and then disabled Quick Boot. After that the
    sound started working!

    On Jun 24, 1:29 pm, "juhani.jaak...@kolumbus.fi"
    wrote:
    > Has anybody got sound working on a 600E with Fedora 7 (or FC6)? The
    > problem with 600E is that its sound card is mis-detected as snd-cs46xx
    > which it is not - see the links below for explanation.
    >
    > I have tried for a long time to get sound working on 600E with Fedora
    > 7. I have followed instructions from the following links, although
    > they are for SUSE and Ubuntu:
    >
    > http://www.linuxquestions.org/questi...p/t-31226.html
    >

    ....


+ Reply to Thread