Please help - problem updating elfutils package - Setup

This is a discussion on Please help - problem updating elfutils package - Setup ; I'm running Fedora Core 6 and getting the following "error resolving dependencies" message when trying to update the elfutils package using the Package Updater 'pup': elfutils-libelf conflicts with elfutils-libelf-devel > 0.123-1.fc6 elfutils-libelf conflicts with elfutils > 0.123-1.fc6 elfutils-libs conflicts with ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Please help - problem updating elfutils package

  1. Please help - problem updating elfutils package

    I'm running Fedora Core 6 and getting the following "error resolving
    dependencies" message when trying to update the elfutils package using
    the Package Updater 'pup':

    elfutils-libelf conflicts with elfutils-libelf-devel > 0.123-1.fc6
    elfutils-libelf conflicts with elfutils > 0.123-1.fc6
    elfutils-libs conflicts with elfutils > 0.123-1.fc6

    So my questions are:

    1. what is the problem here, and
    2. what can I do about it so I can get the package updated
    successfully.

    There's obviously some kind of conflict between the packages mentioned
    in the error message, but I don't know enough to go further than this.
    Any help/suggestions will be gratefully received.

    Thanks, Mike.


  2. Re: Please help - problem updating elfutils package

    i think you have two versions of elfutils installed already in your
    system,
    run rpm -qa | grep elfutils to see how many versions you have, if my
    guess is right then try to del the old version and you'll be alright.

    good luck,

    zaher el siddik
    http://elsiddik.blogspot.com/


  3. Re: Please help - problem updating elfutils package


    elsiddik wrote:
    > i think you have two versions of elfutils installed already in your
    > system,
    > run rpm -qa | grep elfutils to see how many versions you have, if my
    > guess is right then try to del the old version and you'll be alright.
    >
    > good luck,


    Yes, you were right. Thanks for the help.
    Mike.


  4. Re: Please help - problem updating elfutils package

    On 20 Apr, 12:32, Mike Harrison wrote:
    > elsiddik wrote:
    > > i think you have two versions of elfutils installed already in your
    > > system,
    > > run rpm -qa | grep elfutils to see how many versions you have, if my
    > > guess is right then try to del the old version and you'll be alright.

    >
    > > good luck,

    >
    > Yes, you were right. Thanks for the help.
    > Mike.


    How did you wind up with the spare? Interrupted a previous
    installaiton?

    I personally find it useful as a debugging step on development sytems,
    or systems that failed updates, to issue a "rpm -qa --qf '%{name}\n' |
    sort | uniq -d" now and then, to find exactly this sort of problem.


+ Reply to Thread