Hi there !

So far, my attempts have failed to properly install my HP Deskjet 1120C.
After a few unsuccessful trials, I had uninstalled cups, hplip, hpijs,
hpoj... and re-install, as per instructions in the LinuxPrintingHowto. I
got poor results : it only worked with OpenOffice.

Now I am running into yet more trouble : this time I can't re-install
'cupsys' ! I must have mistakenly erased something I shouldn't have. Upon
trying to re-install, I get error messages saying that something is
missing, and, when trying to install that, something else is missing, and
so on... Below are copy/pastes of those messages.

Thanks in advance to tell me what packages I should reinstall so that I
can get 'cups', 'hplip', 'hpijs' and 'hpoj' installed again.


a short translation of the messages below:

reading packages... Done
building dependancies tree... Done
Some packages cannot be installed. this may mean that you have asked for
something impossible, or else, if you use unstable distro, that some
packages have not yet been created... The following packages contain
unsatisfied dependencies : cupsys: Depends: gs-esp but will not be
installed.

As for trying to install gs-esp, I am being told that it depends upon

Les paquets suivants contiennent des dépendances non satisfaites*:
gs-esp: Dépend: libice6 (>= 1:1.0.0) mais 4.3.0.dfsg.1-14sarge3 devra
être installé
E: Paquets défectueux

# apt-get install cupsys -s
Lecture des listes de paquets... Fait Construction de l'arbre des
dépendances... Fait Certains paquets ne peuvent être installés. Ceci
peut signifier que vous avez demandé l'impossible, ou bien, si vous
utilisez la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation*:

Les paquets suivants contiennent des dépendances non satisfaites*:
cupsys: Dépend: gs-esp mais ne sera pas installé
E: Paquets défectueux