glibc upgrade - Setup

This is a discussion on glibc upgrade - Setup ; Can any one help me upgrading the glibc on my system from 2.3 to 2.5 .. I have tried installing it using rpm -Uvh but it is not working .. has any one tried compiling and installing it before? Please ...

+ Reply to Thread
Results 1 to 13 of 13

Thread: glibc upgrade

  1. glibc upgrade

    Can any one help me upgrading the glibc on my system from 2.3 to
    2.5 .. I have tried installing it using rpm -Uvh but it is not
    working .. has any one tried compiling and installing it before?
    Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    that is Redhat Enterprise Linux - AS 4

    onkar


  2. Re: glibc upgrade

    On Apr 9, 1:30 am, "onkar" wrote:
    > Can any one help me upgrading the glibc on my system from 2.3 to
    > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    > working .. has any one tried compiling and installing it before?
    > Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    > that is Redhat Enterprise Linux - AS 4
    >
    > onkar



    Download glibc version 2.5 first and then upgrate it.
    Here is a website with the latest versions :
    http://rpm.pbone.net/index.php3/stat...1/search/glibc .

    cheers,
    zaher el siddik


  3. Re: glibc upgrade

    On Apr 9, 1:57 am, "zouz" wrote:
    > On Apr 9, 1:30 am, "onkar" wrote:
    >
    > > Can any one help me upgrading the glibc on my system from 2.3 to
    > > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    > > working .. has any one tried compiling and installing it before?
    > > Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    > > that is Redhat Enterprise Linux - AS 4

    >
    > > onkar

    >
    > Download glibc version 2.5 first and then upgrate it.
    > Here is a website with the latest versions :http://rpm.pbone.net/index.php3/stat...1/search/glibc.
    >
    > cheers,
    > zaher el siddik



    what do you mean its not working?
    try to download glibc* version 2.5 from the site i pointed at
    earlier,
    run command rmp -Uvh glibc-*
    tell me what you get when you type rpm -aq | grep glibc

    last thing : please reply here - no need to use my email,
    cheers,

    zaher el siddik


  4. Re: glibc upgrade

    On Apr 9, 12:31 pm, "zouz" wrote:
    > On Apr 9, 1:57 am, "zouz" wrote:
    >
    > > On Apr 9, 1:30 am, "onkar" wrote:

    >
    > > > Can any one help me upgrading the glibc on my system from 2.3 to
    > > > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    > > > working .. has any one tried compiling and installing it before?
    > > > Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    > > > that is Redhat Enterprise Linux - AS 4

    >
    > > > onkar

    >
    > > Download glibc version 2.5 first and then upgrate it.
    > > Here is a website with the latest versions :http://rpm.pbone.net/index.php3/stat...1/search/glibc.

    >
    > > cheers,
    > > zaher el siddik

    >
    > what do you mean its not working?
    > try to download glibc* version 2.5 from the site i pointed at
    > earlier,
    > run command rmp -Uvh glibc-*
    > tell me what you get when you type rpm -aq | grep glibc
    >
    > last thing : please reply here - no need to use my email,
    > cheers,
    >
    > zaher el siddik


    [root@localhost Desktop]# rpm -Uvh glibc-2.5-3.i386.rpm
    warning: glibc-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    4f2a6fd2
    error: Failed dependencies:
    glibc-common = 2.5-3 is needed by glibc-2.5-3.i386
    gdb < 6.3.0.0-1.111 conflicts with glibc-2.5-3.i386
    glibc > 2.3.4 conflicts with glibc-common-2.3.4-2.i386
    glibc = 2.3.4 is needed by (installed) glibc-
    headers-2.3.4-2.i386
    glibc = 2.3.4 is needed by (installed) glibc-devel-2.3.4-2.i386
    glibc = 2.3.4-2 is needed by (installed) glibc-
    utils-2.3.4-2.i386

    when I tried to upgrade glibc-common = 2.5-3 it says this :


    [root@localhost Desktop]# rpm -Uvh glibc-common-2.5-3.i386.rpm
    warning: glibc-common-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    4f2a6fd2
    error: Failed dependencies:
    glibc < 2.5 conflicts with glibc-common-2.5-3.i386
    glibc-common = 2.3.4-2 is needed by (installed)
    glibc-2.3.4-2.i686

    ???


    i tried with --Force option but it too doesnt seem to work .. now can
    you suggest something.. ok .. i tried to compile the tarball image as
    well ..


    thanks for your interest ..

    Onkar


  5. Re: glibc upgrade

    On Apr 9, 5:36 am, "onkar" wrote:
    > On Apr 9, 12:31 pm, "zouz" wrote:
    >
    >
    >
    > > On Apr 9, 1:57 am, "zouz" wrote:

    >
    > > > On Apr 9, 1:30 am, "onkar" wrote:

    >
    > > > > Can any one help me upgrading the glibc on my system from 2.3 to
    > > > > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    > > > > working .. has any one tried compiling and installing it before?
    > > > > Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    > > > > that is Redhat Enterprise Linux - AS 4

    >
    > > > > onkar

    >
    > > > Download glibc version 2.5 first and then upgrate it.
    > > > Here is a website with the latest versions :http://rpm.pbone.net/index.php3/stat...1/search/glibc.

    >
    > > > cheers,
    > > > zaher el siddik

    >
    > > what do you mean its not working?
    > > try to download glibc* version 2.5 from the site i pointed at
    > > earlier,
    > > run command rmp -Uvh glibc-*
    > > tell me what you get when you type rpm -aq | grep glibc

    >
    > > last thing : please reply here - no need to use my email,
    > > cheers,

    >
    > > zaher el siddik

    >
    > [root@localhost Desktop]# rpm -Uvh glibc-2.5-3.i386.rpm
    > warning: glibc-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    > 4f2a6fd2
    > error: Failed dependencies:
    > glibc-common = 2.5-3 is needed by glibc-2.5-3.i386
    > gdb < 6.3.0.0-1.111 conflicts with glibc-2.5-3.i386
    > glibc > 2.3.4 conflicts with glibc-common-2.3.4-2.i386
    > glibc = 2.3.4 is needed by (installed) glibc-
    > headers-2.3.4-2.i386
    > glibc = 2.3.4 is needed by (installed) glibc-devel-2.3.4-2.i386
    > glibc = 2.3.4-2 is needed by (installed) glibc-
    > utils-2.3.4-2.i386
    >
    > when I tried to upgrade glibc-common = 2.5-3 it says this :
    >
    > [root@localhost Desktop]# rpm -Uvh glibc-common-2.5-3.i386.rpm
    > warning: glibc-common-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    > 4f2a6fd2
    > error: Failed dependencies:
    > glibc < 2.5 conflicts with glibc-common-2.5-3.i386
    > glibc-common = 2.3.4-2 is needed by (installed)
    > glibc-2.3.4-2.i686
    >
    > ???
    >
    > i tried with --Force option but it too doesnt seem to work .. now can
    > you suggest something.. ok .. i tried to compile the tarball image as
    > well ..
    >
    > thanks for your interest ..
    >
    > Onkar



    All i can think about right now is maybe you can try to install it
    without dependencies
    use rpm -i --nodeps glibc-2.5-3.i386.rpm or rpm -Uvh --nodeps
    glibc-2.5-3.i386.rpm


    cheers,
    zaher el siddik


  6. Re: glibc upgrade

    onkar schrieb:
    > Can any one help me upgrading the glibc on my system from 2.3 to
    > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    > working .. has any one tried compiling and installing it before?


    if you try to upgrade your glibc via rpm (with --nopdeps) you most
    likely will shoot it unusable. It is like sawing the branch off you're
    sitting on. In http://www.linux-sxs.org/upgrading/glibc.html you
    find how to upgrade from 2.2 to 2.3. I've done this succesfully.
    Maybe you can modify this to your needs.

    HTH Martin

  7. Re: glibc upgrade

    On Apr 9, 3:10 pm, "zouz" wrote:
    > On Apr 9, 5:36 am, "onkar" wrote:
    >
    >
    >
    > > On Apr 9, 12:31 pm, "zouz" wrote:

    >
    > > > On Apr 9, 1:57 am, "zouz" wrote:

    >
    > > > > On Apr 9, 1:30 am, "onkar" wrote:

    >
    > > > > > Can any one help me upgrading the glibc on my system from 2.3 to
    > > > > > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    > > > > > working .. has any one tried compiling and installing it before?
    > > > > > Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    > > > > > that is Redhat Enterprise Linux - AS 4

    >
    > > > > > onkar

    >
    > > > > Download glibc version 2.5 first and then upgrate it.
    > > > > Here is a website with the latest versions :http://rpm.pbone.net/index.php3/stat...1/search/glibc.

    >
    > > > > cheers,
    > > > > zaher el siddik

    >
    > > > what do you mean its not working?
    > > > try to download glibc* version 2.5 from the site i pointed at
    > > > earlier,
    > > > run command rmp -Uvh glibc-*
    > > > tell me what you get when you type rpm -aq | grep glibc

    >
    > > > last thing : please reply here - no need to use my email,
    > > > cheers,

    >
    > > > zaher el siddik

    >
    > > [root@localhost Desktop]# rpm -Uvh glibc-2.5-3.i386.rpm
    > > warning: glibc-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    > > 4f2a6fd2
    > > error: Failed dependencies:
    > > glibc-common = 2.5-3 is needed by glibc-2.5-3.i386
    > > gdb < 6.3.0.0-1.111 conflicts with glibc-2.5-3.i386
    > > glibc > 2.3.4 conflicts with glibc-common-2.3.4-2.i386
    > > glibc = 2.3.4 is needed by (installed) glibc-
    > > headers-2.3.4-2.i386
    > > glibc = 2.3.4 is needed by (installed) glibc-devel-2.3.4-2.i386
    > > glibc = 2.3.4-2 is needed by (installed) glibc-
    > > utils-2.3.4-2.i386

    >
    > > when I tried to upgrade glibc-common = 2.5-3 it says this :

    >
    > > [root@localhost Desktop]# rpm -Uvh glibc-common-2.5-3.i386.rpm
    > > warning: glibc-common-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    > > 4f2a6fd2
    > > error: Failed dependencies:
    > > glibc < 2.5 conflicts with glibc-common-2.5-3.i386
    > > glibc-common = 2.3.4-2 is needed by (installed)
    > > glibc-2.3.4-2.i686

    >
    > > ???

    >
    > > i tried with --Force option but it too doesnt seem to work .. now can
    > > you suggest something.. ok .. i tried to compile the tarball image as
    > > well ..

    >
    > > thanks for your interest ..

    >
    > > Onkar

    >
    > All i can think about right now is maybe you can try to install it
    > without dependencies
    > use rpm -i --nodeps glibc-2.5-3.i386.rpm or rpm -Uvh --nodeps
    > glibc-2.5-3.i386.rpm
    >
    > cheers,
    > zaher el siddik


    warning: glibc-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    4f2a6fd2
    file /etc/localtime from install of glibc-2.5-3 conflicts with
    file from package glibc-2.3.4-2
    file /lib/ld-linux.so.2 from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /lib/libBrokenLocale.so.1 from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /lib/libSegFault.so from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /lib/libanl.so.1 from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /lib/libc.so.6 from install of glibc-2.5-3 conflicts with
    file from package glibc-2.3.4-2
    file /lib/libcidn.so.1 from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /lib/libcrypt.so.1 from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /lib/libdl.so.2 from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /lib/libm.so.6 from install of glibc-2.5-3 conflicts with
    file from package glibc-2.3.4-2
    file /lib/libnsl.so.1 from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /lib/libnss_compat.so.2 from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /lib/libnss_dns.so.2 from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /lib/libnss_files.so.2 from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /lib/libnss_hesiod.so.2 from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /lib/libnss_nis.so.2 from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /lib/libnss_nisplus.so.2 from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /lib/libpthread.so.0 from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /lib/libresolv.so.2 from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /lib/librt.so.1 from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /lib/libthread_db-1.0.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /lib/libutil.so.1 from install of glibc-2.5-3 conflicts
    with file from package glibc-2.3.4-2
    file /sbin/ldconfig from install of glibc-2.5-3 conflicts with
    file from package glibc-2.3.4-2
    file /sbin/sln from install of glibc-2.5-3 conflicts with file
    from package glibc-2.3.4-2
    file /usr/lib/gconv/ANSI_X3.110.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ARMSCII-8.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ASMO_449.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/BIG5.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/BIG5HKSCS.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP10007.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1125.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1250.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1251.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1252.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1253.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1254.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1255.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1256.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1257.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP1258.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP737.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP775.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CP932.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CSN_369103.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/CWI.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/DEC-MCS.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-AT-DE-A.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-AT-DE.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-CA-FR.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-DK-NO-A.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-DK-NO.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-ES-A.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-ES-S.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-ES.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-FI-SE-A.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-FI-SE.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-FR.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-IS-FRISS.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-IT.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-PT.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-UK.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EBCDIC-US.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ECMA-CYRILLIC.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EUC-CN.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EUC-JISX0213.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EUC-JP-MS.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EUC-JP.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EUC-KR.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/EUC-TW.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GB18030.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GBBIG5.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GBGBK.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GBK.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GEORGIAN-ACADEMY.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GEORGIAN-PS.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GOST_19768-74.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GREEK-CCITT.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GREEK7-OLD.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/GREEK7.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/HP-ROMAN8.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM037.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM038.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1004.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1026.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1046.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1047.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1124.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1129.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1132.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1133.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1160.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1161.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1162.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1163.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM1164.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM256.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM273.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM274.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM275.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM277.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM278.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM280.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM281.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM284.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM285.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM290.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM297.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM420.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM423.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM424.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM437.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM500.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM850.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM851.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM852.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM855.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM856.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM857.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM860.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM861.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM862.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM863.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM864.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM865.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM866.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM866NAV.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM868.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM869.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM870.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM871.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM874.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM875.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM880.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM891.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM903.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM904.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM905.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM918.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM922.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM930.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM932.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM933.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM935.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM937.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM939.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IBM943.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/IEC_P27-1.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/INIS-8.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/INIS-CYRILLIC.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/INIS.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISIRI-3342.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO-2022-CN-EXT.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO-2022-CN.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO-2022-JP-3.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO-2022-JP.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO-2022-KR.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO-IR-197.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO-IR-209.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO646.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-1.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-10.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-11.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-13.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-14.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-15.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-16.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-2.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-3.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-4.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-5.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-6.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-7.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-8.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO8859-9.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO_10367-BOX.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO_2033.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO_5427-EXT.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO_5427.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO_5428.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO_6937-2.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/ISO_6937.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/JOHAB.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/KOI-8.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/KOI8-R.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/KOI8-T.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/KOI8-U.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/LATIN-GREEK-1.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/LATIN-GREEK.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/MAC-IS.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/MAC-SAMI.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/MAC-UK.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/MACINTOSH.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/NATS-DANO.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/NATS-SEFI.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/PT154.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/RK1048.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/SAMI-WS2.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/SHIFT_JISX0213.so from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/SJIS.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/T.61.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/TCVN5712-1.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/TIS-620.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/TSCII.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/UHC.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/UNICODE.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/UTF-16.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/UTF-32.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/UTF-7.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/VISCII.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/gconv-modules from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/libCNS.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/libGB.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/libISOIR165.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/libJIS.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/libJISX0213.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/lib/gconv/libKSC.so from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2
    file /usr/libexec/getconf/POSIX_V6_ILP32_OFF32 from install of
    glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/libexec/getconf/POSIX_V6_ILP32_OFFBIG from install
    of glibc-2.5-3 conflicts with file from package glibc-2.3.4-2
    file /usr/sbin/iconvconfig from install of glibc-2.5-3
    conflicts with file from package glibc-2.3.4-2


    i did what you told me .I got the above error ..


  8. Re: glibc upgrade

    try out what Martin suggested - otherwise i have no idea,
    hopefully someone here will help you getting over it .

    cheers,
    zaher el siddik


  9. Re: glibc upgrade

    "onkar" writes:

    >Can any one help me upgrading the glibc on my system from 2.3 to
    >2.5 .. I have tried installing it using rpm -Uvh but it is not
    >working .. has any one tried compiling and installing it before?


    No working means what?
    And you want to upgrade why?

    >Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    >that is Redhat Enterprise Linux - AS 4


    >onkar



  10. Re: glibc upgrade

    "onkar" writes:

    >On Apr 9, 12:31 pm, "zouz" wrote:
    >> On Apr 9, 1:57 am, "zouz" wrote:
    >>
    >> > On Apr 9, 1:30 am, "onkar" wrote:

    >>
    >> > > Can any one help me upgrading the glibc on my system from 2.3 to
    >> > > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    >> > > working .. has any one tried compiling and installing it before?
    >> > > Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    >> > > that is Redhat Enterprise Linux - AS 4

    >>
    >> > > onkar

    >>
    >> > Download glibc version 2.5 first and then upgrate it.
    >> > Here is a website with the latest versions :http://rpm.pbone.net/index.php3/stat...1/search/glibc.

    >>
    >> > cheers,
    >> > zaher el siddik

    >>
    >> what do you mean its not working?
    >> try to download glibc* version 2.5 from the site i pointed at
    >> earlier,
    >> run command rmp -Uvh glibc-*
    >> tell me what you get when you type rpm -aq | grep glibc
    >>
    >> last thing : please reply here - no need to use my email,
    >> cheers,
    >>
    >> zaher el siddik



    That is not "not working". That is telling you that in order to upgrade it
    you will have to upgrade a number of other packages as well.
    download also glibc-common, gdb, glibc-headers, glibc-utils, glibc-devel
    and install them all at once.


    >[root@localhost Desktop]# rpm -Uvh glibc-2.5-3.i386.rpm
    >warning: glibc-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    >4f2a6fd2
    >error: Failed dependencies:
    > glibc-common = 2.5-3 is needed by glibc-2.5-3.i386
    > gdb < 6.3.0.0-1.111 conflicts with glibc-2.5-3.i386
    > glibc > 2.3.4 conflicts with glibc-common-2.3.4-2.i386
    > glibc = 2.3.4 is needed by (installed) glibc-
    >headers-2.3.4-2.i386
    > glibc = 2.3.4 is needed by (installed) glibc-devel-2.3.4-2.i386
    > glibc = 2.3.4-2 is needed by (installed) glibc-
    >utils-2.3.4-2.i386


    >when I tried to upgrade glibc-common = 2.5-3 it says this :



    >[root@localhost Desktop]# rpm -Uvh glibc-common-2.5-3.i386.rpm
    >warning: glibc-common-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    >4f2a6fd2
    >error: Failed dependencies:
    > glibc < 2.5 conflicts with glibc-common-2.5-3.i386
    > glibc-common = 2.3.4-2 is needed by (installed)
    >glibc-2.3.4-2.i686


    >???



    >i tried with --Force option but it too doesnt seem to work .. now can
    >you suggest something.. ok .. i tried to compile the tarball image as
    >well ..


    You have to install them all at once-- ie on the same command line.
    rpm -Uhv glibc* gdb*



    >thanks for your interest ..


    >Onkar



  11. Re: glibc upgrade

    "zouz" writes:

    >On Apr 9, 5:36 am, "onkar" wrote:
    >> On Apr 9, 12:31 pm, "zouz" wrote:
    >>
    >>
    >>
    >> > On Apr 9, 1:57 am, "zouz" wrote:

    >>
    >> > > On Apr 9, 1:30 am, "onkar" wrote:

    >>
    >> > > > Can any one help me upgrading the glibc on my system from 2.3 to
    >> > > > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    >> > > > working .. has any one tried compiling and installing it before?
    >> > > > Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    >> > > > that is Redhat Enterprise Linux - AS 4

    >>
    >> > > > onkar

    >>
    >> > > Download glibc version 2.5 first and then upgrate it.
    >> > > Here is a website with the latest versions :http://rpm.pbone.net/index.php3/stat...1/search/glibc.

    >>
    >> > > cheers,
    >> > > zaher el siddik

    >>
    >> > what do you mean its not working?
    >> > try to download glibc* version 2.5 from the site i pointed at
    >> > earlier,
    >> > run command rmp -Uvh glibc-*
    >> > tell me what you get when you type rpm -aq | grep glibc

    >>
    >> > last thing : please reply here - no need to use my email,
    >> > cheers,

    >>
    >> > zaher el siddik

    >>
    >> [root@localhost Desktop]# rpm -Uvh glibc-2.5-3.i386.rpm
    >> warning: glibc-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    >> 4f2a6fd2
    >> error: Failed dependencies:
    >> glibc-common = 2.5-3 is needed by glibc-2.5-3.i386
    >> gdb < 6.3.0.0-1.111 conflicts with glibc-2.5-3.i386
    >> glibc > 2.3.4 conflicts with glibc-common-2.3.4-2.i386
    >> glibc = 2.3.4 is needed by (installed) glibc-
    >> headers-2.3.4-2.i386
    >> glibc = 2.3.4 is needed by (installed) glibc-devel-2.3.4-2.i386
    >> glibc = 2.3.4-2 is needed by (installed) glibc-
    >> utils-2.3.4-2.i386
    >>
    >> when I tried to upgrade glibc-common = 2.5-3 it says this :
    >>
    >> [root@localhost Desktop]# rpm -Uvh glibc-common-2.5-3.i386.rpm
    >> warning: glibc-common-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    >> 4f2a6fd2
    >> error: Failed dependencies:
    >> glibc < 2.5 conflicts with glibc-common-2.5-3.i386
    >> glibc-common = 2.3.4-2 is needed by (installed)
    >> glibc-2.3.4-2.i686
    >>
    >> ???
    >>
    >> i tried with --Force option but it too doesnt seem to work .. now can
    >> you suggest something.. ok .. i tried to compile the tarball image as
    >> well ..
    >>
    >> thanks for your interest ..
    >>
    >> Onkar



    >All i can think about right now is maybe you can try to install it
    >without dependencies
    >use rpm -i --nodeps glibc-2.5-3.i386.rpm or rpm -Uvh --nodeps
    >glibc-2.5-3.i386.rpm



    Bad idea, since the dependencies are there for a reason.


  12. Re: glibc upgrade

    "onkar" wrote:
    > "zouz" wrote:
    > > > "onkar" wrote:

    >
    > > > > Can any one help me upgrading the glibc on my system from 2.3 to
    > > > > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    > > > > working ... I am using ... Redhat Enterprise Linux - AS 4

    >
    > > what do you mean its not working?

    >


    > [root@localhost Desktop]# rpm -Uvh glibc-2.5-3.i386.rpm
    > warning: glibc-2.5-3.i386.rpm: V3 DSA signature: NOKEY, key ID
    > 4f2a6fd2
    > error: Failed dependencies:
    > glibc-common = 2.5-3 is needed by glibc-2.5-3.i386
    > gdb < 6.3.0.0-1.111 conflicts with glibc-2.5-3.i386


    If you want to install a module you need to install its dependencies.
    Either you can download and install all of those dependencies one
    by one, try them, then download each of *their* dependencies,
    or you can use a tool that figures out all of the modules needed
    and gets them for you.

    Enter "up2date" for Red Hat, yum and so on for other distros.

    Register the host at Red Hat. Use "up2date" to get all of the
    dependencies. Install your module now that the dependency
    tree is all in place. Done.


  13. Re: glibc upgrade

    On 9 Apr, 06:30, "onkar" wrote:
    > Can any one help me upgrading the glibc on my system from 2.3 to
    > 2.5 .. I have tried installing it using rpm -Uvh but it is not
    > working .. has any one tried compiling and installing it before?
    > Please help me .. I am using system i386 with kernel 2.6.9-5.EL -
    > that is Redhat Enterprise Linux - AS 4
    >
    > onkar


    I'm looking at RHEL 4.4 SRPM's right now. There is *NO* published
    glibc-2.5 for RHEL 4 in all its flavors. You *CANNOT* expect to just
    slap in a vastly newer version of glibc and have it work for all your
    applications without recompiling *all* of them with the new glibc, and
    the change of glibc will break the compiler itself.

    I suggest you give up now, and proceed to RHEL 5 or CentOS 5 when it
    comes out in a few weeks. This "update one package and everything will
    be great approach" breaks badly due to massive, massive dependencies
    on such core packages. No one at RedHat will want to help you with
    this: mixing and matching such core packages can introduce all sorts
    of nasty breakages.

    If you *have* to do this, I suggest you also grab the compat-
    glibc-2.3.4 package from wherever you grabbed the glibc-2.5, and
    carefully work your way through the dependencies downloading other
    packages as needed.



+ Reply to Thread