lirc 0.8.1 won't configure - Setup

This is a discussion on lirc 0.8.1 won't configure - Setup ; Hi, I just replaced my old Debian (2.2?) with the new 3.1r5. I'm trying to install the latest version of lirc (0.8.1). When I type ./setup.sh or ./configure, I get the following: gumby:/home/jim/installs/lirc-0.8.1# ./configure setup.sh written by Karsten Scheibler, 1999-JUN-28 ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: lirc 0.8.1 won't configure

  1. lirc 0.8.1 won't configure

    Hi,

    I just replaced my old Debian (2.2?) with the new 3.1r5. I'm trying
    to install the latest version of lirc (0.8.1). When I type ./setup.sh
    or ./configure, I get the following:

    gumby:/home/jim/installs/lirc-0.8.1# ./configure
    setup.sh written by Karsten Scheibler, 1999-JUN-28

    If you have problems or questions please consult the mailing list


    Configuration cancelled!

    I don't know where the "Configuration cancelled!" message is coming
    from (I greped ./configure and it isn't there). Am I missing a
    package or something? When I installed Debian, I chose manual package
    selection (I didn't want the desktop 'cause I didn't want any gui
    stuff).

    I'd appreciate any help on this.


    Thanks much,


    Jim


  2. Re: lirc 0.8.1 won't configure

    On Mar 25, 7:53 pm, "Jim" wrote:
    > Hi,
    >
    > I just replaced my old Debian (2.2?) with the new 3.1r5. I'm trying
    > to install the latest version of lirc (0.8.1). When I type ./setup.sh
    > or ./configure, I get the following:
    >
    > gumby:/home/jim/installs/lirc-0.8.1# ./configure
    > setup.sh written by Karsten Scheibler, 1999-JUN-28
    >
    > If you have problems or questions please consult the mailing list
    >
    >
    > Configuration cancelled!
    >
    > I don't know where the "Configuration cancelled!" message is coming
    > from (I greped ./configure and it isn't there). Am I missing a
    > package or something? When I installed Debian, I chose manual package
    > selection (I didn't want the desktop 'cause I didn't want any gui
    > stuff).
    >
    > I'd appreciate any help on this.
    >
    > Thanks much,
    >
    > Jim


    One more thing. I HAVE used configure successfully to build other
    source modules (mpg123)...


    Jim


  3. Re: lirc 0.8.1 won't configure

    On Mar 26, 9:19 pm, "Jim" wrote:
    > On Mar 25, 7:53 pm, "Jim" wrote:
    > > Hi,

    >
    > > I just replaced my old Debian (2.2?) with the new 3.1r5.

    Forget about Old Debian 3.1r5 and install new Debian/Etch 4.0

    You find it at http://www.debian.org/devel/debian-installer/

    It has lit 0.8.0 packed for Debian/Etch

    > > I'm trying
    > > to install the latest version of lirc (0.8.1). When I type ./setup.sh
    > > or ./configure, I get the following:

    >
    > > gumby:/home/jim/installs/lirc-0.8.1# ./configure
    > > setup.sh written by Karsten Scheibler, 1999-JUN-28

    >
    > > If you have problems or questions please consult the mailing list
    > >

    >
    > > Configuration cancelled!


    Is this realy all messages you get?

    What does lirc README tell you what other programming libraries is
    needed to program this?

    > > I don't know where the "Configuration cancelled!" message is coming
    > > from (I greped ./configure and it isn't there). Am I missing a
    > > package or something? When I installed Debian, I chose manual package
    > > selection (I didn't want the desktop 'cause I didn't want any gui
    > > stuff).

    >
    > > I'd appreciate any help on this.

    >
    > > Thanks much,

    >
    > > Jim

    >
    > One more thing. I HAVE used configure successfully to build other
    > source modules (mpg123)...
    >
    > Jim


    I would install Debian/Etch 4.0 and not old Debian/Sarge 3.1

    /Jackson


  4. Re: lirc 0.8.1 won't configure

    On Mar 27, 12:21 pm, "AJackson" wrote:
    > On Mar 26, 9:19 pm, "Jim" wrote:> On Mar 25, 7:53 pm, "Jim" wrote:
    > > > Hi,

    >
    > > > I just replaced my old Debian (2.2?) with the new 3.1r5.

    >
    > Forget about Old Debian 3.1r5 and install new Debian/Etch 4.0
    >
    > You find it athttp://www.debian.org/devel/debian-installer/
    >
    > It has lit 0.8.0 packed for Debian/Etch
    >
    > > > I'm trying
    > > > to install the latest version of lirc (0.8.1). When I type ./setup.sh
    > > > or ./configure, I get the following:

    >
    > > > gumby:/home/jim/installs/lirc-0.8.1# ./configure
    > > > setup.sh written by Karsten Scheibler, 1999-JUN-28

    >
    > > > If you have problems or questions please consult the mailing list
    > > >

    >
    > > > Configuration cancelled!

    >
    > Is this realy all messages you get?
    >
    > What does lirc README tell you what other programming libraries is
    > needed to program this?
    >
    >
    >
    > > > I don't know where the "Configuration cancelled!" message is coming
    > > > from (I greped ./configure and it isn't there). Am I missing a
    > > > package or something? When I installed Debian, I chose manual package
    > > > selection (I didn't want the desktop 'cause I didn't want any gui
    > > > stuff).

    >
    > > > I'd appreciate any help on this.

    >
    > > > Thanks much,

    >
    > > > Jim

    >
    > > One more thing. I HAVE used configure successfully to build other
    > > source modules (mpg123)...

    >
    > > Jim

    >
    > I would install Debian/Etch 4.0 and not old Debian/Sarge 3.1
    >
    > /Jackson


    Old??? I just got it two weeks ago! So I checked again. Etch hasn't
    been released yet. What I have is the most current stable release.
    I'd rather not "live on the edge", thank you.

    As for the error messages, here's a complete listing (I tried with
    v0.8.* and got the same results:


    gumby:/home/jim/installs/lirc-0.7.3pre1# ./setup.sh
    setup.sh written by Karsten Scheibler, 1999-JUN-28

    If you have problems or questions please consult the mailing list


    Configuration cancelled!
    gumby:/home/jim/installs/lirc-0.7.3pre1# ./configure
    creating cache ./config.cache
    setup.sh written by Karsten Scheibler, 1999-JUN-28

    If you have problems or questions please consult the mailing list


    Configuration cancelled!
    gumby:/home/jim/installs/lirc-0.7.3pre1#


    Thanks,


    Jim


  5. Re: lirc 0.8.1 won't configure

    On Mar 31, 6:25 am, "Jim" wrote:
    > On Mar 27, 12:21 pm, "AJackson" wrote:
    >
    >
    >
    > > On Mar 26, 9:19 pm, "Jim" wrote:> On Mar 25, 7:53 pm, "Jim" wrote:
    > > > > Hi,

    >
    > > > > I just replaced my old Debian (2.2?) with the new 3.1r5.

    >
    > > Forget about Old Debian 3.1r5 and install new Debian/Etch 4.0

    >
    > > You find it athttp://www.debian.org/devel/debian-installer/

    >
    > > It has lit 0.8.0 packed for Debian/Etch

    >
    > > > > I'm trying
    > > > > to install the latest version of lirc (0.8.1). When I type ./setup.sh
    > > > > or ./configure, I get the following:

    >
    > > > > gumby:/home/jim/installs/lirc-0.8.1# ./configure
    > > > > setup.sh written by Karsten Scheibler, 1999-JUN-28

    >
    > > > > If you have problems or questions please consult the mailing list
    > > > >

    >
    > > > > Configuration cancelled!

    >
    > > Is this realy all messages you get?

    >
    > > What does lirc README tell you what other programming libraries is
    > > needed to program this?

    >
    > > > > I don't know where the "Configuration cancelled!" message is coming
    > > > > from (I greped ./configure and it isn't there). Am I missing a
    > > > > package or something? When I installed Debian, I chose manual package
    > > > > selection (I didn't want the desktop 'cause I didn't want any gui
    > > > > stuff).

    >
    > > > > I'd appreciate any help on this.

    >
    > > > > Thanks much,

    >
    > > > > Jim

    >
    > > > One more thing. I HAVE used configure successfully to build other
    > > > source modules (mpg123)...

    >
    > > > Jim

    >
    > > I would install Debian/Etch 4.0 and not old Debian/Sarge 3.1

    >
    > > /Jackson

    >
    > Old??? I just got it two weeks ago! So I checked again. Etch hasn't
    > been released yet. What I have is the most current stable release.
    > I'd rather not "live on the edge", thank you.
    >
    > As for the error messages, here's a complete listing (I tried with
    > v0.8.* and got the same results:
    >
    > gumby:/home/jim/installs/lirc-0.7.3pre1# ./setup.sh
    > setup.sh written by Karsten Scheibler, 1999-JUN-28
    >
    > If you have problems or questions please consult the mailing list
    >
    >
    > Configuration cancelled!
    > gumby:/home/jim/installs/lirc-0.7.3pre1# ./configure
    > creating cache ./config.cache
    > setup.sh written by Karsten Scheibler, 1999-JUN-28
    >
    > If you have problems or questions please consult the mailing list
    >
    >
    > Configuration cancelled!
    > gumby:/home/jim/installs/lirc-0.7.3pre1#
    >
    > Thanks,
    >
    > Jim


    I solved this! It turns out I needed the ncurses developer's
    package. Geesh, not having this caused all sorts of bizarre,
    seemingly unrelated problems (like trying to run aptitude via telnet
    and I get a vt320 unrecognized terminal error). Maybe it should be a
    dependency of ncurses or at least a warning in aptitude...


    Jim


  6. Re: lirc 0.8.1 won't configure

    On Mar 31, 3:25 pm, "Jim" wrote:
    > On Mar 27, 12:21 pm, "AJackson" wrote:
    >
    > > On Mar 26, 9:19 pm, "Jim" wrote:> On Mar 25, 7:53 pm, "Jim" wrote:
    > > > > Hi,

    >
    > > > > I just replaced my old Debian (2.2?) with the new 3.1r5.

    >
    > > Forget about Old Debian 3.1r5 and install new Debian/Etch 4.0

    >
    > > You find it athttp://www.debian.org/devel/debian-installer/

    >
    > > It has lit 0.8.0 packed for Debian/Etch


    ....

    You didn't top post, but it's easier to read and answer if you put
    your answers/questions directly after relevant textpart in original
    post.

    > Old??? I just got it two weeks ago! So I checked again. Etch hasn't
    > been released yet. What I have is the most current stable release.
    > I'd rather not "live on the edge", thank you.


    Debian/Sarge har been around for a long time now, so yes. It's old.

    Debian/Etch is not "living on the edge". It will be next stabel in
    this month (of it wont be put forward on month more). Debian/Etch is
    frozen Debian/testing from half a year ago. So it's not Debian/testing
    or Debian/unstable, for whitch I agree with you about "living on the
    edge"

    So in one-two month you will have a old Debian again. And I would say
    it is worth it to skip Debian/Sarge for Debian/Etch, even now.

    But then again, you are behind a small modem, if I'm right. But I
    would install Debian/Etch, and when Debian/Etch declared Debian/
    Stable, I would get the CD-Roms and upgrade from there.

    > As for the error messages, here's a complete listing (I tried with
    > v0.8.* and got the same results:
    >
    > gumby:/home/jim/installs/lirc-0.7.3pre1# ./setup.sh
    > setup.sh written by Karsten Scheibler, 1999-JUN-28
    >
    > If you have problems or questions please consult the mailing list
    >
    >
    > Configuration cancelled!
    > gumby:/home/jim/installs/lirc-0.7.3pre1# ./configure
    > creating cache ./config.cache
    > setup.sh written by Karsten Scheibler, 1999-JUN-28
    >
    > If you have problems or questions please consult the mailing list
    >
    >
    > Configuration cancelled!
    > gumby:/home/jim/installs/lirc-0.7.3pre1#


    I saw that you solved it. Usally it is a package with appended "-dev"
    that is missing when you compile a program yourself.

    Good luck with old Debian/Sarge ;-)


+ Reply to Thread