CUPS: Unsupported format 'application/postscript' - Setup

This is a discussion on CUPS: Unsupported format 'application/postscript' - Setup ; Hello I'm trying to set up CUPS on my HLFS distribution. I added my printer (Samsung ML-2010) via the web interface successfully. When I try to print something, e.g. a test page, I get: Unsupported format 'application/postscript'! When I tried ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: CUPS: Unsupported format 'application/postscript'

  1. CUPS: Unsupported format 'application/postscript'

    Hello

    I'm trying to set up CUPS on my HLFS distribution. I added my printer
    (Samsung ML-2010) via the web interface successfully. When I try to
    print something, e.g. a test page, I get:

    Unsupported format 'application/postscript'!

    When I tried to print a text file, I got unsupported format 'text/
    plain' instead. It looks like cups (or the printer drivers?) are only
    supporting raster formats. I have no idea why cups didn't attempt to
    convert the document to whatever the drivers accept, and no idea where
    I could set this up.

    I compiled cups, EPS GhostScript and splix drivers from source. It's a
    amd64 architecture.

    Any ideas where else can I look? What to debug? What config files to
    hack?


  2. Re: CUPS: Unsupported format 'application/postscript'

    uukgoblin@googlemail.com wrote:

    > Unsupported format 'application/postscript'!


    > Any ideas where else can I look? What to debug? What config files to
    > hack?



    maybe have a look at /etc/cups/mime.convs or wherever it resides ...

    HTH Martin

+ Reply to Thread