vim error - SCO

This is a discussion on vim error - SCO ; $ vim dynamic linker : vim : error opening /usr/local/lib/libgtk-1.2.so0 when i run vim on sco 506 using skunk version of vim properly installed i get the error above. The path does not exist. /usr/local/lib does. i tried the install ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: vim error

  1. vim error

    $ vim
    dynamic linker : vim : error opening /usr/local/lib/libgtk-1.2.so0


    when i run vim on sco 506 using skunk version of vim properly
    installed i get the error above. The path does not exist.
    /usr/local/lib does.

    i tried the install from the CD and the custom using the VOL.000
    install.

    any ideas?

    Smokey

  2. Re: vim error


    ----- Original Message -----
    From:
    Newsgroups: comp.unix.sco.misc
    To:
    Sent: Friday, May 25, 2007 6:49 PM
    Subject: vim error


    >$ vim
    > dynamic linker : vim : error opening /usr/local/lib/libgtk-1.2.so0
    >
    >
    > when i run vim on sco 506 using skunk version of vim properly
    > installed i get the error above. The path does not exist.
    > /usr/local/lib does.
    >
    > i tried the install from the CD and the custom using the VOL.000
    > install.
    >
    > any ideas?
    >
    > Smokey


    No idea what the skunkware vim requires, since most of skunkware is old
    enough that most of skunkwares original requirements have now been subsumes
    and obsoleted by single large newer packages. There were several skunkware
    and oss/sls/tls packages that provided various libraries that other
    skunkware packages needed. So the vim from skunkware might originally have
    been documented to need say, the other skunware package Glib-1.5 and maybe
    oss631c. But you don't have to guess. every skunkware package has a cover
    letter that says what it requires.

    But you mostly don't want to follow those to the letter any more. newer
    versions of what was in Glib and oss631c are now in one package gwxlibs
    which you do want.
    Installing both gwxlibs and the older stuff at the same time is just a
    recipe for confusion.

    I have vim-6.3 built for osr5 here:
    http://www.aljex.com/kw/sco/#vim

    which requires gwxlibs and xorg
    ftp://ftp.sco.com/pub/openserver5/50...xlibs-2.1.0Ba/
    ftp://ftp.sco.com/pub/openserver5/50.../xorg-6.7.0Ba/
    Which in turn, (on a 506 or earlier machine) require oss646c and rs506a

    But there is now an even newer gwxlibs, which now also _includes_ a newer
    xorg, .. and theres a vim 7 in there too:
    ftp://ftp.sco.com/pub/openserver5/507/mp/osr507mp5/

    As long as rs506a and oss646c is installed, the sub-component packages from
    507mp5 probably will install and work fine on 506.
    What you do is dowload and unpack the tar in a temp dir like /vols
    then run custom and select install from local, media images, and enter the
    dir /vols
    then expand the osr507mp5 item and unselect the top level mp5 item itself,
    also make sure not to select the rs507d item, and select the gwxlibs and vim
    sub components.

    I just installed perl, apache, extshells (which gets you new versions of
    ksh93, bash, zsh), vim, & lynx from there onto a 506 box.
    All displacing older versions I had already.

    No problems so far after a day. (apache didn't mess up my htdocs and cgi-bin
    for example and perl still works.)

    Brian K. White brian@aljex.com http://www.myspace.com/KEYofR
    +++++[>+++[>+++++>+++++++<<-]<-]>>+.>.+++++.+++++++.-.[>+<---]>++.
    filePro BBx Linux SCO FreeBSD #callahans Satriani Filk!


+ Reply to Thread