Openserver 6 HP DAT72 Problems tar: tape read error TaA RESERVED - SCO

This is a discussion on Openserver 6 HP DAT72 Problems tar: tape read error TaA RESERVED - SCO ; Having major trouble with 2 brand new HP Dat72 tape drive on Openserver 6 on 2 different servers. HP Proliant ML370 G4 HP Internal DAT72 Errors I get # tar tvf /dev/rmt/ctape0 tar: tape read error read: I/O error # ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Openserver 6 HP DAT72 Problems tar: tape read error TaA RESERVED

  1. Openserver 6 HP DAT72 Problems tar: tape read error TaA RESERVED

    Having major trouble with 2 brand new HP Dat72 tape drive on Openserver
    6 on 2 different servers.

    HP Proliant ML370 G4
    HP Internal DAT72

    Errors I get

    # tar tvf /dev/rmt/ctape0
    tar: tape read error
    read: I/O error

    # tar tvf /dev/rStp0
    tar: tape read error
    read: I/O error
    #

    Microlite BackupEdge backs up, but fails verify, citing next volume and
    no media detected errors.

    >From /var/adm/syslog


    Jul 28 10:57:48 powgrp WARNING: Tape Driver: HA 3 TC 3 LU 0 - CHECK
    CONDITION:
    Jul 28 10:57:48 powgrp
    Jul 28 10:57:48 powgrp WARNING: TaA "RESERVED" condition has been
    detected.
    Jul 28 10:57:48 powgrp
    Jul 28 11:00:27 powgrp
    Jul 28 11:00:27 powgrp WARNING: Tape Driver: HA 3 TC 3 LU 0 - CHECK
    CONDITION:
    Jul 28 11:00:27 powgrp
    Jul 28 11:00:27 powgrp WARNING: TaA "RESERVED" condition has been
    detected.
    Jul 28 11:00:27 powgrp

    Output from mkdev tape:

    # mkdev tape
    Mass storage devices are configured automatically
    when the system is booted with a new device present.

    Current tape drive configuration:

    Alias - Address - Inquiry String
    -------- -------- --------------
    hba6 - c3b0t7 - (mpt,2) LSI Logic 1030 10329
    ctape1 - c3b0t3l0 - HP C7438A V312

    See st01(7) for information about tape drive device nodes.
    #

    Listing of /dev/rmt:

    # ls -l /dev/rmt
    total 0
    crw-rw-rw- 1 root sys 295, 41 Mar 27 17:00 c0s0
    crw-rw-rw- 1 root sys 295, 42 Mar 27 17:00 c0s0n
    crw-rw-rw- 1 root sys 295, 44 Mar 27 17:00 c0s0nr
    crw-rw-rw- 1 root sys 295, 43 Mar 27 17:00 c0s0r
    crw-rw-rw- 2 root sys 295, 41 Jul 27 12:45 c3b0t3l0
    crw-rw-rw- 2 root sys 295, 42 Jul 28 10:57 c3b0t3l0n
    crw-rw-rw- 2 root sys 295, 44 Mar 27 17:00 c3b0t3l0nr
    crw-rw-rw- 2 root sys 295, 43 Mar 27 17:00 c3b0t3l0r
    crw-rw-rw- 2 root sys 295, 45 Mar 27 17:00 c3b0t3l0u
    crw-rw-rw- 2 root sys 295, 41 Jul 27 12:45 ctape0
    crw-rw-rw- 2 root sys 295, 44 Mar 27 17:00 nrtape0
    crw-rw-rw- 2 root sys 295, 42 Jul 28 10:57 ntape0
    crw-rw-rw- 2 root sys 295, 43 Mar 27 17:00 rtape0
    crw-rw-rw- 2 root sys 295, 45 Mar 27 17:00 utape0
    #

    I have tried Microlite's BackupEdge and it seems to write the backup to
    tape, but when it tries to verify it keeps asking for the next volume
    or says no media detected. Microlite wasn't much help except to say
    they had heard similar problems about HPDAT72 drives.

    I have tried this on 2 different HP Proliant Servers, the ML370 G4 and
    an older ML350 with an external DAT 72 (I have 2 of these drives) same
    or similar problem on both machines.

    I remember seeing some kind of Sense Data error or something on the
    ML350 in syslog too.

    I really doubt that both of these tape drives are bad, they are both
    new, bought at totally different times, both from Tech Data.

    Any suggestions? I couldn't find anything on sco.com or hp.com to help
    either.


  2. Re: Openserver 6 HP DAT72 Problems tar: tape read error TaA RESERVED

    Chris Schmidt wrote:
    > Having major trouble with 2 brand new HP Dat72 tape drive on Openserver
    > 6 on 2 different servers.
    >
    > HP Proliant ML370 G4
    > HP Internal DAT72
    >
    > Errors I get
    >
    > # tar tvf /dev/rmt/ctape0
    > tar: tape read error
    > read: I/O error
    >
    > # tar tvf /dev/rStp0
    > tar: tape read error
    > read: I/O error
    > #
    >
    > Microlite BackupEdge backs up, but fails verify, citing next volume and
    > no media detected errors.
    >
    >>From /var/adm/syslog

    >
    > Jul 28 10:57:48 powgrp WARNING: Tape Driver: HA 3 TC 3 LU 0 - CHECK
    > CONDITION:
    > Jul 28 10:57:48 powgrp
    > Jul 28 10:57:48 powgrp WARNING: TaA "RESERVED" condition has been
    > detected.
    > Jul 28 10:57:48 powgrp
    > Jul 28 11:00:27 powgrp
    > Jul 28 11:00:27 powgrp WARNING: Tape Driver: HA 3 TC 3 LU 0 - CHECK
    > CONDITION:
    > Jul 28 11:00:27 powgrp
    > Jul 28 11:00:27 powgrp WARNING: TaA "RESERVED" condition has been
    > detected.
    > Jul 28 11:00:27 powgrp
    >
    > Output from mkdev tape:
    >
    > # mkdev tape
    > Mass storage devices are configured automatically
    > when the system is booted with a new device present.
    >
    > Current tape drive configuration:
    >
    > Alias - Address - Inquiry String
    > -------- -------- --------------
    > hba6 - c3b0t7 - (mpt,2) LSI Logic 1030 10329
    > ctape1 - c3b0t3l0 - HP C7438A V312
    >
    > See st01(7) for information about tape drive device nodes.
    > #
    >
    > Listing of /dev/rmt:
    >
    > # ls -l /dev/rmt
    > total 0
    > crw-rw-rw- 1 root sys 295, 41 Mar 27 17:00 c0s0
    > crw-rw-rw- 1 root sys 295, 42 Mar 27 17:00 c0s0n
    > crw-rw-rw- 1 root sys 295, 44 Mar 27 17:00 c0s0nr
    > crw-rw-rw- 1 root sys 295, 43 Mar 27 17:00 c0s0r
    > crw-rw-rw- 2 root sys 295, 41 Jul 27 12:45 c3b0t3l0
    > crw-rw-rw- 2 root sys 295, 42 Jul 28 10:57 c3b0t3l0n
    > crw-rw-rw- 2 root sys 295, 44 Mar 27 17:00 c3b0t3l0nr
    > crw-rw-rw- 2 root sys 295, 43 Mar 27 17:00 c3b0t3l0r
    > crw-rw-rw- 2 root sys 295, 45 Mar 27 17:00 c3b0t3l0u
    > crw-rw-rw- 2 root sys 295, 41 Jul 27 12:45 ctape0
    > crw-rw-rw- 2 root sys 295, 44 Mar 27 17:00 nrtape0
    > crw-rw-rw- 2 root sys 295, 42 Jul 28 10:57 ntape0
    > crw-rw-rw- 2 root sys 295, 43 Mar 27 17:00 rtape0
    > crw-rw-rw- 2 root sys 295, 45 Mar 27 17:00 utape0
    > #
    >
    > I have tried Microlite's BackupEdge and it seems to write the backup to
    > tape, but when it tries to verify it keeps asking for the next volume
    > or says no media detected. Microlite wasn't much help except to say
    > they had heard similar problems about HPDAT72 drives.
    >
    > I have tried this on 2 different HP Proliant Servers, the ML370 G4 and
    > an older ML350 with an external DAT 72 (I have 2 of these drives) same
    > or similar problem on both machines.
    >
    > I remember seeing some kind of Sense Data error or something on the
    > ML350 in syslog too.
    >
    > I really doubt that both of these tape drives are bad, they are both
    > new, bought at totally different times, both from Tech Data.
    >
    > Any suggestions? I couldn't find anything on sco.com or hp.com to help
    > either.
    >


    Usual SCSI checks, and:

    - Those units usually terminate at the end of the cable - make sure the
    tape drive is not ALSO terminated.

    - On that subject: The G4, for some bean counting reason, do NOT come
    with the correct internal LVD SCSI cable unlike the G3's. If you bought
    a non-HP or non-LVD or non-terminated cable there's your problem.

    - Make sure the drives and the adapter agree on parity/no parity enabled.

    - What RAID card/level?

    - Have you tried channel B instead? (or A if it's on B now).

    - You are probably not using the other SCSI channel. Disable the unused
    channel in the BIOS. We've found in the G4 machines this can make a
    difference, don't know about the older G3's

    - If you are NOT using SATA disable it in the BIOS.

    - Is SCO fully patched? mp2 was recently released for example.

    - Did you install the EFS version specifically for OS 6.0?

    - Have you checked with HP in re a newer ROM flash for the drives?

    - Got 6 future winning Lotto numbers you'd care to share?

    --
    ----------------------------------------------------
    Pat Welch, UBB Computer Services, a WCS Affiliate
    SCO Authorized Partner
    Unix/Linux/Windows/Hardware Sales/Support
    (209) 745-1401 Cell: (209) 251-9120
    E-mail: patubb@inreach.com
    ----------------------------------------------------

  3. Re: Openserver 6 HP DAT72 Problems tar: tape read error TaA RESERVED

    Pat, it is MP2 from SCO, I don't recall if we did the EFS, It is using
    the factory HP cable inside the server, it has not been changed.

    This particular machine has Serial SCSI in addition to the builtin SCSI
    controller, the tape drive is on the builtin SCSI. Not sure what
    channel.

    I will have to look into all these things if you really think it is a
    hardware issue. I was under the impression that it was likely a
    software issue, it does backup to the drive, in BackupEdge, just does
    not Verify.

    Thanks,

    Chris


  4. Re: Openserver 6 HP DAT72 Problems tar: tape read error TaA RESERVED

    In article <1154133355.079009.238410@s13g2000cwa.googlegroups. com>,
    Chris Schmidt wrote:
    >Pat, it is MP2 from SCO, I don't recall if we did the EFS, It is using
    >the factory HP cable inside the server, it has not been changed.
    >
    >This particular machine has Serial SCSI in addition to the builtin SCSI
    >controller, the tape drive is on the builtin SCSI. Not sure what
    >channel.
    >
    >I will have to look into all these things if you really think it is a
    >hardware issue. I was under the impression that it was likely a
    >software issue, it does backup to the drive, in BackupEdge, just does
    >not Verify.
    >
    >Thanks,
    >
    >Chris


    If it doesn't verify it's probably not backing up.

    Years ago I went through one of the worst weeks of my computing
    life updating an old Xenix on Tandy 6000s to an AT&T 3B2-310.

    I'd make changes, and also do data transfers, and then backup to
    the 20MB tapes. Each tape would verify - using the included system
    programs.

    They verified. But they were not readable.

    It turns out the system wrote NOTHING to the tape, and the verify
    agreed that NOTHING was written.

    If it does not verify you are probably just writing data to
    a black hole.

    Bill


    --
    Bill Vermillion - bv @ wjv . com

  5. Re: Openserver 6 HP DAT72 Problems tar: tape read error TaA RESERVED

    Chris Schmidt wrote:
    > Having major trouble with 2 brand new HP Dat72 tape drive on Openserver
    > 6 on 2 different servers.
    >
    > HP Proliant ML370 G4
    > HP Internal DAT72
    >
    > Errors I get
    >
    > # tar tvf /dev/rmt/ctape0
    > tar: tape read error
    > read: I/O error
    >
    > # tar tvf /dev/rStp0
    > tar: tape read error
    > read: I/O error
    > #
    >
    > Microlite BackupEdge backs up, but fails verify, citing next volume and
    > no media detected errors.
    >
    >>From /var/adm/syslog

    >
    > Jul 28 10:57:48 powgrp WARNING: Tape Driver: HA 3 TC 3 LU 0 - CHECK
    > CONDITION:
    > Jul 28 10:57:48 powgrp
    > Jul 28 10:57:48 powgrp WARNING: TaA "RESERVED" condition has been
    > detected.
    > Jul 28 10:57:48 powgrp
    > Jul 28 11:00:27 powgrp
    > Jul 28 11:00:27 powgrp WARNING: Tape Driver: HA 3 TC 3 LU 0 - CHECK
    > CONDITION:
    > Jul 28 11:00:27 powgrp
    > Jul 28 11:00:27 powgrp WARNING: TaA "RESERVED" condition has been
    > detected.
    > Jul 28 11:00:27 powgrp
    >
    > Output from mkdev tape:
    >
    > # mkdev tape
    > Mass storage devices are configured automatically
    > when the system is booted with a new device present.
    >
    > Current tape drive configuration:
    >
    > Alias - Address - Inquiry String
    > -------- -------- --------------
    > hba6 - c3b0t7 - (mpt,2) LSI Logic 1030 10329
    > ctape1 - c3b0t3l0 - HP C7438A V312
    >
    > See st01(7) for information about tape drive device nodes.
    > #
    >
    > Listing of /dev/rmt:
    >
    > # ls -l /dev/rmt
    > total 0
    > crw-rw-rw- 1 root sys 295, 41 Mar 27 17:00 c0s0
    > crw-rw-rw- 1 root sys 295, 42 Mar 27 17:00 c0s0n
    > crw-rw-rw- 1 root sys 295, 44 Mar 27 17:00 c0s0nr
    > crw-rw-rw- 1 root sys 295, 43 Mar 27 17:00 c0s0r
    > crw-rw-rw- 2 root sys 295, 41 Jul 27 12:45 c3b0t3l0
    > crw-rw-rw- 2 root sys 295, 42 Jul 28 10:57 c3b0t3l0n
    > crw-rw-rw- 2 root sys 295, 44 Mar 27 17:00 c3b0t3l0nr
    > crw-rw-rw- 2 root sys 295, 43 Mar 27 17:00 c3b0t3l0r
    > crw-rw-rw- 2 root sys 295, 45 Mar 27 17:00 c3b0t3l0u
    > crw-rw-rw- 2 root sys 295, 41 Jul 27 12:45 ctape0
    > crw-rw-rw- 2 root sys 295, 44 Mar 27 17:00 nrtape0
    > crw-rw-rw- 2 root sys 295, 42 Jul 28 10:57 ntape0
    > crw-rw-rw- 2 root sys 295, 43 Mar 27 17:00 rtape0
    > crw-rw-rw- 2 root sys 295, 45 Mar 27 17:00 utape0
    > #
    >
    > I have tried Microlite's BackupEdge and it seems to write the backup to
    > tape, but when it tries to verify it keeps asking for the next volume
    > or says no media detected. Microlite wasn't much help except to say
    > they had heard similar problems about HPDAT72 drives.
    >
    > I have tried this on 2 different HP Proliant Servers, the ML370 G4 and
    > an older ML350 with an external DAT 72 (I have 2 of these drives) same
    > or similar problem on both machines.
    >
    > I remember seeing some kind of Sense Data error or something on the
    > ML350 in syslog too.
    >
    > I really doubt that both of these tape drives are bad, they are both
    > new, bought at totally different times, both from Tech Data.
    >
    > Any suggestions? I couldn't find anything on sco.com or hp.com to help
    > either.
    >


    I'm not sure if this is specific to the internal drive, but FWIW, I'm
    running OpenServer 6 with a HP DAT 72 external without any problems.
    tar, lone-tar, work just fine.

    Alias - Address - Inquiry String
    -------- -------- --------------
    hba4 - c1b0t7 - (adsl,1) Adaptec Logic PCI SCSI
    ctape1 - c1b0t2l0 - HP C7438A ZP58

    Looks like my firmware revision is newer. Maybe try updating
    your drive firmware and see if that helps.




  6. Re: Openserver 6 HP DAT72 Problems tar: tape read error TaA RESERVED

    Chris Schmidt wrote:
    > Having major trouble with 2 brand new HP Dat72 tape drive on Openserver
    > 6 on 2 different servers.
    >
    > HP Proliant ML370 G4
    > HP Internal DAT72
    >
    > Errors I get
    >
    > # tar tvf /dev/rmt/ctape0
    > tar: tape read error
    > read: I/O error
    >
    > # tar tvf /dev/rStp0
    > tar: tape read error
    > read: I/O error
    > #
    >
    > Microlite BackupEdge backs up, but fails verify, citing next volume and
    > no media detected errors.
    >
    >>From /var/adm/syslog

    >
    > Jul 28 10:57:48 powgrp WARNING: Tape Driver: HA 3 TC 3 LU 0 - CHECK
    > CONDITION:
    > Jul 28 10:57:48 powgrp
    > Jul 28 10:57:48 powgrp WARNING: TaA "RESERVED" condition has been
    > detected.
    > Jul 28 10:57:48 powgrp
    > Jul 28 11:00:27 powgrp
    > Jul 28 11:00:27 powgrp WARNING: Tape Driver: HA 3 TC 3 LU 0 - CHECK
    > CONDITION:
    > Jul 28 11:00:27 powgrp
    > Jul 28 11:00:27 powgrp WARNING: TaA "RESERVED" condition has been
    > detected.
    > Jul 28 11:00:27 powgrp
    >
    > Output from mkdev tape:
    >
    > # mkdev tape
    > Mass storage devices are configured automatically
    > when the system is booted with a new device present.
    >
    > Current tape drive configuration:
    >
    > Alias - Address - Inquiry String
    > -------- -------- --------------
    > hba6 - c3b0t7 - (mpt,2) LSI Logic 1030 10329
    > ctape1 - c3b0t3l0 - HP C7438A V312
    >
    > See st01(7) for information about tape drive device nodes.
    > #
    >
    > Listing of /dev/rmt:
    >
    > # ls -l /dev/rmt
    > total 0
    > crw-rw-rw- 1 root sys 295, 41 Mar 27 17:00 c0s0
    > crw-rw-rw- 1 root sys 295, 42 Mar 27 17:00 c0s0n
    > crw-rw-rw- 1 root sys 295, 44 Mar 27 17:00 c0s0nr
    > crw-rw-rw- 1 root sys 295, 43 Mar 27 17:00 c0s0r
    > crw-rw-rw- 2 root sys 295, 41 Jul 27 12:45 c3b0t3l0
    > crw-rw-rw- 2 root sys 295, 42 Jul 28 10:57 c3b0t3l0n
    > crw-rw-rw- 2 root sys 295, 44 Mar 27 17:00 c3b0t3l0nr
    > crw-rw-rw- 2 root sys 295, 43 Mar 27 17:00 c3b0t3l0r
    > crw-rw-rw- 2 root sys 295, 45 Mar 27 17:00 c3b0t3l0u
    > crw-rw-rw- 2 root sys 295, 41 Jul 27 12:45 ctape0
    > crw-rw-rw- 2 root sys 295, 44 Mar 27 17:00 nrtape0
    > crw-rw-rw- 2 root sys 295, 42 Jul 28 10:57 ntape0
    > crw-rw-rw- 2 root sys 295, 43 Mar 27 17:00 rtape0
    > crw-rw-rw- 2 root sys 295, 45 Mar 27 17:00 utape0
    > #
    >
    > I have tried Microlite's BackupEdge and it seems to write the backup to
    > tape, but when it tries to verify it keeps asking for the next volume
    > or says no media detected. Microlite wasn't much help except to say
    > they had heard similar problems about HPDAT72 drives.
    >
    > I have tried this on 2 different HP Proliant Servers, the ML370 G4 and
    > an older ML350 with an external DAT 72 (I have 2 of these drives) same
    > or similar problem on both machines.
    >
    > I remember seeing some kind of Sense Data error or something on the
    > ML350 in syslog too.
    >
    > I really doubt that both of these tape drives are bad, they are both
    > new, bought at totally different times, both from Tech Data.
    >
    > Any suggestions? I couldn't find anything on sco.com or hp.com to help
    > either.
    >


    I have 2 HP Dat72 internals, one on Linux (Custom dual Xeon) and one on
    OSR506 (Acer Altos). Both did NOT work at first. The problem turned
    out to be the cables that HP supplied with the drives. A good quick
    test is to boot with a Knoppix CD. If it still fails it is most likely
    hardware.

    Good Luck
    Glenn

+ Reply to Thread