sco osr5 snmp fails - getone localhost public mib-2.25.1.6.0 - SCO

This is a discussion on sco osr5 snmp fails - getone localhost public mib-2.25.1.6.0 - SCO ; I have followed, several times, the instructions in: http://members.cruzio.com/~jeffl/sco/snmp_install.txt Yet, I cannot get snmp to show anything other than interface statistics. (That is, 'getmany localhost public iso' dumps out sysinfo and network stats only.) Here is what I get on ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: sco osr5 snmp fails - getone localhost public mib-2.25.1.6.0

  1. sco osr5 snmp fails - getone localhost public mib-2.25.1.6.0

    I have followed, several times, the instructions in:

    http://members.cruzio.com/~jeffl/sco/snmp_install.txt

    Yet, I cannot get snmp to show anything other than interface
    statistics. (That is, 'getmany localhost public iso' dumps out sysinfo
    and network stats only.)

    Here is what I get on something more specific:

    apple:/etc/sysadm.d# getone localhost public mib-2.25.1.6.0
    Error code set in packet - No such variable name. Index: 1.

    I checked my config files, and they all match snmp_install.txt.

    I must be doing something wrong, but I can't figure it out. Some
    troubleshooting help would be appreciated.

    # uname -a
    SCO_SV apple 3.2 2 i386


  2. Re: sco osr5 snmp fails - getone localhost public mib-2.25.1.6.0

    On 18 Jul 2006 12:14:59 -0700, dustinable@gmail.com wrote:

    >I have followed, several times, the instructions in:


    It's only necessary to follow my instructions once.

    >http://members.cruzio.com/~jeffl/sco/snmp_install.txt
    >
    >Yet, I cannot get snmp to show anything other than interface
    >statistics. (That is, 'getmany localhost public iso' dumps out sysinfo
    >and network stats only.)


    OK, that means that hostmib isn't "grafted" onto the main tree
    correctly.

    >Here is what I get on something more specific:
    >
    >apple:/etc/sysadm.d# getone localhost public mib-2.25.1.6.0
    >Error code set in packet - No such variable name. Index: 1.


    1. Do any of these work?
    | getone -f /etc/sysadm.d/hostmib.dfn sloth public mib-2.25.1.6.0
    | getone -f /etc/sysadm.d/hostmib.dfn sloth public 1.3.6.1.2.1.25.1.6.0
    | getmany -f /etc/sysadm.d/hostmib.dfn sloth public hrSystemProcesses
    | getone -f /etc/sysadm.d/hostmib.dfn sloth public hrSystemProcesses.0


    2. Is SNMP daemon actually running?
    ps -e | grep snmpd
    Is SMUX running?
    ps -e | grep smux

    3. From the error message, my guess is you messed up this line in
    /etc/snmptd.peers:
    ####"hostmib" 1.3.6.1.4.1.32.99.1 "aintNoThing"
    "hostmib" 1.3.6.1.2.1.25 "aintNoThing"

    4. If all else fails, try a reboot and verify the snmpd and smuxtcl
    are running in the process table.

    >I checked my config files, and they all match snmp_install.txt.


    Well, mine works on everything from 3.2.2 to 3.2v5.0.6. However,
    there were some fixes to SNMP released in 3.2v5.0.6 which may have
    broken something. Dunno as you didn't supply the full version number.

    Try:
    customquery listpatches | head -1
    instead for the version number.

    --
    # Jeff Liebermann 150 Felker St #D Santa Cruz CA 95060
    # 831-336-2558 jeffl@comix.santa-cruz.ca.us
    # http://802.11junk.com jeffl@cruzio.com
    # http://www.LearnByDestroying.com AE6KS

+ Reply to Thread