setkey doesn't work in scoterm (Openserver 6) - SCO

This is a discussion on setkey doesn't work in scoterm (Openserver 6) - SCO ; Hi, "setkey" is being silently ignored in scoterm under Openserver 6. I vaguely recall a similar problem from a long time ago, but can't remember the solution. Google wasn't helpful either. Thanks. -3-...

+ Reply to Thread
Results 1 to 6 of 6

Thread: setkey doesn't work in scoterm (Openserver 6)

  1. setkey doesn't work in scoterm (Openserver 6)

    Hi,

    "setkey" is being silently ignored in scoterm under Openserver 6.
    I vaguely recall a similar problem from a long time ago, but can't
    remember the solution. Google wasn't helpful either. Thanks.

    -3-

  2. Re: setkey doesn't work in scoterm (Openserver 6)

    setkey only works on devices running in scancode mode.

    The scoterm man page says:

    +scancodes
    runs scoterm in scancode mode. The user must specify a
    keyboard file before using scancodes, because no default
    is provided. For details on specifying a keyboard file,
    see the descriptions of languageFile and keyboard in the
    Resources section later in this manual page.

    I would try that to see if it works.

    John


  3. Re: setkey doesn't work in scoterm (Openserver 6)

    As per (jboland@sco.com):

    > setkey only works on devices running in scancode mode.
    >
    > The scoterm man page says:
    >
    > +scancodes
    > runs scoterm in scancode mode. The user must specify a
    > keyboard file before using scancodes, because no default
    > is provided. For details on specifying a keyboard file,
    > see the descriptions of languageFile and keyboard in the
    > Resources section later in this manual page.
    >
    > I would try that to see if it works.


    No effect. I also tried playing with codesets in International Settings
    Manager. Same difference. Works on console, doesn't in scoterm. By they way,
    does anyone know the default settings for Internal/Console Codesets and
    keyboard of Opensever 6? I changed them so many times, I forgot what the
    defaults were. Thanks.

    -mk

  4. Re: setkey doesn't work in scoterm (Openserver 6)

    What keyboard file did you select?

    John


  5. Re: setkey doesn't work in scoterm (Openserver 6)

    As per (jboland@sco.com):

    > What keyboard file did you select?


    As far as I can tell, the choice of a keyboard, is tied to the setting of
    Internal/Console Codesets. More precisely, the setting of Console Codeset.
    So if Console Codeset is IBM858, the keyboard values which scoterm will
    accept without producing an error message are those from "#IBM 858" section
    of /usr/lib/X11/sco/ScoTerm/LangIndex.

    I added "ScoTerm*Keyboard United States(US)" to .Xdefaults-HOSTNAME, I also
    tried invoking scoterm with "-keyboard /usr/lib/keyboard/ps.858.usa" parameter.
    In both cases Options/Keyboard menu of scoterm reflects "United Stated(US)"
    keyboard. "setkey" command, however still doesn't work.

    -3-

  6. Re: setkey doesn't work in scoterm (Openserver 6)

    Try using the syntax suggested in:

    http://wdb1.sco.com/kb/showta?taid=108988

    to see if this works.

    John


+ Reply to Thread