sshd for SCO 5.05? - SCO

This is a discussion on sshd for SCO 5.05? - SCO ; I just inherited the admin of a bunch of 3.2v5.0.5 servers which must be kept alive, kicking, and a bit more secure for 12 months or so. I'm looking for a) some kind of sshd package for this version of ...

+ Reply to Thread
Results 1 to 12 of 12

Thread: sshd for SCO 5.05?

  1. sshd for SCO 5.05?

    I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    be kept alive, kicking, and a bit more secure for 12 months or so.
    I'm looking for

    a) some kind of sshd package for this version of SCO unix
    b) gcc so I could potentially compile an sshd package
    c) any resources for compiling and running open source utilities.

    Any pointers to repositories, FAQ's, or other materials is welcome.

    Thanks in advance!

    Dave




  2. Re: sshd for SCO 5.05?

    dthacker wrote:
    > I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    > be kept alive, kicking, and a bit more secure for 12 months or so.
    > I'm looking for
    >
    > a) some kind of sshd package for this version of SCO unix
    > b) gcc so I could potentially compile an sshd package
    > c) any resources for compiling and running open source utilities.
    >
    > Any pointers to repositories, FAQ's, or other materials is welcome.
    >
    > Thanks in advance!


    We feel your pain. Just put them behind a real firewall, let them alone,
    and the 12 months will pass sooner than later...

    Alternatively, get ready for a trip to the ancient past of UNIX, by the
    hand of a system patched to death, layer over layer, to try to look
    current, as that is what OpenServer familiy is.

    Good luck.

  3. Re: sshd for SCO 5.05?

    dthacker wrote:
    > I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    > be kept alive, kicking, and a bit more secure for 12 months or so.
    > I'm looking for
    >
    > a) some kind of sshd package for this version of SCO unix
    > b) gcc so I could potentially compile an sshd package
    > c) any resources for compiling and running open source utilities.
    >
    > Any pointers to repositories, FAQ's, or other materials is welcome.
    >


    http://www.aljex.com/bkw/sco/


    --
    RGB

  4. Re: sshd for SCO 5.05?

    dthacker wrote (on Wed, Jun 18, 2008 at 12:47:44PM -0700):
    > I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    > be kept alive, kicking, and a bit more secure for 12 months or so.
    > I'm looking for
    >
    > a) some kind of sshd package for this version of SCO unix
    > b) gcc so I could potentially compile an sshd package
    > c) any resources for compiling and running open source utilities.
    >
    > Any pointers to repositories, FAQ's, or other materials is welcome.
    >
    > Thanks in advance!
    >
    > Dave


    i copied an ssh installation from a 506 box to a 505 one. mostly
    it was just a matter of dropping binaries into place (a couple
    libraries, I could send you my tar files if you want). a little
    tricky setting up prgnd (the pseudo-random number generator).
    but not too bad.

    --
    _________________________________________
    Nachman Yaakov Ziskind, FSPA, LLM awacs@ziskind.us
    Attorney and Counselor-at-Law http://ziskind.us
    Economic Group Pension Services http://egps.com
    Actuaries and Employee Benefit Consultants

  5. Re: sshd for SCO 5.05?


    ----- Original Message -----
    From: "dthacker"
    Newsgroups: comp.unix.sco.misc
    To:
    Sent: Wednesday, June 18, 2008 3:47 PM
    Subject: sshd for SCO 5.05?


    >I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    > be kept alive, kicking, and a bit more secure for 12 months or so.
    > I'm looking for
    >
    > a) some kind of sshd package for this version of SCO unix
    > b) gcc so I could potentially compile an sshd package
    > c) any resources for compiling and running open source utilities.
    >
    > Any pointers to repositories, FAQ's, or other materials is welcome.
    >
    > Thanks in advance!


    Install, update, or verify already installed, in this order:
    ftp://ftp.sco.com/pub/openserver5/rs505a/
    ftp://ftp.sco.com/pub/openserver5/oss646c/
    ftp://ftp.sco.com/pub/openserver5/op...xlibs-2.1.0Ba/
    ftp://ftp.jpr.com/pub/openssh-4.5p1.tar.gz

    For the openssh, unpack the tar and the look in /usr/fix for a text file with further instructions.

    There is a sco-built, custom-installable openssh but the latest version claims to require 5.0.6 or later.

    Probably it works fine on 5.0.5, but I haven't tried and there are differences in the rc start scripts and config files and supporting libs/utils like prngd and openssl between 505 and 506 and 506 after certain patches and 507, So, it's actually simpler and safer to install a 3rd party non-standard build like mine or JPR's, until somone goes through and writes down how to install the sco built one on 505.

    Probably it just requires installing gwxlibs to get openssl and zlib, and prngd from osr507mp5. You will see all of those in the skunkware collection, they're too old and install old versions of libraries in locations that the latest openssh will not recognize.

    Instead of the stand-alone gwxlibs above, you might want or need to install the gwxlibs sub component from osr507mp5, which is somewhat newer. I don't know what libs JPR's build is linked against, but I'm sure his included directions will cover all requirements. I haven't installed this latest build but previous ones were clear and it will have any requirements either supplied in the tar or clearly stipulated so you can go get them.

    Warning.
    gwxlibs is fairly large, and many old 505 boxes have small root filesystems that may not have room for this much.
    Do not allow the root filesystem to get more full than 90%
    If you don't have room, either live without, find old mail/print/fax spools or logs to delete, clear out /tmp /usr/tmp, zero out certain files that grow forever like syslog and wtmp, users home directories may have fat in them, or do a backup/re-divvy/restore using a supertar like lone-tar or backupedge.

    You can also get other seperate packages of just openssh's requirements instead of all of gwxlibs. Consult the text file in jpr's tar for suggestions there. You'll need to get gzip seperately too if you don't install gwxlibs. Thats ok to get from skunkware or I beleive jpr provides a simple binary too, so do I at http://www.aljex.com/bkw/sco/

    --
    Brian K. White brian@aljex.com http://www.myspace.com/KEYofR
    +++++[>+++[>+++++>+++++++<<-]<-]>>+.>.+++++.+++++++.-.[>+<---]>++.
    filePro BBx Linux SCO FreeBSD #callahans Satriani Filk!


  6. Re: sshd for SCO 5.05?

    On Jun 18, 4:54 pm, "Brian K. White" wrote:
    > ----- Original Message -----
    > From: "dthacker"
    >
    > Newsgroups: comp.unix.sco.misc
    > To:
    > Sent: Wednesday, June 18, 2008 3:47 PM
    > Subject: sshd for SCO 5.05?
    >
    > >I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    > > be kept alive, kicking, and a bit more secure for 12 months or so.
    > > I'm looking for

    >
    > > a) some kind of sshd package for this version of SCO unix
    > > b) gcc so I could potentially compile an sshd package
    > > c) any resources for compiling and running open source utilities.

    >
    > > Any pointers to repositories, FAQ's, or other materials is welcome.

    >
    > > Thanks in advance!

    >
    > Install, update, or verify already installed, in this order:ftp://ftp.sco.com/pub/openserver5/rs...h-4.5p1.tar.gz
    >


    How would I verify the patch level on these machines?

    Thanks,

    Dave

  7. Re: sshd for SCO 5.05?

    dthacker wrote:
    > On Jun 18, 4:54 pm, "Brian K. White" wrote:
    >> ----- Original Message -----
    >> From: "dthacker"
    >>
    >> Newsgroups: comp.unix.sco.misc
    >> To:
    >> Sent: Wednesday, June 18, 2008 3:47 PM
    >> Subject: sshd for SCO 5.05?
    >>
    >>> I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    >>> be kept alive, kicking, and a bit more secure for 12 months or so.
    >>> I'm looking for
    >>> a) some kind of sshd package for this version of SCO unix
    >>> b) gcc so I could potentially compile an sshd package
    >>> c) any resources for compiling and running open source utilities.
    >>> Any pointers to repositories, FAQ's, or other materials is welcome.
    >>> Thanks in advance!

    >> Install, update, or verify already installed, in this order:
    >> ftp://ftp.sco.com/pub/openserver5/rs505a/
    >> ftp://ftp.sco.com/pub/openserver5/oss646c/
    >> ftp://ftp.sco.com/pub/openserver5/op...xlibs-2.1.0Ba/
    >> ftp://ftp.jpr.com/pub/openssh-4.5p1.tar.gz

    >
    > How would I verify the patch level on these machines?
    >


    Maybe
    customquery ListPatches SCO:Unix
    customquery ListPatches SCO:gwxlibs
    ...


    --
    RGB

  8. Re: sshd for SCO 5.05?

    On Jun 18, 2:47*pm, dthacker wrote:
    > I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    > be kept alive, kicking, and a bit more secure for 12 months or so.
    > I'm looking for
    >
    > a) some kind of sshd package for this version of SCO unix
    > b) gcc so I could potentially compile an sshd package
    > c) any resources for compiling and running open source utilities.
    >
    > Any pointers to repositories, FAQ's, or other materials is welcome.
    >
    > Thanks in advance!
    >
    > Dave


    Hello Dave,

    Today I install OpenSSH in my SCO OpenServer 5.0.7, I follow the
    instruction that I found in http://www.atcs.net/ssh_osr5.htm.

    Good luck

  9. Re: sshd for SCO 5.05?

    durbina wrote:
    > On Jun 18, 2:47 pm, dthacker wrote:
    >> I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    >> be kept alive, kicking, and a bit more secure for 12 months or so.
    >> I'm looking for
    >>
    >> a) some kind of sshd package for this version of SCO unix
    >> b) gcc so I could potentially compile an sshd package
    >> c) any resources for compiling and running open source utilities.
    >>
    >> Any pointers to repositories, FAQ's, or other materials is welcome.
    >>
    >> Thanks in advance!
    >>
    >> Dave

    >
    > Hello Dave,
    >
    > Today I install OpenSSH in my SCO OpenServer 5.0.7, I follow the
    > instruction that I found in http://www.atcs.net/ssh_osr5.htm.
    >
    > Good luck


    Say what?

    5.0.7 comes with OpenSSH standard and enabled right out of the box.

    --
    ----------------------------------------------------
    Pat Welch, UBB Computer Services, a WCS Affiliate
    SCO Authorized Partner
    Microlite BackupEdge Certified Reseller
    Unix/Linux/Windows/Hardware Sales/Support
    (209) 745-1401 Cell: (209) 251-9120
    E-mail: patubb@inreach.com
    ----------------------------------------------------

  10. Re: sshd for SCO 5.05?

    Pat Welch wrote:
    > durbina wrote:
    >> On Jun 18, 2:47 pm, dthacker wrote:
    >>> I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    >>> be kept alive, kicking, and a bit more secure for 12 months or so.
    >>> I'm looking for
    >>>
    >>> a) some kind of sshd package for this version of SCO unix
    >>> b) gcc so I could potentially compile an sshd package
    >>> c) any resources for compiling and running open source utilities.
    >>>
    >>> Any pointers to repositories, FAQ's, or other materials is welcome.
    >>>
    >>> Thanks in advance!
    >>>
    >>> Dave

    >>
    >> Hello Dave,
    >>
    >> Today I install OpenSSH in my SCO OpenServer 5.0.7, I follow the
    >> instruction that I found in http://www.atcs.net/ssh_osr5.htm.
    >>
    >> Good luck

    >
    > Say what?
    >
    > 5.0.7 comes with OpenSSH standard and enabled right out of the box.
    >


    And 5.0.6 has a much more recent version installable as well, easily
    downloaded. I wonder if this
    (ftp://ftp.sco.com/pub/openserver5/op...nssh-4.2p1.txt)
    will install on 5.0.5, with all the updates in place?

  11. Re: sshd for SCO 5.05?

    Nico Kadel-Garcia wrote:
    > Pat Welch wrote:
    >> durbina wrote:
    >>> On Jun 18, 2:47 pm, dthacker wrote:
    >>>> I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    >>>> be kept alive, kicking, and a bit more secure for 12 months or so.
    >>>> I'm looking for
    >>>>
    >>>> a) some kind of sshd package for this version of SCO unix
    >>>> b) gcc so I could potentially compile an sshd package
    >>>> c) any resources for compiling and running open source utilities.
    >>>>
    >>>> Any pointers to repositories, FAQ's, or other materials is welcome.
    >>>>
    >>>> Thanks in advance!
    >>>>
    >>>> Dave
    >>>
    >>> Hello Dave,
    >>>
    >>> Today I install OpenSSH in my SCO OpenServer 5.0.7, I follow the
    >>> instruction that I found in http://www.atcs.net/ssh_osr5.htm.
    >>>
    >>> Good luck

    >>
    >> Say what?
    >>
    >> 5.0.7 comes with OpenSSH standard and enabled right out of the box.
    >>

    >
    > And 5.0.6 has a much more recent version installable as well, easily
    > downloaded. I wonder if this
    > (ftp://ftp.sco.com/pub/openserver5/op...nssh-4.2p1.txt)
    > will install on 5.0.5, with all the updates in place?


    Haven't tried that on 5.0.5, but I have installed the older v 3.4 one at
    several 5.0.5 sites in the past and that version at least has worked well.

    --
    ----------------------------------------------------
    Pat Welch, UBB Computer Services, a WCS Affiliate
    SCO Authorized Partner
    Microlite BackupEdge Certified Reseller
    Unix/Linux/Windows/Hardware Sales/Support
    (209) 745-1401 Cell: (209) 251-9120
    E-mail: patubb@inreach.com
    ----------------------------------------------------

  12. Re: sshd for SCO 5.05?

    On Jul 6, 5:54*am, Pat Welch wrote:
    > Nico Kadel-Garcia wrote:
    > > Pat Welch wrote:
    > >> durbina wrote:
    > >>> On Jun 18, 2:47 pm, dthacker wrote:
    > >>>> I just inherited the admin of a bunch of 3.2v5.0.5 servers which must
    > >>>> be kept alive, kicking, and a bit more secure for 12 months or so.
    > >>>> I'm looking for

    >
    > >>>> a) some kind of sshd package for this version of SCO unix
    > >>>> b) gcc so I could potentially compile an sshd package
    > >>>> c) any resources for compiling and running open source utilities.

    >
    > >>>> Any pointers to repositories, FAQ's, or other materials is welcome.

    >
    > >>>> Thanks in advance!

    >
    > >>>> Dave

    >
    > >>> Hello Dave,

    >
    > >>> Today I install OpenSSH in my SCO OpenServer *5.0.7, I follow the
    > >>> instruction that I found inhttp://www.atcs.net/ssh_osr5.htm.

    >
    > >>> Good luck

    >
    > >> Say what?

    >
    > >> 5.0.7 comes with OpenSSH standard and enabled right out of the box.

    >
    > > And 5.0.6 has a much more recent version installable as well, easily
    > > downloaded. I wonder if this
    > > (ftp://ftp.sco.com/pub/openserver5/op.../openssh-4.2p1....)
    > > will install on 5.0.5, with all the updates in place?

    >
    > Haven't tried that on 5.0.5, but I have installed the older v 3.4 one at
    > several 5.0.5 sites in the past and that version at least has worked well..
    >
    > --
    > ----------------------------------------------------
    > Pat Welch, UBB Computer Services, a WCS Affiliate
    > * * * * * * SCO Authorized Partner
    > * * * * * * Microlite BackupEdge Certified Reseller
    > * * * * * * Unix/Linux/Windows/Hardware Sales/Support
    > * * * * * * (209) 745-1401 Cell: (209) 251-9120
    > * * * * * * E-mail: pat...@inreach.com
    > ----------------------------------------------------


    Here are my notes, slightly edited, on installing openssh 4.2 on SCO
    5.0.5, which I had working on some client systems, but which have all
    been upgraded, so no lectures please.

    Before starting:

    If you had loaded ssh, prng and zlib before, uninstall them using
    custom.
    Clean up /etc/rc2.d and /etc/init.d to stop old versions from loading.

    1. On a 5.0.5 or greater box, install OSS646c. It isn't documented to
    work with 5.0.5 but it seems to
    work fine.

    2. Reboot

    3. Install the gwxlibs package with custom. gwxlibs package includes
    a new
    prng package.

    4. Install the openssh 4.x package.

    5. Edit the file /etc/ssh/sshd_config and add the line:

    AllowUsers {user} {user} {user}....

    To only allow connections from selected users.

    Uncomment the PermitRootLogin line and change the argument to 'no'.

    6. Reboot (or kill -1 `echo /etc/sshd.pid`), then test.

    7. If using the AlphaCom package, you may need to upgrade to AlphaCom
    6
    to avoid security messages.

    Good luck.

+ Reply to Thread