Problem with compiler for sco unix in Linux - SCO

This is a discussion on Problem with compiler for sco unix in Linux - SCO ; I have an old compiler (microfocus cobol) running under sco unix 3.2.4. Now I use it under RH 8.0 with abi-ibcs, but now I have to change pc and in the new distro with kernel 2.6 there isn't abi-ibcs. How ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Problem with compiler for sco unix in Linux

  1. Problem with compiler for sco unix in Linux

    I have an old compiler (microfocus cobol) running under sco unix 3.2.4.
    Now I use it under RH 8.0 with abi-ibcs, but now I have to change pc and
    in the new distro with kernel 2.6 there isn't abi-ibcs. How can I do ?

  2. Re: Problem with compiler for sco unix in Linux

    There are still kernel patches around but you wil have to patch and
    build your own kernel.

    ie:

    http://www.feise.com/~jfeise/Downloads/linux-abi/

    I have used the link below with Debian Sarge

    http://ace-host.stuart.id.au/russell...atch-linuxabi/

    Glenn


    pac wrote:
    > I have an old compiler (microfocus cobol) running under sco unix 3.2.4.
    > Now I use it under RH 8.0 with abi-ibcs, but now I have to change pc and
    > in the new distro with kernel 2.6 there isn't abi-ibcs. How can I do ?


  3. Re: Problem with compiler for sco unix in Linux

    On Sun, Mar 30, 2008, pac wrote:
    >I have an old compiler (microfocus cobol) running under sco unix 3.2.4.
    >Now I use it under RH 8.0 with abi-ibcs, but now I have to change pc and
    >in the new distro with kernel 2.6 there isn't abi-ibcs. How can I do ?


    The last Linux I've found that reliably has run SCO COFF applications with
    the linux-abi was SuSE 9.0 Pro. The last new OpenServer installation I did
    was one where they were still running 80286 Xenix binaries which, to the
    best of my knowledge, never ran under Linux.

    Today, I would probably run the old SCO applications under VMware rather
    than dealing with the linux-abi.

    Bill
    --
    INTERNET: bill@celestial.com Bill Campbell; Celestial Software LLC
    URL: http://www.celestial.com/ PO Box 820; 6641 E. Mercer Way
    FAX: (206) 232-9186 Mercer Island, WA 98040-0820; (206) 236-1676

    I have no reason to suppose that he, who would take away my Liberty, would
    not when he had me in his Power, take away everything else. John Locke

  4. Re: Problem with compiler for sco unix in Linux

    Glenn ha scritto:
    > There are still kernel patches around but you wil have to patch and
    > build your own kernel.
    >
    > ie:
    >
    > http://www.feise.com/~jfeise/Downloads/linux-abi/
    >
    > I have used the link below with Debian Sarge
    >
    > http://ace-host.stuart.id.au/russell...atch-linuxabi/
    >

    I have tried debian's patch and it's ok !!!
    Thank's
    >
    > Glenn
    >
    >
    > pac wrote:
    >> I have an old compiler (microfocus cobol) running under sco unix 3.2.4.
    >> Now I use it under RH 8.0 with abi-ibcs, but now I have to change pc and
    >> in the new distro with kernel 2.6 there isn't abi-ibcs. How can I do ?


+ Reply to Thread