OpenServer 5 and OpenServer 6 compatibility - SCO

This is a discussion on OpenServer 5 and OpenServer 6 compatibility - SCO ; I support both OS5 and OS6 SCO customers. I tend to build all applications on OS5 and distributed to both OS5 and OS6 customers. This has always worked until I began using pseudo terminals. I have a "shell" that uses ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: OpenServer 5 and OpenServer 6 compatibility

  1. OpenServer 5 and OpenServer 6 compatibility

    I support both OS5 and OS6 SCO customers. I tend to build all
    applications on OS5 and distributed to both OS5 and OS6 customers.
    This has always worked until I began using pseudo terminals.

    I have a "shell" that uses pseudo terminals to drive the application
    passed on the command line. When I build on OS5 it works fine. When
    I build on OS6 it works fine. When I build on OS5 but deploy and
    execute on OS6, getpgid() -- used to insure the application is still
    active -- an EPERM (89) is generated by getpgid().

    Any ideas?


  2. Re: OpenServer 5 and OpenServer 6 compatibility

    CJ typed (on Thu, May 31, 2007 at 09:20:05AM -0700):
    | I support both OS5 and OS6 SCO customers. I tend to build all
    | applications on OS5 and distributed to both OS5 and OS6 customers.
    | This has always worked until I began using pseudo terminals.
    |
    | I have a "shell" that uses pseudo terminals to drive the application
    | passed on the command line. When I build on OS5 it works fine. When
    | I build on OS6 it works fine. When I build on OS5 but deploy and
    | execute on OS6, getpgid() -- used to insure the application is still
    | active -- an EPERM (89) is generated by getpgid().

    Is oss646c installed on your OSR 5.0.x system?

    --
    JP
    ==> http://www.frappr.com/cusm <==

+ Reply to Thread