Psion Series 3c - Dead ? - Scion

This is a discussion on Psion Series 3c - Dead ? - Scion ; Hi, My psion s3C gives some strange things when I turn it on : SYS$SHLL.$05 process exited #60 I opened the beast to check everything inside. The solder points are clean and ok, ... I then removed all the batteries ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Psion Series 3c - Dead ?

  1. Psion Series 3c - Dead ?

    Hi,

    My psion s3C gives some strange things when I turn it on :

    SYS$SHLL.$05
    process exited #60

    I opened the beast to check everything inside.
    The solder points are clean and ok, ...
    I then removed all the batteries (the backup battery is dead, anyway) and pluged an adaptor.
    I got my psion working fine for some minutes, and decided to put everything back together.
    Same issue as above
    Redid the previous manipulation, and now get the sys$shll.05 thing all the time.

    Did someone experience this issue ?

    Thanx a lot,
    P.


    --------------= Posted using GrabIt =----------------
    ------= Binary Usenet downloading made easy =---------
    -= Get GrabIt for free from http://www.shemes.com/ =-


  2. Re: Psion Series 3c - Dead ?

    Hi.

    On my 3c SYS$HELL.$05 is the system shell. That is
    the main process that all other programs/processes
    need. It's part of the OS and is in ROM so i doubt it
    is faulty.

    But it won't run if something fundamental is wrong
    with the 3c. For your own sake, get it serviced.

    As far as I know, the best people here in the UK are
    Pinnock Organiser Services
    who now do Psion's own servicing for 3cs (and
    others).

    But first leave the thing to discharge for a few hours
    with no batteries at all. Put new batteries in and see
    if it comes back to full vigour, it might.

    Take care,
    Phil.

    "Time wounds all heels."

    http://aypee1.mysite.wanadoo-members.co.uk/index.html

+ Reply to Thread