Not able to ping by host name - Samba

This is a discussion on Not able to ping by host name - Samba ; Hi All, I am trying to set up dhcp on my arm platform. In order to do this I am doing the following : 1) Start dhcpcd as dhcpcd-bin -d -C -D -N -S -G -h MyBoard -L /etc/dhcpc eth0 ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Not able to ping by host name

  1. Not able to ping by host name

    Hi All,

    I am trying to set up dhcp on my arm platform.

    In order to do this I am doing the following :
    1) Start dhcpcd as
    dhcpcd-bin -d -C -D -N -S -G -h MyBoard -L /etc/dhcpc eth0

    2) Run nmbd
    nmbd -D -s /etc/smb.conf -l /etc/samba

    smb.conf contains
    [global]
    workgroup =lnx.pidnet.net
    dns proxy = yes


    I am able to get a valid IP address. But I am not able to ping my board by the

    host name which I supplied with -h option to dhcpcd-bin.

    If my domain name iis aaa.bbbbbb.net and host name is hhh then
    1) If I ping from my windows pc
    a) I am able to ping my board as 'ping hhh.bbbbbb.net'
    b) I am able to ping my board as 'ping hhh'
    c) But I am NOT able to ping my board as 'ping hhh.aaa.bbbbbb.net'

    2) If I ping from my linux pc
    a) I am able to ping my board as 'ping hhh.bbbbbb.net'
    b) I am NOT ABLE to ping my board as 'ping hhh'
    c) I am NOT ABLE to ping my board as 'ping hhh.aaa.bbbbbb.net'

    I am able to ping using the IP address from both Windows and Linux PC's.

    Following is the content of my /etc/dhcp/dhcpcd-eth0.info file

    IPADDR=10.27.105.126
    NETMASK=255.255.252.0
    NETWORK=10.27.104.0
    BROADCAST=10.27.107.255
    GATEWAY=10.27.104.7
    DOMAIN='aaa.bbbbbb.net'
    DNS=10.27.104.67,10.27.104.68
    DHCPSID=10.27.104.67
    DHCPGIADDR=0.0.0.0
    DHCPSIADDR=0.0.0.0
    DHCPCHADDR=00:60:35:0A:35:03
    DHCPSHADDR=00:0E:7F:7C:6F:98
    DHCPSNAME=''
    LEASETIME=691200
    RENEWALTIME=345600
    REBINDTIME=604800
    INTERFACE='eth0'
    CLASSID='Linux 2.6.10_dev-mainstone_pxa27x armv5tel'
    CLIENTID=00:60:35:0A:35:03

    Can any one tell if I am missing something or doing something wrong.

    I am not able to resolve the issue yet , any hints or suggestions are warmly

    welcome.

    thanks in advance.

    Regards
    vjn
    Last edited by vjn; 11-26-2009 at 04:49 PM. Reason: typo

  2. Re: Not able to ping by host name

    Any help on this !!!!

+ Reply to Thread