[Samba] samba with pam: ad accounts ok, local ones not - Samba

This is a discussion on [Samba] samba with pam: ad accounts ok, local ones not - Samba ; hi, my smb.conf looks like this: ... security = share update encrypted = yes encrypt passwords = no ... /etc/pam.d/samba: #%PAM-1.0 auth required pam_nologin.so auth required pam_stack.so service=system-auth account required pam_stack.so service=system-auth session required pam_stack.so service=system-auth password required pam_stack.so service=system-auth ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: [Samba] samba with pam: ad accounts ok, local ones not

  1. [Samba] samba with pam: ad accounts ok, local ones not


    hi,

    my smb.conf looks like this:

    ...
    security = share

    update encrypted = yes
    encrypt passwords = no
    ...

    /etc/pam.d/samba:

    #%PAM-1.0
    auth required pam_nologin.so
    auth required pam_stack.so service=system-auth
    account required pam_stack.so service=system-auth
    session required pam_stack.so service=system-auth
    password required pam_stack.so service=system-auth


    pam is configured so that local and active directory accounts can login
    (e.g. with ssh).
    samba works correctly with ad accounts, but does not with local accounts.
    what could be the problem?

    thanks for the help.
    --
    View this message in context: http://www.nabble.com/samba-with-pam...p18130507.html
    Sent from the Samba - General mailing list archive at Nabble.com.

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba


  2. Re: [Samba] samba with pam: ad accounts ok, local ones not

    Did you create NT passwords for the local users with smbpasswd -a?

    Also, why is your security setting on share? That seems a bit odd for
    AD integration.

    --Ryan

    On Thu, Jun 26, 2008 at 6:06 AM, alex.blackbit
    wrote:
    >
    > hi,
    >
    > my smb.conf looks like this:
    >
    > ...
    > security = share
    >
    > update encrypted = yes
    > encrypt passwords = no
    > ...
    >
    > /etc/pam.d/samba:
    >
    > #%PAM-1.0
    > auth required pam_nologin.so
    > auth required pam_stack.so service=system-auth
    > account required pam_stack.so service=system-auth
    > session required pam_stack.so service=system-auth
    > password required pam_stack.so service=system-auth
    >
    >
    > pam is configured so that local and active directory accounts can login
    > (e.g. with ssh).
    > samba works correctly with ad accounts, but does not with local accounts.
    > what could be the problem?
    >
    > thanks for the help.
    > --
    > View this message in context: http://www.nabble.com/samba-with-pam...p18130507.html
    > Sent from the Samba - General mailing list archive at Nabble.com.
    >
    > --
    > To unsubscribe from this list go to the following URL and read the
    > instructions: https://lists.samba.org/mailman/listinfo/samba
    >

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba


+ Reply to Thread