Samba 4 compilation error - Samba

This is a discussion on Samba 4 compilation error - Samba ; Hi Tonight, when compiling I got the following error: Compiling smbd/process_model.c smbd/process_model.c: In function 'process_model_init': smbd/process_model.c:87: error: 'process_model_thread_init' undeclared (first use in this function) smbd/process_model.c:87: error: (Each undeclared identifier is reported only once smbd/process_model.c:87: error: for each function it appears ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Samba 4 compilation error

  1. Samba 4 compilation error

    Hi

    Tonight, when compiling I got the following error:

    Compiling smbd/process_model.c
    smbd/process_model.c: In function 'process_model_init':
    smbd/process_model.c:87: error: 'process_model_thread_init' undeclared
    (first use in this function) smbd/process_model.c:87: error: (Each
    undeclared identifier is reported only once smbd/process_model.c:87:
    error: for each function it appears in.) The following command failed:
    gcc -Ilib/talloc -Ilib/replace
    -DSTATIC_process_model_MODULES="process_model_standard_init,
    process_model_prefork_init, process_model_thread_init,
    process_model_single_init,NULL" -fPIC -I./include -I. -I./lib
    -I./lib/replace -I./lib/talloc -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H -c
    smbd/process_model.c -o smbd/process_model.o

    I applied the attached patch and it compiled, that was all the testing
    I did. If it matters, I ran ./configure --with-pthreads.

    Please take a look and see if this is really a fix, there is always the
    chance I messed up my compilation!

    On an unrelated note, when doing git-diff, I got some changes on
    source/heimdal/lib/asn1/lex.c, given that this file is generated by
    flex, should it be under source control?

    Tiago


  2. Re: Samba 4 compilation error

    DUMB me!!!!

    On Sat, 14 Jun 2008 01:22:43 +0100
    Tiago Batista wrote:

    > Hi
    >
    > Tonight, when compiling I got the following error:
    >
    > Compiling smbd/process_model.c
    > smbd/process_model.c: In function 'process_model_init':
    > smbd/process_model.c:87: error: 'process_model_thread_init' undeclared
    > (first use in this function) smbd/process_model.c:87: error: (Each
    > undeclared identifier is reported only once smbd/process_model.c:87:
    > error: for each function it appears in.) The following command failed:
    > gcc -Ilib/talloc -Ilib/replace
    > -DSTATIC_process_model_MODULES="process_model_standard_init,
    > process_model_prefork_init, process_model_thread_init,
    > process_model_single_init,NULL" -fPIC -I./include -I. -I./lib
    > -I./lib/replace -I./lib/talloc -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H -c
    > smbd/process_model.c -o smbd/process_model.o
    >
    > I applied the attached patch and it compiled, that was all the testing
    > I did. If it matters, I ran ./configure --with-pthreads.
    >
    > Please take a look and see if this is really a fix, there is always
    > the chance I messed up my compilation!
    >
    > On an unrelated note, when doing git-diff, I got some changes on
    > source/heimdal/lib/asn1/lex.c, given that this file is generated by
    > flex, should it be under source control?
    >
    > Tiago



  3. Re: Samba 4 compilation error

    Hi Tiago,

    Am Samstag, den 14.06.2008, 01:22 +0100 schrieb Tiago Batista:
    > Tonight, when compiling I got the following error:
    >
    > Compiling smbd/process_model.c
    > smbd/process_model.c: In function 'process_model_init':
    > smbd/process_model.c:87: error: 'process_model_thread_init' undeclared
    > (first use in this function) smbd/process_model.c:87: error: (Each
    > undeclared identifier is reported only once smbd/process_model.c:87:
    > error: for each function it appears in.) The following command failed:
    > gcc -Ilib/talloc -Ilib/replace
    > -DSTATIC_process_model_MODULES="process_model_standard_init,
    > process_model_prefork_init, process_model_thread_init,
    > process_model_single_init,NULL" -fPIC -I./include -I. -I./lib
    > -I./lib/replace -I./lib/talloc -D_SAMBA_BUILD_=4 -DHAVE_CONFIG_H -c
    > smbd/process_model.c -o smbd/process_model.o
    >
    > I applied the attached patch and it compiled, that was all the testing
    > I did. If it matters, I ran ./configure --with-pthreads.

    --with-pthreads was apparently broken. Should be fixed in 280c411.

    > Please take a look and see if this is really a fix, there is always the
    > chance I messed up my compilation!
    >
    > On an unrelated note, when doing git-diff, I got some changes on
    > source/heimdal/lib/asn1/lex.c, given that this file is generated by
    > flex, should it be under source control?

    Yes, this file (like the files generated by SWIG) is under source
    control so people don't have to install a particular version of
    lex/yacc.

    Cheers,

    Jelmer
    --
    Jelmer Vernooij - http://samba.org/~jelmer/
    Jabber: jelmer@jabber.fsfe.org


+ Reply to Thread