I recently installed Fedora 9 for use as a squid server. We use smb_auth
basic authorization and have run into a problem with it. I believe that I
have tracked the problem down to smbclient when the USER environmental
variable contains the userid and password. smb_auth.sh in squid uses the
USER environmental variable. Below are test results for Version
3.0.28a-0.fc8 and Version 3.2.0pre3-9.fc9.

Note that typing in the password or putting it on the command line works
for both versions. However, USER="smbauth%test1234" fails with Version
3.2.0pre3-9.fc9



[testuser@bhssrv01 ~]$ smbclient -V
Version 3.0.28a-0.fc8
[testuser@bhssrv01 ~]$ USER="smbauth"
[testuser@bhssrv01 ~]$ smbclient "//hssrv01/netlogon" -c "get proxyauth -"
Password:
Domain=[EGHSLIB] OS=[Unix] Server=[Samba 3.0.28a-0.fc8]
allow
getting file \proxyauth of size 6 as - (5.9 kb/s) (average 5.9 kb/s)
[testuser@bhssrv01 ~]$ smbclient "//hssrv01/netlogon" test1234 -c "get
proxyauth -"
Domain=[EGHSLIB] OS=[Unix] Server=[Samba 3.0.28a-0.fc8]
allow
getting file \proxyauth of size 6 as - (5.9 kb/s) (average 5.9 kb/s)
[testuser@bhssrv01 ~]$ USER="smbauth%test1234"
[testuser@bhssrv01 ~]$ export USER
[testuser@bhssrv01 ~]$ smbclient "//hssrv01/netlogon" -c "get proxyauth -"
Domain=[EGHSLIB] OS=[Unix] Server=[Samba 3.0.28a-0.fc8]
allow
getting file \proxyauth of size 6 as - (5.9 kb/s) (average 5.9 kb/s)
[testuser@bhssrv01 ~]$




[testuser@bcen ~]$ smbclient -V
Version 3.2.0pre3-9.fc9
[testuser@bcen ~]$ USER="smbauth"
[testuser@bcen ~]$ smbclient "//hssrv01/netlogon" -c "get proxyauth -"
Enter smbauth's password:
Domain=[EGHSLIB] OS=[Unix] Server=[Samba 3.0.28a-0.fc8]
allow
getting file \proxyauth of size 6 as - (60000.0 kb/s) (average inf kb/s)
[testuser@bcen ~]$ smbclient "//hssrv01/netlogon" test1234 -c "get
proxyauth -"
Domain=[EGHSLIB] OS=[Unix] Server=[Samba 3.0.28a-0.fc8]
allow
getting file \proxyauth of size 6 as - (60000.0 kb/s) (average inf kb/s)
[testuser@bcen ~]$ USER="smbauth%test1234"
[testuser@bcen ~]$ export USER
[testuser@bcen ~]$ smbclient "//hssrv01/netlogon" -c "get proxyauth -"
session setup failed: NT_STATUS_LOGON_FAILURE
[testuser@bcen ~]$

Mark Orenstein
East Granby, CT, USA School System




--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

--
To unsubscribe from this list go to the following URL and read the
instructions: https://lists.samba.org/mailman/listinfo/samba