[Samba] net rpc commands not working - Samba

This is a discussion on [Samba] net rpc commands not working - Samba ; maybe this is a simple fix but i really don't know how to fix it... it seems that i cannot run any net rpc commands... i wanted to see the members of Domain Users group so i did the following: ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: [Samba] net rpc commands not working

  1. [Samba] net rpc commands not working

    maybe this is a simple fix but i really don't know how to fix it...

    it seems that i cannot run any net rpc commands...

    i wanted to see the members of Domain Users group so i did the following:

    root# net rpc group members "Domain Users" -Uroot%not24get

    and i got this error:

    Could not connect to server 127.0.0.1
    Connection failed: NT_STATUS_CONNECTION_REFUSED

    i can ping localhost without a problem

    i'm not sure why this is happening, does anyone have any ideas??? thanks.
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  2. Re: [Samba] net rpc commands not working

    On Mon, May 19, 2008 at 11:37 AM, Leandro Tracchia wrote:
    > maybe this is a simple fix but i really don't know how to fix it...
    >
    > it seems that i cannot run any net rpc commands...
    >
    > i wanted to see the members of Domain Users group so i did the following:
    >
    > root# net rpc group members "Domain Users" -Uroot%not24get
    >
    > and i got this error:
    >
    > Could not connect to server 127.0.0.1
    > Connection failed: NT_STATUS_CONNECTION_REFUSED
    >
    > i can ping localhost without a problem
    >


    Is samba running on the local host? Is it listening on 127.0.0.1? Did
    it ask for a password?

    John
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  3. Re: [Samba] net rpc commands not working

    On Mon, May 19, 2008 at 11:54 AM, Leandro Tracchia wrote:
    > yes, samba is running on the localhost...
    >
    > the command did not ask for a password because i used %not24get
    >
    > samba is listening on eth1
    >

    How about lo (as this is not eth1)?

    netstat -tulpen

    Also have you checked your samba logs?
    John
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  4. Re: [Samba] net rpc commands not working

    On Mon, May 19, 2008 at 12:33 PM, Leandro Tracchia wrote:
    > problem solved. i had to add 127.0.0.1 to the interfaces list of smb.conf.
    > this is because i had set bind interfaces only = yes.
    >
    > the manpage makes mention of smbpasswd not working properly if bind
    > interfaces only is set and the network address 127.0.0.1 is not added to the
    > interfaces parameter.
    >
    > i guess this also applies to correct functionality of the net rpc command,
    > although the man page makes no mention of this and i'm not very
    > knowledgeable to explain to you how it does apply. but it worked for me.
    >


    The reason for this is that eth1 and lo are seen as 2 different
    network cards and listening on eth1 does not allow you to listen on lo
    (which gives you 127.0.0.1).

    John
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  5. Re: [Samba] net rpc commands not working

    > The reason for this is that eth1 and lo are seen as 2 different
    > network cards and listening on eth1 does not allow you to listen on lo
    > (which gives you 127.0.0.1).
    >

    I should have worded that listening only on eth1 does not allow
    access to 127.0.0.1. You need to listen on lo as well or not bind to
    interfaces which will then listen on all vaild ip addresses for the
    server.

    John
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  6. Re: [Samba] net rpc commands not working

    problem solved. i had to add 127.0.0.1 to the interfaces list of smb.conf.
    this is because i had set bind interfaces only = yes.

    the manpage makes mention of smbpasswd not working properly if bind
    interfaces only is set and the network address 127.0.0.1 is not added to the
    interfaces parameter.

    i guess this also applies to correct functionality of the net rpc command,
    although the man page makes no mention of this and i'm not very
    knowledgeable to explain to you how it does apply. but it worked for me.

    thanks for your help john.

    On Mon, May 19, 2008 at 12:41 PM, John Drescher
    wrote:

    > > The reason for this is that eth1 and lo are seen as 2 different
    > > network cards and listening on eth1 does not allow you to listen on lo
    > > (which gives you 127.0.0.1).
    > >

    > I should have worded that listening only on eth1 does not allow
    > access to 127.0.0.1. You need to listen on lo as well or not bind to
    > interfaces which will then listen on all vaild ip addresses for the
    > server.
    >
    > John
    >

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

+ Reply to Thread