On Fri, Apr 25, 2008 at 12:20:19AM +0200, Michael wrote:
> Hello Everybody!
>
> I set up a fileserver:
> - Pentium II, 350 Mhz,
> - 256MB RAM,
> - Intel Fast Ethernet PCI
> - VIA-SATA Controller
> - 2x500GB SATA HDD RAID 1
> - Debian 4, Samba 3
> - Samba set up in user shares mode without special options, but with
> the suggested optimizations
>
> Clients:
> - Windows XP Prof SP2
>
> So far it works fine. I can read and write files without problem. But my
> bandwith seems to be limited somehow. When i copy one file i get a
> nearly constant transfer rate of about 6.8 MB/s (read and write).
> Do i copy two files in parallel i get a total transfer rate of about
> 10MB/s (again for read and write)
> with 3 files it is even around 11MB/s. Why i can't reach this transfer
> rate with just one file? It is the same from both windows pc.
>
> I benchmarked my network around 11.5MB/s are reached using netio
> (Win-Win,Win-Debian).
> The HDDs are reaching 60MB/s with hdparm -t /dev/sd?
>
> I search for such an issue, but didn't find something useful. I looked into
> the documentation, but didn't find some hints for that issue.
>
> How can i find the bootleneck in the system?


I'd guess the problem is the Windows redirector only
allowing one outstanding 64k read/write request on
the wire at a time. This is a known problem with
XP. To test is this is the case, try using smbclient
from another Linux box to write a file and see
if the throughput rises. We allow up to max mux
(protocol limit) outstanding requests on the
wire.

Jeremy.
--
To unsubscribe from this list go to the following URL and read the
instructions: https://lists.samba.org/mailman/listinfo/samba