I don't know what happened, but suddenly SAMBA quit working on my server
running Debian Etch. It was working just fine, but suddenly quit. I made
some small changes to smb.conf last night, and this afternoon it's not
working. I don't know if the chages caused the failure, or not, and I can't
see what would be wrong. It's a pretty simple setup. I can see the shares
on the network, but attempting to access any of them results in a "The
network name cannot be found" error on any of the windows clients.

/etc/samba/smb.conf

# Samba config file created using SWAT
# from 192.168.0.18 (192.168.0.18)
# Date: 2008/01/06 18:27:31

[global]
workgroup = HOME
server string = %h server
obey pam restrictions = Yes
guest account = lrhorer
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
syslog = 0
log file = /var/log/samba/%m.log
max log size = 1000
acl compatibility = winnt
server signing = auto
preferred master = No
domain master = No
dns proxy = No
ldap ssl = no
panic action = /usr/share/samba/panic-action %d
invalid users = root

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

[Server-Main]
path = /RAID/Server-Main
invalid users =
admin users = lrhorer
read only = No
guest ok = Yes
case sensitive = No
strict locking = No
msdfs proxy = no

[Liza]
path = /RAID/Personal_Folders/Liza
valid users = lrhorer, lgates
admin users = lrhorer
read only = No
create mask = 0700
directory mask = 0700
case sensitive = No
strict locking = No
msdfs proxy = no

[Leslie]
path = /RAID/Personal_Folders/Leslie
valid users = lrhorer
admin users = lrhorer
read only = No
case sensitive = No
strict locking = No
msdfs proxy = no

[TiVo Music]
path = /RAID/Music
invalid users =
read only = No
guest ok = Yes
case sensitive = No
strict locking = No
msdfs proxy = no

[Video]
path = /RAID/Recordings
invalid users =
admin users = lrhorer
read only = No
guest ok = Yes
case sensitive = No
strict locking = No
msdfs proxy = no


/var/log/winbdd.log

[2008/01/06 18:28:07, 0] nsswitch/winbindd_util.c:winbindd_param_init(787)
winbindd: idmap uid range missing or invalid
[2008/01/06 18:28:07, 0] nsswitch/winbindd_util.c:winbindd_param_init(788)
winbindd: cannot continue, exiting.
[2008/01/06 18:28:07, 1] nsswitch/winbindd.c:main(986)
Could not init idmap -- netlogon proxy only


Snippet of one machine log

[2008/01/06 18:38:20, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/01/06 18:38:20, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users
[2008/01/06 18:38:20, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/01/06 18:38:20, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users