[Samba] Cannot join domain with error: ads_connect: No logon servers - Samba

This is a discussion on [Samba] Cannot join domain with error: ads_connect: No logon servers - Samba ; Hello All, I am trying to get a Gentoo Linux system to join a domain run by a Mac OS X Server. I have set up kerberos and ldap as per the instructions in the Samba documentation and I am ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: [Samba] Cannot join domain with error: ads_connect: No logon servers

  1. [Samba] Cannot join domain with error: ads_connect: No logon servers

    Hello All,

    I am trying to get a Gentoo Linux system to join a domain run by a Mac
    OS X Server. I have set up kerberos and ldap as per the instructions
    in the Samba documentation and I am able to log in to the system using
    the info (getent finds the users, and kinit successfully connects),
    but I can't get Samba to join the domain and authenticate the users.
    When I run "net ads join" I get:

    [2007/12/17 19:16:07, 0] utils/net_ads.c:ads_startup_int(286)
    ads_connect: No logon servers
    Failed to join domain: No logon servers

    I have tried searching google for this, but have found no response.
    Does anybody know what the problem is?

    Thanks for any help.
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  2. Re: [Samba] Cannot join domain with error: ads_connect: No logon servers

    there is a switch to specify the server name. I was having a similar
    problem that was solved specifying it's name.
    try:

    net -d ads join -s your_server_dns

    don't forget to add your_server_dns to /etc/hosts

    On Dec 18, 2007 3:20 AM, Jean-Pierre Gillione wrote:
    > Hello All,
    >
    > I am trying to get a Gentoo Linux system to join a domain run by a Mac
    > OS X Server. I have set up kerberos and ldap as per the instructions
    > in the Samba documentation and I am able to log in to the system using
    > the info (getent finds the users, and kinit successfully connects),
    > but I can't get Samba to join the domain and authenticate the users.
    > When I run "net ads join" I get:
    >
    > [2007/12/17 19:16:07, 0] utils/net_ads.c:ads_startup_int(286)
    > ads_connect: No logon servers
    > Failed to join domain: No logon servers
    >
    > I have tried searching google for this, but have found no response.
    > Does anybody know what the problem is?
    >
    > Thanks for any help.
    > --
    > To unsubscribe from this list go to the following URL and read the
    > instructions: https://lists.samba.org/mailman/listinfo/samba
    >

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  3. Re: [Samba] Cannot join domain with error: ads_connect: No logon servers

    Thank You for the response Carlos. I tried specifying the server and
    that doesn't help. So I ran it in debug mode. Here is what I think
    is the relevant output:

    [2007/12/18 11:19:12, 5] lib/debug.c:debug_dump_status(391)
    INFO: Current debug levels:
    all: True/5
    tdb: False/0
    printdrivers: False/0
    lanman: False/0
    smb: False/0
    rpc_parse: False/0
    rpc_srv: False/0
    rpc_cli: False/0
    passdb: False/0
    sam: False/0
    auth: False/0
    winbind: False/0
    vfs: False/0
    idmap: False/0
    quota: False/0
    acls: False/0
    locking: False/0
    msdfs: False/0
    dmapi: False/0
    [2007/12/18 11:19:12, 3] param/loadparm.c:lp_load(5031)
    lp_load: refreshing parameters
    [2007/12/18 11:19:12, 3] param/loadparm.c:init_globals(1430)
    Initialising global parameters
    [2007/12/18 11:19:12, 3] param/params.cm_process(572)
    params.cm_process() - Processing configuration file "/etc/samba/smb.conf"
    [2007/12/18 11:19:12, 3] param/loadparm.c:do_section(3770)
    Processing section "[global]"
    doing parameter workgroup = s2
    doing parameter realm = LEOPARD.SAFARI.INSIDE
    doing parameter security = ADS
    doing parameter server string = File Server
    doing parameter wins server = 10.0.0.10
    doing parameter password server = 10.0.0.10
    doing parameter preferred master = No
    doing parameter domain master = No
    doing parameter wins proxy = No
    doing parameter dns proxy = No
    doing parameter load printers = No
    doing parameter socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    [2007/12/18 11:19:12, 5] lib/util.c:init_names(287)
    Netbios name list:-
    my_netbios_names[0]="ELEPHANT"
    [2007/12/18 11:19:12, 2] lib/interface.c:add_interface(81)
    added interface ip=10.0.0.4 bcast=10.0.0.255 nmask=255.255.255.0
    [2007/12/18 11:19:12, 5] lib/gencache.c:gencache_init(61)
    Opening cache file at /var/cache/samba/gencache.tdb
    [2007/12/18 11:19:12, 5] libads/dns.c:sitename_fetch(674)
    sitename_fetch: No stored sitename for LEOPARD.SAFARI.INSIDE
    [2007/12/18 11:19:12, 4] libsmb/namequery_dc.c:ads_dc_name(73)
    ads_dc_name: domain=S2
    [2007/12/18 11:19:12, 5] libads/dns.c:sitename_fetch(674)
    sitename_fetch: No stored sitename for LEOPARD.SAFARI.INSIDE
    [2007/12/18 11:19:12, 5] libsmb/namequery.c:saf_fetch(133)
    saf_fetch: failed to find server for "LEOPARD.SAFARI.INSIDE" domain
    [2007/12/18 11:19:12, 3] libsmb/namequery.c:get_dc_list(1489)
    get_dc_list: preferred server list: ", 10.0.0.10"
    [2007/12/18 11:19:12, 5] libads/dns.c:sitename_fetch(674)
    sitename_fetch: No stored sitename for LEOPARD.SAFARI.INSIDE
    [2007/12/18 11:19:12, 4] libsmb/namequery.c:get_dc_list(1599)
    get_dc_list: returning 1 ip addresses in an ordered list
    [2007/12/18 11:19:12, 4] libsmb/namequery.c:get_dc_list(1600)
    get_dc_list: 10.0.0.10:389
    [2007/12/18 11:19:12, 5] libads/ldap.c:ads_try_connect(180)
    ads_try_connect: sending CLDAP request to 10.0.0.10 (realm:
    LEOPARD.SAFARI.INSIDE)
    [2007/12/18 11:19:12, 1] libads/cldap.c:recv_cldap_netlogon(219)
    no reply received to cldap netlogon
    [2007/12/18 11:19:12, 3] libads/ldap.c:ads_try_connect(189)
    ads_try_connect: CLDAP request 10.0.0.10 failed.
    [2007/12/18 11:19:12, 5] libsmb/namequery.c:saf_fetch(133)
    saf_fetch: failed to find server for "S2" domain
    [2007/12/18 11:19:12, 3] libsmb/namequery.c:get_dc_list(1489)
    get_dc_list: preferred server list: ", 10.0.0.10"
    [2007/12/18 11:19:12, 5] libads/dns.c:sitename_fetch(674)
    sitename_fetch: No stored sitename for LEOPARD.SAFARI.INSIDE
    [2007/12/18 11:19:12, 4] libsmb/namequery.c:get_dc_list(1599)
    get_dc_list: returning 1 ip addresses in an ordered list
    [2007/12/18 11:19:12, 4] libsmb/namequery.c:get_dc_list(1600)
    get_dc_list: 10.0.0.10:389
    [2007/12/18 11:19:12, 5] libsmb/namecache.c:namecache_status_fetch(346)
    namecache_status_fetch: no entry for NBT/S2#1C.20.10.0.0.10 found.
    [2007/12/18 11:19:12, 5] libsmb/nmblib.c:send_udp(777)
    Sending a packet of len 50 to (10.0.0.10) on port 137
    [2007/12/18 11:19:12, 5] libsmb/nmblib.c:read_packet(755)
    Received a packet of len 265 from (10.0.0.10) port 137
    [2007/12/18 11:19:12, 4] libsmb/nmblib.c:debug_nmb_packet(112)
    nmb packet from 10.0.0.10(137) header: id=23715 opcode=Query(0) response=Yes
    header: flags: bcast=No rec_avail=No rec_des=No trunc=No auth=Yes
    header: rcode=0 qdcount=0 ancount=1 nscount=0 arcount=0
    answers: nmb_name=S2<1c> rr_type=33 rr_class=1 ttl=0
    answers 0 char .LEOPARD hex 094C454F504152442020202020202020
    answers 10 char .d.LEOPARD hex 0364004C454F50415244202020202020
    answers 20 char .d.LEOPARD hex 20200064004C454F5041524420202020
    answers 30 char d...__MSBRO hex 2020202020640001025F5F4D5342524F
    answers 40 char WSE__....S2 hex 5753455F5F0201E40053322020202020
    answers 50 char ...S2 hex 20202020202020201EE4005332202020
    answers 60 char .d.S2 hex 202020202020202020201D6400533220
    answers 70 char ...S hex 20202020202020202020202000E40053
    answers 80 char 2 .d hex 32202020202020202020202020201B64
    answers 90 char .S2 hex 00533220202020202020202020202020
    answers a0 char ................ hex 1CE40000000000000000000000000000
    answers b0 char ................ hex 00000000000000000000000000000000
    answers c0 char ................ hex 00000000000000000000000000000000
    answers d0 char . hex 00
    [2007/12/18 11:19:12, 3] libsmb/namequery_dc.c:rpc_dc_name(194)
    rpc_dc_name: Returning DC LEOPARD (10.0.0.10) for domain S2
    [2007/12/18 11:19:12, 5] libads/dns.c:sitename_fetch(674)
    sitename_fetch: No stored sitename for LEOPARD.SAFARI.INSIDE
    [2007/12/18 11:19:12, 5] libsmb/namequery.c:saf_fetch(133)
    saf_fetch: failed to find server for "LEOPARD.SAFARI.INSIDE" domain
    [2007/12/18 11:19:12, 3] libsmb/namequery.c:get_dc_list(1489)
    get_dc_list: preferred server list: ", 10.0.0.10"
    [2007/12/18 11:19:12, 5] libads/dns.c:sitename_fetch(674)
    sitename_fetch: No stored sitename for LEOPARD.SAFARI.INSIDE
    [2007/12/18 11:19:12, 5] libsmb/namequery.c:get_dc_list(1577)
    get_dc_list: negative entry 10.0.0.10 removed from DC list
    [2007/12/18 11:19:12, 4] libsmb/namequery.c:get_dc_list(1599)
    get_dc_list: returning 0 ip addresses in an ordered list
    [2007/12/18 11:19:12, 4] libsmb/namequery.c:get_dc_list(1600)
    get_dc_list:
    [2007/12/18 11:19:12, 5] libsmb/namequery.c:saf_fetch(133)
    saf_fetch: failed to find server for "LEOPARD.SAFARI.INSIDE" domain
    [2007/12/18 11:19:12, 3] libsmb/namequery.c:get_dc_list(1489)
    get_dc_list: preferred server list: ", 10.0.0.10"
    [2007/12/18 11:19:12, 5] libads/dns.c:sitename_fetch(674)
    sitename_fetch: No stored sitename for LEOPARD.SAFARI.INSIDE
    [2007/12/18 11:19:12, 5] libsmb/namequery.c:get_dc_list(1577)
    get_dc_list: negative entry 10.0.0.10 removed from DC list
    [2007/12/18 11:19:12, 4] libsmb/namequery.c:get_dc_list(1599)
    get_dc_list: returning 0 ip addresses in an unordered list
    [2007/12/18 11:19:12, 4] libsmb/namequery.c:get_dc_list(1600)
    get_dc_list:
    [2007/12/18 11:19:12, 0] utils/net_ads.c:ads_startup_int(286)
    ads_connect: No logon servers
    [2007/12/18 11:19:12, 1] utils/net_ads.c:net_ads_join(1470)
    error on ads_startup: No logon servers
    Failed to join domain: No logon servers
    [2007/12/18 11:19:12, 2] utils/net.c:main(1036)
    return code = -1


    On Dec 18, 2007 8:13 AM, Carlos Ramos wrote:
    > there is a switch to specify the server name. I was having a similar
    > problem that was solved specifying it's name.
    > try:
    >
    > net -d ads join -s your_server_dns
    >
    > don't forget to add your_server_dns to /etc/hosts
    >
    >
    > On Dec 18, 2007 3:20 AM, Jean-Pierre Gillione wrote:
    > > Hello All,
    > >
    > > I am trying to get a Gentoo Linux system to join a domain run by a Mac
    > > OS X Server. I have set up kerberos and ldap as per the instructions
    > > in the Samba documentation and I am able to log in to the system using
    > > the info (getent finds the users, and kinit successfully connects),
    > > but I can't get Samba to join the domain and authenticate the users.
    > > When I run "net ads join" I get:
    > >
    > > [2007/12/17 19:16:07, 0] utils/net_ads.c:ads_startup_int(286)
    > > ads_connect: No logon servers
    > > Failed to join domain: No logon servers
    > >
    > > I have tried searching google for this, but have found no response.
    > > Does anybody know what the problem is?
    > >
    > > Thanks for any help.
    > > --
    > > To unsubscribe from this list go to the following URL and read the
    > > instructions: https://lists.samba.org/mailman/listinfo/samba
    > >

    >

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

+ Reply to Thread