Hi all,



On my Suse 9.3 prof. server I had two NIC’s:



Eth0 IP 192.168.1.1

Eth1 IP 192.168.2.1



Now I added new NIC (eth2)



Eth0 IP 192.168.1.1

Eth1 IP 192.168.2.1

Eth2 IP 192.168.1.2



Now I erased eth0 config and turned off this NIC in motherboard bios



Eth1 IP 192.168.2.1

Eth2 IP 192.168.1.2



I renamed eth2 to eth0



Eth1 IP 192.168.2.1

Eth0 IP 192.168.1.2



And, finally I changed IP of eth0



Eth1 IP 192.168.2.1

Eth0 IP 192.168.1.1



So, now I have same setup as I had before but with new NIC at place.



Swat is working as it should, but when I press “status” button in swat, smbd
and nmbd are shown as not started, but my samba works well. Anyway, in
/var/log/samba/log.swat when I press “status” button I have:



[2006/03/29 08:34:16, 2] lib/util_sock.cpen_socket_out(789)

error connecting to 192.168.1.2:445 (No route to host)

[2006/03/29 08:34:19, 2] lib/util_sock.cpen_socket_out(789)

error connecting to 192.168.1.2:139 (No route to host)

[2006/03/29 08:34:19, 1] libsmb/cliconnect.c:cli_connect(1326)

Error connecting to 192.168.1.2 (No route to host)

[2006/03/29 08:34:22, 2] lib/util_sock.cpen_socket_out(789)

error connecting to 192.168.1.2:445 (No route to host)

[2006/03/29 08:34:25, 2] lib/util_sock.cpen_socket_out(789)

error connecting to 192.168.1.2:139 (No route to host)

[2006/03/29 08:34:25, 1] libsmb/cliconnect.c:cli_connect(1326)

Error connecting to 192.168.1.2 (No route to host)

[2006/03/29 08:34:25, 0] libsmb/nmblib.c:send_udp(790)

Packet send failed to 192.168.1.2(137) ERRNO=Invalid argument

[2006/03/29 08:34:25, 0] libsmb/nmblib.c:send_udp(790)

Packet send failed to 192.168.1.2(137) ERRNO=Invalid argument



As you can see, swat is somehow using IP 192.168.1.2 that is not in use now,
instead of 192.168.1.1 of 192.168.2.1.



server:/var/log/samba # ifconfig

eth0 Link encap:Ethernet HWaddr 00:11:95:5F:F2:6F

inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0

inet6 addr: fe80::211:95ff:fe5f:f26f/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:649842 errors:0 dropped:0 overruns:0 frame:0

TX packets:771539 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:153367849 (146.2 Mb) TX bytes:431793577 (411.7 Mb)

Interrupt:185 Base address:0x4000



eth1 Link encap:Ethernet HWaddr 00:11:95:5F:F2:72

inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0

inet6 addr: fe80::211:95ff:fe5f:f272/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:5168465 errors:0 dropped:0 overruns:0 frame:0

TX packets:6542625 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:961455736 (916.9 Mb) TX bytes:5116440423 (4879.4 Mb)

Interrupt:217 Base address:0x6000



lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:225478 errors:0 dropped:0 overruns:0 frame:0

TX packets:225478 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:75038623 (71.5 Mb) TX bytes:75038623 (71.5 Mb)



server:/var/log/samba # route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use
Iface

192.168.2.0 * 255.255.255.0 U 0 0 0 eth1

192.168.1.0 * 255.255.255.0 U 0 0 0 eth0

loopback * 255.0.0.0 U 0 0 0 lo

server:/var/log/samba #



I can’t figure out where this 192.168.1.2 is written?





Zoran


--
To unsubscribe from this list go to the following URL and read the
instructions: https://lists.samba.org/mailman/listinfo/samba