Hi I have installed Solari 9 on SunFire e450 box and installed latest
Solaris patches. Then I have downloaded samba-latest.tar.gz and along
with it the following packages

gcc-3.4.6-sol9-sparc-local.gz
samba-latest.tar.gz
libiconv-1.11.tar.gz

Then
# gunzip gcc-3.4.6-sol9-sparc-local.gz
# gunzip samba-latest.tar.gz
# gunzip libiconv-1.11.tar.gz

pkgadd -d gcc-3.4.6-sol9-sparc-local
pkgadd -d libiconv-1.11

then cd /u02/stage

# ls -ltr
gcc-3.4.6-sol9-sparc-local
libiconv-1.11
samba-3.0.23d

# which gcc
/usr/local/bin/gcc
# tar -xvf samba-latest.tar
# samba-3.0.23d
# cd samba-3.0.23d/source
#./configure
SAMBA VERSION: 3.0.23d
checking for -fPIE...
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C
compiler cannot create executables
See `config.log' for more details.
# pkginfo SMCgcc
application SMCgcc gcc

# cd libiconv-1.11
# ./configure
checking for a BSD-compatible install... build-aux/install-sh -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether make sets $(MAKE)... no
checking whether make sets $(MAKE)... (cached) no
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C
compiler cannot create executables
See `config.log' for more details.

I am stuck here. Could anyone please advise what I need to do to get
libiconv, gcc & damba installed. Thanks in advance