On 3/28/06, McDougald, James D. (Contr) wrote:
> I am Running IRIX 6.5.28 and I am still having this problem. I just can
> not get ADS support in Samba to compile. I have Kerberos and ldap and I
> can even use kinit to authenticate against the ads server in the Windows
> domain, but the Samba install chokes and says libldap is required for
> ads support. I am at a loss. This does not make sense unless the
> configure script can not follow symlinks as the ldap libs live in
> /usr/freeware/lib32 and I have them symlinked to /usr/lib.


The latest version of fw_openldap I can see in Freeware is 2.1.21. IRIX
6.5.28 ships with openldap 2.2.23. This does include the development
headers.

You should remove your symlink and install the openldap subsystem from
the CD 3. You will need at least openldap.sw.lib32 and openldap.sw.hdr.

> Anyone running samba 3.0 or higher for IRIX 6.5.28 willing to share
> built binaries?
>
> As an asides, I can build samba 3.0.21c for this host with no issues as
> a normal NT domain member without ADS.
>
> Thank You
>
> J. Darrin McDougald
>
> -----Original Message-----
> From: Jason Mader [mailto:jason@ncac.gwu.edu]
> Sent: Friday, March 24, 2006 10:30 AM
> To: samba@lists.samba.org
> Cc: McDougald, James D. (Contr)
> Subject: Re: [Samba] SAMBA install on IRIX 6.5
>
> On Fri, 24 Mar 2006, James Peach wrote:
>
> > Use IRIX 6.5.22 or later. From 6.5.22 onwards, kerberos, openldap and
> > openssl were bundled with the base OS. I've never attempted to build
> > against the Freeware versions.

>
> Irix doesn't bundle Kerberos headers, won't that be a problem?


I'm asking about this ...

--
James Peach | jorgar@gmail.com
--
To unsubscribe from this list go to the following URL and read the
instructions: https://lists.samba.org/mailman/listinfo/samba