Greetings all,

I'm attempting to move a Samba-2 PDC to a new server and upgrade it to
Samba-3. I'm seeing the error message "get_md4pw: Workstation WS1$: no
account in domain". I have read the instructions at:

http://www.samba.org/samba/docs/man/.../upgrades.html

The new server and a test workstation (WS1) are on a separate network to
avoid interference with the live network. I have:

1) Made sure the new server has the same network settings as the current
one: IP address, hostname, etc.

2) Copied relevant accounts/groups from /etc/passwd, /etc/shadow
& /etc/group from the old server to the new server.

3) Copied configuration files in /etc/samba from the current server to
the new server, including smb.conf, smbpasswd and secrets.tdb.

4) Copied all *.tdb files from /var/cache/samba to the new server.

According to the instructions, it seems like Samba should automatically
read & upgrade the *.tdb files, preserving my existing domain, but this
doesn't appear to be the case.

Does the workstation case make any difference? Existing workstations
are in lowercase, the error is all uppercase?

I didn't add a script for "add machine script" to smb.conf. I've added
the machine accounts in the past and since there should already be one,
I'm guessing I don't need this configuration.

I have a feeling I've missed something simple, but I don't know what it
is. Any help is most appreciated.

-Eric

--
Eric Sisler
Library Applications Specialist
Westminster Public Library
Westminster, CO USA

Linux - Don't fear the Penguin.
Want to know what we use Linux for?
Visit http://wallace.westminster.lib.co.us/linux

--
To unsubscribe from this list go to the following URL and read the
instructions: https://lists.samba.org/mailman/listinfo/samba