This is a multi-part message in MIME format.
--------------010202000805070701010604
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit

Hello mailing-list,

this is my first post and i hope that you enjoy my very bad but
sometimes funny english.

My Problem is the following:

First of all, my server-config:
Samba Version 3.0.20b-3.4-SUSE
on a
SUSE Linux Enterprise Server 9
with Kernel 2.6.5-7.252-smp


Now the problem is, that samba generally works fine, but it doesn't work
to work with a special application directly on a samba-share.
This app is EPLAN, who is configured to save his project-data on the
servershare, because of the fact that there everything will be backuped
regularly.

All this worked prior with a Windows Server 2003, which now should be
replaced with the linux samba-server.

Now when we switched to Samba for testing purposes the error occured,
that Windows throws the following Error while working with EPLAN on the
networkshare:

-----------------------------------------------------------------------
Windows - Datenverlust beim schreiben

Es konnten nicht alle Daten für die Datei \\UNC-Path-to-share\file.ext
gespeichert werden. Die Daten gingen verloren. Mögliche Ursache könnten
Computerhardware oder Netzwerkverbindung sein. Versuchen Sie, die Dateien...
-----------------------------------------------------------------------

which in english means something like
-----------------------------------------------------------------------
Windows - data loss at writing

It was not possible to save all data for the file
\\UNC-Path-to-share\file.ext. The data was lossed. Possible reasons can
be the Hardware or networkconnection. ...
-----------------------------------------------------------------------

Copying data on the share while using copy ans paste with the explorer
seems to be working fine.

I have no idea which reason this can have. Maybe some pro here outside
has an idea.
Of course there can be recognized something in the /var/log/messages:
------------------------------------------------------------------------
Mar 7 11:14:47 mve-server2 smbd[8195]: [2006/03/07 11:14:47, 0]
lib/util_sock.c:write_data(554)
Mar 7 11:14:47 mve-server2 smbd[8195]: write_data: write failure in
writing to client 0.0.0.0. Error Connection reset by peer
Mar 7 11:14:47 mve-server2 smbd[8195]: [2006/03/07 11:14:47, 0]
lib/util_sock.c:send_smb(762)
Mar 7 11:14:47 mve-server2 smbd[8195]: Error writing 5 bytes to
client. -1. (Connection reset by peer)
Mar 7 11:18:55 mve-server2 smbd[8244]: [2006/03/07 11:18:55, 0]
lib/util_sock.c:get_peer_addr(1222)
Mar 7 11:18:55 mve-server2 smbd[8244]: getpeername failed. Error was
Transport endpoint is not connected
Mar 7 11:18:55 mve-server2 smbd[8250]: [2006/03/07 11:18:55, 0]
lib/util_sock.c:get_peer_addr(1222)
Mar 7 11:18:55 mve-server2 smbd[8250]: getpeername failed. Error was
Transport endpoint is not connected
Mar 7 11:18:55 mve-server2 smbd[8250]: [2006/03/07 11:18:55, 0]
lib/util_sock.c:get_peer_addr(1222)
Mar 7 11:18:55 mve-server2 smbd[8250]: getpeername failed. Error was
Transport endpoint is not connected
Mar 7 11:18:55 mve-server2 smbd[8250]: [2006/03/07 11:18:55, 0]
lib/access.c:check_access(328)
Mar 7 11:18:55 mve-server2 smbd[8250]: [2006/03/07 11:18:55, 0]
lib/util_sock.c:get_peer_addr(1222)
Mar 7 11:18:55 mve-server2 smbd[8250]: getpeername failed. Error was
Transport endpoint is not connected
Mar 7 11:18:55 mve-server2 smbd[8250]: Denied connection from (0.0.0.0)
Mar 7 11:18:55 mve-server2 smbd[8250]: [2006/03/07 11:18:55, 0]
lib/util_sock.c:get_peer_addr(1222)
Mar 7 11:18:55 mve-server2 smbd[8250]: getpeername failed. Error was
Transport endpoint is not connected
Mar 7 11:18:55 mve-server2 smbd[8250]: Connection denied from 0.0.0.0
Mar 7 11:18:55 mve-server2 smbd[8250]: [2006/03/07 11:18:55, 0]
lib/util_sock.c:write_data(554)
Mar 7 11:18:55 mve-server2 smbd[8250]: write_data: write failure in
writing to client 0.0.0.0. Error Connection reset by peer
Mar 7 11:18:55 mve-server2 smbd[8250]: [2006/03/07 11:18:55, 0]
lib/util_sock.c:send_smb(762)
Mar 7 11:18:55 mve-server2 smbd[8250]: Error writing 5 bytes to
client. -1. (Connection reset by peer)
------------------------------------------------------------------------

After some search i put the following params into my smb.conf, but this
didn't help:
------------------------------------------------------------------------
use sendfile = no
large readwrite = no
max xmit = 16644
------------------------------------------------------------------------

Of course i will show you my complete smb.conf:
------------------------------------------------------------------------
[global]
workgroup = mve
socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
encrypt passwords = yes
unix extensions = yes
create mask = 0777
directory mask = 0777
username map = /etc/samba/smbusers
wins server = 172.20.6.104
wins support = no
domain logons = No
domain master = No
netbios name = mve-server
security = user
server string = mve-server
use sendfile = no
large readwrite = no
max xmit = 16644
hosts allow = 172.20. 192.


[mve]
path = /daten/mve-server
valid users = @mve, @mv
admin users = @mve
read list = @mve, @mv
write list = @mve
guest ok = No
read only = No
printable = No
browseable = Yes
------------------------------------------------------------------------

mve is the share that causes the problem. i never tested anotherone,
because of the fact that there is no other share .

I hope for any ideas,
Björn Mayer

--------------010202000805070701010604
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
To unsubscribe from this list go to the following URL and read the
instructions: https://lists.samba.org/mailman/listinfo/samba
--------------010202000805070701010604--