I am having issues getting my Windows clients (all WinXP) in a 2003 AD
domain to transparently authenticate to my Samba (version 3.0.10-1.4E.2)
server. I had this previously working before I changed the name of the
server. After changing the name of the server in smb.conf, I ran the
same init commands such as kinit, net ads join, and so on. I had also
deleted the previous computer object in AD, and a new object did appear
after the 'net ads join'. In WINS, the samba server is showing up with
the correct name, IP, and record types (x00, x03, x20).

=20

When clients try to hit the server via explorer (\\mysambaserver
), it pops up a dialog asking for the
user/pass. The user is specified as SAMBASERVER\username instead of the
default domain. Using Ethereal, I see the following sequence:

=20

1) Client requests DNS resolution and WINS resolution (x20 type
record) of sambaserver from domain controller (dns/wins server)

2) Domain controller responds with correct IP for both requests


3) Client establishes a successful TCP connection to TCP 445 on
the sambaserver

4) Client sends a Session request to sambaserver

5) Sambaserver sends back a Positive session response

6) Client sends a Negotiate Protocol Request to sambaserver

7) Sambaserver responds with a Negotiate Protocol Response. I
noticed in the response 'Primary Domain: MYDOMAIN' which is correct.
(turned spnego off to see this)

8) Client then sends a name query to the domain controller (wins
server) asking for the x1C (domain controller) record of sambaserver.

9) Wins server responds back with failure (correct response)

=20

If I change the login prompt to MYDOMAIN\username and enter my domain
password, the login is successful. The problem is apparent in Item 8.
Why is my client requesting the x1C (domain controller) record of my
samba server? What would cause it to think sambaserver is not a part of
the domain and thus not use the domain credentials?

=20

Here is the config for the server:

=20

-----------------------------------------------------------------------

=20

[global]

workgroup =3D MYDOMAIN

netbios name =3D sambaserver

server string =3D File Server (sambaserver)

=20

nt acl support =3D yes

map acl inherit =3D yes

obey pam restrictions =3D yes

winbind enum users =3D yes

winbind enum groups =3D yes

idmap uid =3D 16777216-33554431

idmap gid =3D 16777216-33554431

template shell =3D /bin/bash

template homedir =3D /home/%U

winbind use default domain =3D yes

=20

wins server =3D 192.168.0.200

=20

log file =3D /var/log/samba/%m.log

log level =3D 3

max log size =3D 100

security =3D ADS

realm =3D MYDOMAIN.COM

password server =3D dc.mydomain.com

=20

encrypt passwords =3D yes

socket options =3D TCP_NODELAY SO_RCVBUF=3D8192 SO_SNDBUF=3D8192

local master =3D no

domain master =3D no

preferred master =3D no

domain logons =3D no

name resolve order =3D wins host

dns proxy =3D no

-----------------------------------------------------------------------

=20

=20

Any help/insight would be appreciated.

=20

Thanks,

- Rob

--
To unsubscribe from this list go to the following URL and read the
instructions: https://lists.samba.org/mailman/listinfo/samba