[Samba] join ads -> Preauthentication failed - Samba

This is a discussion on [Samba] join ads -> Preauthentication failed - Samba ; Solaris 10 on sparc Samba version 3.0.25b (SUNWspro/bin/cc) kerberos from MIT Hi all, I'm trying to join a Active Directory Domain. kinit is working fine with any AD User. Join with a none-privileged user shout with - Failed to set ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: [Samba] join ads -> Preauthentication failed

  1. [Samba] join ads -> Preauthentication failed

    Solaris 10 on sparc

    Samba version 3.0.25b (SUNWspro/bin/cc)

    kerberos from MIT



    Hi all,



    I'm trying to join a Active Directory Domain.


    kinit is working fine with any AD User.



    Join with a none-privileged user shout with - Failed to set password for
    machine account (NT_STATUS_ACCESS_DENIED) -

    Great.


    Join with a Administrator user gives me :


    [2007/08/16 17:21:49, 0] libads/kerberos.c228)

    kerberos_kinit_password myuser@AD.PLOUF.NET failed: Preauthentication
    failed

    Failed to join domain: Logon failure



    Any help would be appreciated.



    Nicolas
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  2. Re: [Samba] join ads -> Preauthentication failed

    The same situation.

    There is open bug https://bugzilla.samba.org/show_bug.cgi?id=4863

    Seems krb5 support broken after samba 3.0.24


    with 3.0.24 krb5 works fine.


    >
    >
    > Join with a Administrator user gives me :
    >
    >
    > [2007/08/16 17:21:49, 0] libads/kerberos.c228)
    >
    > kerberos_kinit_password myuser@AD.PLOUF.NET failed: Preauthentication
    > failed
    >
    > Failed to join domain: Logon failure
    >
    >
    >
    > Any help would be appreciated.
    >
    >
    >
    > Nicolas



    --
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  3. Re: [Samba] join ads -> Preauthentication failed

    Many thanks Alexandr.
    Works perfectly with 3.0.24 .


    Next issue : zfs and ACL . May work in 3.0.25 with the correct module !
    I'll post on technical list.




    Nicolas
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  4. RE: [Samba] join ads -> Preauthentication failed

    I just had a look at that bug report and noticed the OS is Solaris. If you've got time to try it, I suspect you'll find you have two options that will make it work: 1) Set the password of the username you are using to join the domain to 8 characters or less 2) Just use the net command from samba 3.0.24 in conjunction with your 3.0.25 Samba.



    -----Original Message-----
    From: samba-bounces+tom=umsl.edu@lists.samba.org on behalf of Alexandr Miasnikov
    Sent: Fri 8/17/2007 5:15 AM
    To: Nicolas Dorfsman; samba@lists.samba.org
    Subject: Re: [Samba] join ads -> Preauthentication failed

    The same situation.

    There is open bug https://bugzilla.samba.org/show_bug.cgi?id=4863

    Seems krb5 support broken after samba 3.0.24


    with 3.0.24 krb5 works fine.


    >
    >
    > Join with a Administrator user gives me :
    >
    >
    > [2007/08/16 17:21:49, 0] libads/kerberos.c228)
    >
    > kerberos_kinit_password myuser@AD.PLOUF.NET failed: Preauthentication
    > failed
    >
    > Failed to join domain: Logon failure
    >
    >
    >
    > Any help would be appreciated.
    >
    >
    >
    > Nicolas



    --
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  5. Re: [Samba] join ads -> Preauthentication failed

    2007/8/20, Nicolas Dorfsman :
    > 2007/8/18, Schaefer Jr, Thomas R. :
    > > I just had a look at that bug report and noticed the OS is Solaris. If you've got time to try it, I suspect you'll find you have two options that will make it work: 1) Set the password of the username you are using to join the domain to 8 characters or less 2) Just use the net command from samba 3.0.24 in conjunction with your 3.0.25 Samba.

    >
    > I'm going to try. Could you explain your suspectation ? I'd like to
    > dig into source code....for now I don't whre to start !


    It works with a 8 characters password !
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  6. Re: [Samba] join ads -> Preauthentication failed

    Bug report updated with DC versions.

    2007/8/18, Schaefer Jr, Thomas R. :
    > I just had a look at that bug report and noticed the OS is Solaris. If you've got time to try it, I suspect you'll find you have two options that will make it work: 1) Set the password of the username you are using to join the domain to 8 characters or less 2) Just use the net command from samba 3.0.24 in conjunction with your 3.0.25 Samba.


    I'm going to try. Could you explain your suspectation ? I'd like to
    dig into source code....for now I don't whre to start !
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

+ Reply to Thread