[Samba] yet another wbinfo & getent problem - Samba

This is a discussion on [Samba] yet another wbinfo & getent problem - Samba ; Hello, I am running a RHEL5 server as a member in a NT4 domain. I am not using an AD. my nsswitch.conf and /etc/pam.d/{login,authconfig,samba} are configured accordingly. (auth-config in RHEL4 is now renamed to authconfig on RHEL5). My problem is ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: [Samba] yet another wbinfo & getent problem

  1. [Samba] yet another wbinfo & getent problem

    Hello,

    I am running a RHEL5 server as a member in a NT4 domain. I am not using
    an AD.

    my nsswitch.conf and /etc/pam.d/{login,authconfig,samba} are configured
    accordingly.
    (auth-config in RHEL4 is now renamed to authconfig on RHEL5).

    My problem is that wbinfo -u & wbinfo -g work fine, but getent passwd
    only returns local linux users;

    Also smbclient -L localhost -Uusers will only work anonymously...

    What could I be missing?

    Here are some of my configuration files.

    Regards,
    Pierig


    /etc/nsswitch.conf:

    passwd: files winbind
    shadow: files
    group: files winbind

    /etc/pam.d/authconfig:
    auth required /lib/security/pam_securetty.so
    auth required /lib/security/pam_nologin.so
    auth sufficient /lib/security/pam_winbind.so
    auth required /lib/security/pam_pwdb.so use_first_pass shadow
    nullok
    account required /lib/security/pam_winbind.so

    /etc/pam.d/login:

    auth required /lib/security/pam_securetty.so
    auth sufficient /lib/security/pam_winbind.so
    auth sufficient /lib/security/pam_unix.so use_first_pass
    auth required /lib/security/pam_stack.so service=system-auth
    auth required /lib/security/pam_nologin.so
    account sufficient /lib/security/pam_stack.so service=system-auth
    account sufficient /lib/security/pam_winbind.so
    password required /lib/security/pam_stack.so service=system-auth

    /etc/pam.d/samba:

    auth required /lib/security/pam_winbind.so
    auth required /lib/security/pam_pwdb.so nullok shadow
    account required /lib/security/pam_winbind.so
    account required /lib/security/pam_pwdb.so
    session required pam_stack.so service=system-auth
    password required pam_stack.so service=system-auth

    /etc/samba/smb.conf
    [global]
    unix charset = LOCALE
    workgroup = PARDIR
    security = DOMAIN
    #username map = /etc/samba/smbusers
    log level = 1
    syslog = 0
    log file = /var/log/samba/%m
    max log size = 0
    smb ports = 139
    name resolve order = wins bcast hosts
    #password server = *
    netbios name = SRV-SAMBA
    #printcap name = CUPS
    #inherit acl = yes
    #client schannel = no
    nt acl support = yes
    #map inherit acl = yess
    inherit owner = yes
    inherit permissions = yes
    local master = No
    os level = 33
    domain master = no
    preferred master = no
    wins server = 172.25.1.9
    idmap uid = 10000-20000
    idmap gid = 10000-20000



    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  2. Re: [Samba] yet another wbinfo & getent problem


    > My problem is that wbinfo -u & wbinfo -g work fine, but getent passwd
    > only returns local linux users;
    >

    Try setting 'winbind enum users = yes' and 'winbind enum groups = yes'
    in smb.conf
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  3. Re: [Samba] yet another wbinfo & getent problem

    Thanks for your answer,

    In fact release 3.0.23 of samba in RHEL5 is totally bugged and core
    dumps every 5 minutes or so.

    Upgrading to version 3.0.24 now works: wbinfo & getent have a normal
    behaviour.

    I now have another problem while migrating files with acls to the
    server, but that deserve a new subject on the mailing list.

    Regards.

    Pierig,


    Ryan Suarez wrote:
    >
    >> My problem is that wbinfo -u & wbinfo -g work fine, but getent passwd
    >> only returns local linux users;
    >>

    > Try setting 'winbind enum users = yes' and 'winbind enum groups = yes'
    > in smb.conf


    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

+ Reply to Thread