[Samba] WinXp - Samba - Solaris Connection issue - Samba

This is a discussion on [Samba] WinXp - Samba - Solaris Connection issue - Samba ; Folks: I have a strange issue that occurs when one of my XP Pro system tries to connect to a samba server (2.0.24) on either a Sparc Solaris 10 or Sparc Solaris 9 system. This is the output from log.smbd ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: [Samba] WinXp - Samba - Solaris Connection issue

  1. [Samba] WinXp - Samba - Solaris Connection issue

    Folks:

    I have a strange issue that occurs when one of my XP Pro system tries
    to connect to a samba server (2.0.24) on either a Sparc Solaris 10 or
    Sparc Solaris 9 system.

    This is the output from log.smbd when the problem XP Pro system tries
    to connect to the server:

    [2007/03/28 14:47:01, 0] lib/util_sock.c:get_peer_addr(1229)
    getpeername failed. Error was Invalid argument
    [2007/03/28 14:47:01, 0] lib/util_sock.c:set_socket_options(261)
    Failed to set socket option SO_KEEPALIVE (Error Invalid argument)
    [2007/03/28 14:47:01, 0] lib/util_sock.c:set_socket_options(261)
    Failed to set socket option TCP_NODELAY (Error Invalid argument)
    [2007/03/28 14:47:01, 0] lib/util_sock.c:get_peer_addr(1229)
    getpeername failed. Error was Invalid argument
    [2007/03/28 14:47:01, 0] lib/util_sock.c:read_data(534)
    read_data: read failure for 4 bytes to client 0.0.0.0 Error =
    Connection refused

    Please note:
    - all systems, XP Pro and Sun, are on the same subnet - same switch
    - other XP Pro boxes connect to the shares on this server just fine
    - on the problem XP Pro system when I try to use the "Add Network
    Place Wizard" the Sun system shows up in an "Other" catagory - not the
    domain listed in the smb.conf file
    - I have tried both "smb ports = 139" and "smb ports = 445" on the
    server to no avail - the problem XP box still can't connect to the
    shares.

    Frankly, I don't think it is the Samba server - rather I think it is
    something about how the XP Pro system is configured on the domain but
    since I don't control the domain I'm flying blind.

    Ideas?


    Thanks -


    Michael
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  2. Re: [Samba] WinXp - Samba - Solaris Connection issue

    Hi there,

    > [2007/03/28 14:47:01, 0] lib/util_sock.c:get_peer_addr(1229)
    > getpeername failed. Error was Invalid argument
    > [2007/03/28 14:47:01, 0] lib/util_sock.c:set_socket_options(261)
    > Failed to set socket option SO_KEEPALIVE (Error Invalid argument)
    > [2007/03/28 14:47:01, 0] lib/util_sock.c:set_socket_options(261)
    > Failed to set socket option TCP_NODELAY (Error Invalid argument)

    kick out your socket options or search for these entries in your conf
    SO_KEEPALIVE
    TCP_NODELAY
    and restart your samba daemons!

    Do you run a firewall on your boixes? Try to turn off.

    Configure wins and dns correctly.

    Please post you smb.conf, seems the biggest problem to me.

    Greetings

    sascha
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  3. Re: [Samba] WinXp - Samba - Solaris Connection issue


    I had the same issue.

    It turned out to be a problem with the permissions in the base directory for
    samba (/samba had 700 permissions, changing to 755 fixed immediately).

    The problem with the permissions occured due to zfs import - so cool, so
    close but not quite there ...

    Good luck.

    --
    View this message in context: http://www.nabble.com/WinXp---Samba-...html#a10135997
    Sent from the Samba - General mailing list archive at Nabble.com.

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

+ Reply to Thread