[Samba] Performance Problems in smbmount but not in smbclient - Samba

This is a discussion on [Samba] Performance Problems in smbmount but not in smbclient - Samba ; I have an OS X 10.4 Server machine that has abysmal performance when copying files to it over smbmount from a linux machine or through Finder on OS X but performs very well when copying files through smbclient from the ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: [Samba] Performance Problems in smbmount but not in smbclient

  1. [Samba] Performance Problems in smbmount but not in smbclient

    I have an OS X 10.4 Server machine that has abysmal performance when
    copying files to it over smbmount from a linux machine or through Finder
    on OS X but performs very well when copying files through smbclient from
    the same Linux and OS X machines. I have already tried the commonly
    suggested adjustment of net.inet.tcp.delayed_ack=0 and have not noticed
    a significant performance improvement. Through smbmount I am seeing
    about 2-3 megs up and 8 megs down, when I am in the upper 20s or lower
    30s/sec with smbclient.

    What could account for this performance discrepancy? Any ideas (even
    far-fetched ones) would be much appreciated.

    Sincerely,
    Rob J. Caskey

    smb: \Documents\> put big2.bin
    putting file big2.bin as \Documents\big2.bin (28113.6 kb/s) (average
    26200.3 kb/s)
    smb: \Documents\> exit
    root@rcaskey-desktop:~# dd if=/dev/zero of=/mnt/smb/bigfile.bin bs=1024
    count=100000
    100000+0 records in
    100000+0 records out
    102400000 bytes (102 MB) copied, 30.565 seconds, 3.4 MB/s


    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  2. Re: [Samba] Performance Problems in smbmount but not in smbclient

    On 13/04/07, Rob Caskey wrote:
    > I have an OS X 10.4 Server machine that has abysmal performance when
    > copying files to it over smbmount from a linux machine or through Finder
    > on OS X but performs very well when copying files through smbclient from
    > the same Linux and OS X machines. I have already tried the commonly
    > suggested adjustment of net.inet.tcp.delayed_ack=0 and have not noticed
    > a significant performance improvement. Through smbmount I am seeing
    > about 2-3 megs up and 8 megs down, when I am in the upper 20s or lower
    > 30s/sec with smbclient.
    >
    > What could account for this performance discrepancy?


    You are using 2 completely different SMB clients, which have different
    performance characteristics. Try using cifsfs on Linux - it's
    supported and reputed to have good performance.

    --
    James Peach | jorgar@gmail.com
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

+ Reply to Thread