This weekend upgraded a Solaris 9 system which has been using
samba-3.0.10 for a while without any problems to version 24 with patches
applied.

When Samba-3.0.10 is running, can browse to share as well as map it
without getting any prompts or failures. Under 3.0.24, get prompted for
username and password and still not allowed into share. User is on
Windows XP professional and AD server is Windows 2000 Server.

[global]
hide unreadable = Yes
workgroup = adtestnetbios
realm = adtest.com
security = ADS
encrypt passwords = yes
log level = 4
idmap uid = 10000-35000
idmap gid = 10000-35000
winbind enum users = yes
winbind enum groups = yes
template homedir = /u/%U
template shell = /bin/csh
winbind use default domain = yes
winbind cache time = 600
client schannel = no
username map = /usr/local/samba/lib/users.map

[u]
comment = Monarch's u directory
path = /u
public = no
create mask = 0660
read only = No
directory mask = 0770
browseable = Yes
force group = group
valid users = root,monarch,@"xyzusers"

[public]
comment = Monarch's public directory
public = no
path = /u/public
read only = No
create mask = 0660
directory mask = 0770
browseable = Yes
force group = group
valid users = root,monarch,@"xyzusers"

[user]
comment = User's home directory
path = /u/%U
writable = yes
public = no
create mask = 0660
directory mask = 0770
browseable = Yes
force group = group
valid users = root,monarch,@"xyzusers"

[stock]
comment = Monarch's stock directory
path = /u/stock
read only = no
public = no
create mask = 0660
directory mask = 0770
browseable = Yes
force group = group
valid users = root,monarch,@"xyzusers"
--
To unsubscribe from this list go to the following URL and read the
instructions: https://lists.samba.org/mailman/listinfo/samba