[Samba] error was re: disappearing printer drivers - Samba

This is a discussion on [Samba] error was re: disappearing printer drivers - Samba ; Hello, Adding to my previous msg, debug level 7 finally gave me some output. In my smbd.log i am seeing the following whenever i try to upload printer drivers: getpeername failed. error was transport endpoint is not connected I've looked ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: [Samba] error was re: disappearing printer drivers

  1. [Samba] error was re: disappearing printer drivers

    Hello,
    Adding to my previous msg, debug level 7 finally gave me some output. In
    my smbd.log i am seeing the following whenever i try to upload printer
    drivers:

    getpeername failed. error was transport endpoint is not connected

    I've looked in to other methods of doing this, imprints doesn't seem to be
    supported, cupsaddsmb won't work with vendor supplied drivers, and to date i
    haven't been brave enough to try out rpcclient, i'm not sure of the syntax
    and have concerns about the case of these drivers. So, i need to get this
    working. If anyone has seen this error i'd appreciate any suggestions.
    Thanks.
    Dave.

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  2. Re: ham,[Samba] error was re: disappearing printer drivers

    Dave,

    See if either of these two links are able to help you:

    http://readlist.com/lists/lists.samb...ba/0/1622.html
    http://blog.aplpi.com/

    Good luck,

    Dale

    Dave wrote:
    > Hello,
    > Adding to my previous msg, debug level 7 finally gave me some
    > output. In my smbd.log i am seeing the following whenever i try to
    > upload printer drivers:
    >
    > getpeername failed. error was transport endpoint is not connected
    >
    > I've looked in to other methods of doing this, imprints doesn't seem
    > to be supported, cupsaddsmb won't work with vendor supplied drivers,
    > and to date i haven't been brave enough to try out rpcclient, i'm not
    > sure of the syntax and have concerns about the case of these drivers.
    > So, i need to get this working. If anyone has seen this error i'd
    > appreciate any suggestions.
    > Thanks.
    > Dave.

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  3. Re: [Samba] error was re: disappearing printer drivers

    On Friday 30 March 2007, Dave wrote:
    > I've looked in to other methods of doing this, imprints doesn't seem to be
    > supported, cupsaddsmb won't work with vendor supplied drivers, and to date
    > i haven't been brave enough to try out rpcclient, i'm not sure of the
    > syntax and have concerns about the case of these drivers. So, i need to get
    > this working. If anyone has seen this error i'd appreciate any suggestions.


    To install vendor supplied Windows drivers from Windows clients using cups and
    samba create a raw queue in cups for the printer, reload samba so that it is
    aware of the printer. Make sure that "use client driver" is the default value
    of "no" (testparm -sv | grep 'use client'). Then carefully follow the
    instructions in the classical print section of the howto (yes, works just
    fine for cups):
    http://us1.samba.org/samba/docs/man/....html#id358732

    If you have the proper rights all should be fine.

    Chris
    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

  4. Re: [Samba] error was re: disappearing printer drivers

    Hello,
    My thanks to everyone so far who have offered suggestions. I have made a
    second print queue in cups, this time a raw queue, ensured that the samba
    user who is adding the drivers from the windows box has the permissions to
    do so, and tried using the apw to again add drivers. This time i'm getting
    some errors although the files aren't going, it's like they're again
    disappearing. I'm getting some service connect errors and am not sure if
    they're even relevant to the issue. Any other suggestions please keep them
    coming. Errors below.
    Thanks.
    Dave.

    [2007/03/30 17:49:12, 1] param/loadparm.c:lp_do_parameter(3426)
    WARNING: The "printer admin" option is deprecated
    [2007/03/30 17:50:14, 1] smbd/ipc.c:api_fd_reply(290)
    api_fd_reply: INVALID PIPE HANDLE: 706c
    [2007/03/30 17:50:22, 0] smbd/service.c:make_connection(1111)
    satellite (192.168.0.2) couldn't find service
    ::{2227a280-3aea-1069-a2de-08002b30309d}

    --
    To unsubscribe from this list go to the following URL and read the
    instructions: https://lists.samba.org/mailman/listinfo/samba

+ Reply to Thread