Does anyone happened to have a "WRT54GC" that is running through the
same problems I'm having?
Just to let all to know, I did update the firmware prior to doing this.


Alright, here's my issue(s) I just happened to replace my old linksys
router, for this router. So when I go through my "Applications &
Gaming" : "Port Range Forwarding", I'll begin by typing and selecting
all the service, port, Protocol, IP, and I would Click "Save Settings".

All has gone well, it saved the settings as is. Now for the harsh
part, I begin to check what I currently want to enable and save its
settings, I am only able to come across saving 4 applications,
anything after that it wouldn't let me save. Saving as in, when I
check the 5th or 6th application, and go ahead and click "Save
settings" the browser and its status bar all of a sudden only go up to
about "20-40%" then it eithers gets an "Action Canceled" or "Timeout"
or it goes back to popping up asking the router's password, but if it
asked that and I type in the password, it just goes back to what I had
previously saved. I've tried this on different browsers already
also(IE, Mozilla Suite, Mozilla Firefox, Opera, Netscape) , and
different client computer, wired and wireless. I also went back to
resetting my router, to default and factory settings, and did
everything all over again. All came out the same.

This problem is also on the "Assign Static DHCP" which is also
similar, after creating the list of Clients and its IP and MAC address,
and saving it, it is ok, but after trying to enable and saving it, it
wouldn't save, it gets the "timeout" etc. situations.

I've done networking and never had any problems with linksys, and all
of a sudden this one I run into just stumps me.

Sorry, for the long information, but hopes that is enough information
for one to solve.

~Thanks Dave