RPM question - Redhat

This is a discussion on RPM question - Redhat ; I'm trying to install Oracle 10g Enterprise server on a Power series RHEL 4 system. The installation guide says I need, libgcc-3.4.3-9.EL4 libgcc-3.4.3-9.EL4.ppc64.rpm libstdc++-3.4.3-9.EL4 libstdc++-devel-3.4.3-9.EL4 but I already have later versions installed and these version don't have a 'EL4': libgcc-3.4.6-10 ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: RPM question

  1. RPM question

    I'm trying to install Oracle 10g Enterprise server on a Power series
    RHEL 4 system. The installation guide says I need,

    libgcc-3.4.3-9.EL4
    libgcc-3.4.3-9.EL4.ppc64.rpm
    libstdc++-3.4.3-9.EL4
    libstdc++-devel-3.4.3-9.EL4

    but I already have later versions installed and these version don't
    have a 'EL4':

    libgcc-3.4.6-10
    libgcc-3.4.6-10
    libstdc++-3.4.6-10
    libstdc++-devel-3.4.6-10

    If I try to install the older 'EL4' packages I get the error below and
    I can't remove the newer libgcc and libstdc++ packages because most of
    the other packages installed depend on these versions. How can I
    resolve this?

    # rpm -ivh libgcc-3.4.3-9.EL4.ppc.rpm
    Preparing...
    ########################################### [100%]
    package libgcc-3.4.6-10 (which is newer than
    libgcc-3.4.3-9.EL4) is already installed
    file /lib/libgcc_s.so.1 from install of libgcc-3.4.3-9.EL4
    conflicts with file from package libgcc-3.4.6-10
    file /usr/sbin/libgcc_post_upgrade from install of
    libgcc-3.4.3-9.EL4 conflicts with file from package libgcc-3.4.6-10

  2. Re: RPM question

    jim wrote:
    > I'm trying to install Oracle 10g Enterprise server on a Power series
    > RHEL 4 system. The installation guide says I need,
    >
    > libgcc-3.4.3-9.EL4
    > libgcc-3.4.3-9.EL4.ppc64.rpm
    > libstdc++-3.4.3-9.EL4
    > libstdc++-devel-3.4.3-9.EL4
    >
    > but I already have later versions installed and these version don't
    > have a 'EL4':
    >
    > libgcc-3.4.6-10
    > libgcc-3.4.6-10
    > libstdc++-3.4.6-10
    > libstdc++-devel-3.4.6-10
    >
    > If I try to install the older 'EL4' packages I get the error below and
    > I can't remove the newer libgcc and libstdc++ packages because most of
    > the other packages installed depend on these versions. How can I
    > resolve this?
    >
    > # rpm -ivh libgcc-3.4.3-9.EL4.ppc.rpm
    > Preparing...
    > ########################################### [100%]
    > package libgcc-3.4.6-10 (which is newer than
    > libgcc-3.4.3-9.EL4) is already installed
    > file /lib/libgcc_s.so.1 from install of libgcc-3.4.3-9.EL4
    > conflicts with file from package libgcc-3.4.6-10
    > file /usr/sbin/libgcc_post_upgrade from install of
    > libgcc-3.4.3-9.EL4 conflicts with file from package libgcc-3.4.6-10


    If you really need these *particular* versions, you need to use 'rpm -U
    libgcc-3.4.3-9.EL4.ppc.rpm --oldpackage', and resolve any additional package
    dependencies. Then you'll need to tweak your yum or up2date settings to
    prevent updating those packages.

+ Reply to Thread